Page MenuHomePureOS Tracker
Feed All Stories

Jan 13 2021

drs added a comment to T778: Calamares Installer: Manual partitioning, unable to create LVs on VG on LUKS. Unable to install to existing LUKS volume or alongside existing LVs on LUKS..

related issues in the upstream issue tracker: https://github.com/calamares/calamares/issues?q=is:issue+is:open+lvm+label:"N+lvm2"

Jan 13 2021, 12:50 · Restricted Project
jeremiahmoree added a comment to T752: PureOS Installer - Partitions - Manual partitioning - Issues.

I just tried to delete the partitions and let the installer create them. It still does not ask for a LUKS passphrase and crashes. I also tried manually setting up partitions, LUKS, LVM and various combinations before running the installer. I don't know how I got this to work before but it always crashes now. Seems that PureOS no longer likes me (it was a difficult relationship to begin with).

Jan 13 2021, 05:52 · Restricted Project
Garryhoward updated Garryhoward.
Jan 13 2021, 00:00

Jan 12 2021

Garryhoward updated Garryhoward.
Jan 12 2021, 23:55
jeremiahmoree added a comment to T752: PureOS Installer - Partitions - Manual partitioning - Issues.

I just ran into this issue. I have installed PureOS with encrypted root before and dont remember allowing it to create the partitions but it seems that way based on reading this. I would prefer not to delete the partitions every time I have to re-install (with PureOS is about every 6 months).

Jan 12 2021, 06:50 · Restricted Project

Jan 11 2021

joao.azevedo edited the content of Mobile-optimized apps.
Jan 11 2021, 06:40
joao.azevedo edited the content of Mobile-optimized apps.
Jan 11 2021, 06:37
joao.azevedo edited the content of Mobile-optimized apps from 3rd party repos.
Jan 11 2021, 06:35

Jan 5 2021

mak added a comment to T945: Please help me delete my PureOS Tracker account.

Has this been done? I think only sysadmins have the necessary privileges to destroy a user account, all I can do is disable them.

Jan 5 2021, 17:54
mak added a comment to T978: Confirm whether "Software & Upgrades" portion of GNOME Software can control unattended-upgrades settings.

Then this should have worked - they should verify that /etc/apt/apt.conf.d/20auto-upgrades exists and has the correct values.

Jan 5 2021, 08:28 · Restricted Project, Restricted Project
jeremiah.foster added a comment to T978: Confirm whether "Software & Upgrades" portion of GNOME Software can control unattended-upgrades settings.
In T978#17857, @mak wrote:

the issue is the "Software & Updates > Updates > Automatically check for updates: Never" configuration is not preventing the system from automatically checking for updates every day.

they have to do that *and* disable updates in GNOME: "GNOME Software" > "Burger Menu" > "Update Preferences" > Toggle Automatic Updates
(as shown in the image I posted above)

Jan 5 2021, 07:42 · Restricted Project, Restricted Project
Jacobliam updated Jacobliam.
Jan 5 2021, 05:32

Jan 4 2021

mak added a comment to T978: Confirm whether "Software & Upgrades" portion of GNOME Software can control unattended-upgrades settings.

the issue is the "Software & Updates > Updates > Automatically check for updates: Never" configuration is not preventing the system from automatically checking for updates every day.

Jan 4 2021, 16:28 · Restricted Project, Restricted Project
jeremiah.foster added a comment to T978: Confirm whether "Software & Upgrades" portion of GNOME Software can control unattended-upgrades settings.

The Original Poster is stating that their use case is customers at sea who have expensive connection charges which require they disable unnecessary network communication.

Jan 4 2021, 15:55 · Restricted Project, Restricted Project
jeremiah.foster added a comment to T978: Confirm whether "Software & Upgrades" portion of GNOME Software can control unattended-upgrades settings.

The user writes back saying that they disabled GNOME Software and was unable to stop automatic upgrades. There is no effect of the GNOME Software settings observed. I think the next step on my side is to run strace on GNOME Software and settings to see what is happening (or not happening).

Jan 4 2021, 15:53 · Restricted Project, Restricted Project
6745xyx created T982: After login plasma not entry.
Jan 4 2021, 01:55 · Restricted Project

Jan 3 2021

rickypauls updated rickypauls.
Jan 3 2021, 23:51

Jan 1 2021

Programmin created T981: Packaging Repeater-START.
Jan 1 2021, 13:33

Dec 31 2020

robinwilson updated robinwilson.
Dec 31 2020, 03:26

Dec 30 2020

mak added a comment to T978: Confirm whether "Software & Upgrades" portion of GNOME Software can control unattended-upgrades settings.

No, disabling the timers is completely the wrong approach. The service belonging to the timer unit has built-in logic to do only what it was configured to do + some cleanup work that we always want to have done.
All you need to do to disable upgrades is to disable them in GNOME Software as well as in software-sources-gtk which is available in GNOME Software's burger-menu as well.
See the attached picture:

Dec 30 2020, 19:11 · Restricted Project, Restricted Project
jeremiah.foster triaged T958: Package Blanket for the Librem 5 as Normal priority.
Dec 30 2020, 18:21 · Restricted Project
jeremiah.foster added a comment to T978: Confirm whether "Software & Upgrades" portion of GNOME Software can control unattended-upgrades settings.

It appears that one *cannot* shut off updates with GNOME Software despite the settings that would imply that this is possible. What needs to be address is apt-daily-upgrade.timer. systemctl status apt-daily-upgrade.timer says;

● apt-daily-upgrade.timer - Daily apt upgrade and clean activities
     Loaded: loaded (/lib/systemd/system/apt-daily-upgrade.timer; enabled; vendor preset: enabled)
     Active: active (waiting) since Fri 2020-12-11 10:07:48 EST; 2 weeks 5 days ago
    Trigger: Thu 2020-12-31 06:28:21 EST; 10h left
   Triggers: ● apt-daily-upgrade.service

This can be disabled which ought to turn off automatic updates. Stop the timer and disable this way;

sudo systemctl stop apt-daily-upgrade.timer
sudo systemctl disable apt-daily-upgrade.timer
Dec 30 2020, 17:11 · Restricted Project, Restricted Project
gisellekenneth updated gisellekenneth.
Dec 30 2020, 03:18

Dec 29 2020

gusnan added a comment to T958: Package Blanket for the Librem 5.

I am working on getting this into Debian - There's already a Ubuntu PPA, whos maintainer I have mailed and asked if they are interested in maintaining it in Debian - If they are not, I'll ITP it, and maintain it myself.

Dec 29 2020, 11:59 · Restricted Project
Wildfire added a comment to T403: Installation process: guidelines for a two-disk system.

I am in the same boat. My Lib15v4 Secure Boot. I thought came out of the box preconfigured with dual drives that I spec'd when I placed my order. I would like to make sure that both drives are properly encrypted.

Dec 29 2020, 10:59 · Restricted Project, Restricted Project
Wildfire added a comment to Change Disk Encryption Password.

luks cryptsetup- trying to change encrypt pw
I see the warning, about using GNOME Disks to change the pw. I went to the link https://tracker.pureos.net/T541, and checked for updates to the string. Seems that mladen posted an update back in June 2020 that this issue was resolved. "Debian bug report: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=928893 indicates that this has been fixed."
We are now headed in Jan 2021, can anyone confirm this to be true? I would prefer not to be the "ginny pig".
I tried the terminal route first and ran into some issues and did not work out as described above. My drives are set up differently, I have two drives in this machine and not listed as sda's.
Before I dove down that rabbit hole, I figured I would revisit using GNOME Disks, as it would be far easier, if its safe.
I don't have a virtual machine set up yet to test it out on.
Feedback please.
12-30-20 update- used the GNOME Disks and reset the passphrase with no issues.

Dec 29 2020, 10:39
joshuadollar updated joshuadollar.
Dec 29 2020, 04:10

Dec 23 2020

jeremiah.foster edited the content of PureOS Archive Layout.
Dec 23 2020, 13:53
jonas.smedegaard added a comment to T980: Firefox ESR implements Encrypted Media Extensions (EME).

I reported this issue on my own (not driven by reports of others but from my prior knowledge in maintaining PureBrowser and therefore pretty exactly knowing how they differ).

Dec 23 2020, 13:23 · Freedom-harm: downloads nonfree code
jeremiah.foster added a comment to T980: Firefox ESR implements Encrypted Media Extensions (EME).

The plan that was devised consists of two steps;

Dec 23 2020, 13:04 · Freedom-harm: downloads nonfree code
jeremiah.foster added a comment to T980: Firefox ESR implements Encrypted Media Extensions (EME).

@jonas.smedegaard Did a user report this? Or is this bug from your own sleuthing? :-) I ask because sometimes the FSF rewards users who report freedom issues with GNU Bucks and there may be some at stake for reporting.

Dec 23 2020, 12:54 · Freedom-harm: downloads nonfree code
jeremiah.foster renamed T978: Confirm whether "Software & Upgrades" portion of GNOME Software can control unattended-upgrades settings from Remove unattended upgrades from PureOS default base packages to Confirm whether "Software & Upgrades" portion of GNOME Software can control unattended-upgrades settings.
Dec 23 2020, 10:05 · Restricted Project, Restricted Project

Dec 22 2020

Wayne added a comment to T979: python-libxml2 is missing from amber repository.

BTW, though I do not know what caused this, I am glad it happened. I had 86 updates awaiting that I never knew about.

Dec 22 2020, 11:42
jeremiah.foster added a comment to T979: python-libxml2 is missing from amber repository.

Glad you tracked down the issue! Nice sleuthing!

Dec 22 2020, 11:41
Wayne closed T979: python-libxml2 is missing from amber repository as Resolved.

I was finally able to make this work by erasing repo.puri.sm_pureos_dists_amber_main_binary-amd64_Packages in /var/lib/apt/lists and then doing the 'apt update.' I am not sure why this did not work by simply doing apt update, but it seems to have gotten stuck somehow.

Dec 22 2020, 11:05
joao.azevedo edited the content of Mobile-optimized apps from 3rd party repos.
Dec 22 2020, 07:14
joao.azevedo edited the content of Mobile-optimized apps from 3rd party repos.
Dec 22 2020, 07:13
joao.azevedo edited the content of Mobile-optimized apps.
Dec 22 2020, 07:01
joao.azevedo edited the content of Mobile-optimized apps.
Dec 22 2020, 06:59
joao.azevedo edited the content of Mobile-optimized apps from 3rd party repos.
Dec 22 2020, 06:55
todd added a comment to T980: Firefox ESR implements Encrypted Media Extensions (EME).

This is important as we do not want to implement any browser prompt to install an EME plugin.

Dec 22 2020, 05:59 · Freedom-harm: downloads nonfree code
Wayne added a comment to T979: python-libxml2 is missing from amber repository.

Jeremiah, you were correct. There is a difference in versions, but I do not know why my apt database has a different one, i.e. python-libxml2_2.9.4+dfsg1-7+b3_amd64.deb. I tried to purge it and get the new listing, but to no avail.

Dec 22 2020, 03:23

Dec 21 2020

jonas.smedegaard triaged T980: Firefox ESR implements Encrypted Media Extensions (EME) as Freedom Issue priority.
Dec 21 2020, 17:42 · Freedom-harm: downloads nonfree code
Wayne added a comment to T979: python-libxml2 is missing from amber repository.

As I mentioned in my initial post, I already tried the 'update' and the --fix-missing, so your commands yield the same errors as I have mentioned before. Have you checked that the file is actually on repo.puri.sm?

Dec 21 2020, 09:33
jeremiah.foster added a comment to T979: python-libxml2 is missing from amber repository.

What does sudo apt-update && sudo apt install python-libxml2 say?

Dec 21 2020, 09:06
alvesadrian added a comment to T963: Package Tootle for the Librem 5.

@jeremiah.foster Yes, that repo is pulled from Debian. We are good to go with that one.

Dec 21 2020, 09:05 · Restricted Project
jeremiah.foster added a comment to T963: Package Tootle for the Librem 5.

Let's pull tootle in from Debian. If there's a flatpak or package that we need in Debian then we should just default to using that.

Dec 21 2020, 09:01 · Restricted Project

Dec 20 2020

alvesadrian added a comment to T963: Package Tootle for the Librem 5.

@jeremiah.foster this on is up to date, https://source.puri.sm/librem5-apps/tootle

Dec 20 2020, 13:42 · Restricted Project
alvesadrian added a comment to T848: Package Shortwave for the Librem 5.

@jeremiah.foster I can't build Flatpaks inside of the bizantium-arm64 docker image because of this,
"Running in qemu-user, not using seccomp"
I can only build flatpaks over Intel since I don't have the right hardware to do it.

Dec 20 2020, 12:38 · Restricted Project
alvesadrian added a comment to T848: Package Shortwave for the Librem 5.

@jeremiah.foster created a repo https://source.puri.sm/librem5-apps/shortwave and pushed the flatpak built into our SLAT server, inside of /home/adrian/flatpak/shortwave/app, there is where the flatpak build it is

Dec 20 2020, 11:17 · Restricted Project
alvesadrian added a comment to T963: Package Tootle for the Librem 5.

@jeremiah.foster our version is the same as salsa I think this one is already completed

Dec 20 2020, 09:16 · Restricted Project
alvesadrian updated subscribers of T963: Package Tootle for the Librem 5.

@jeremiah.foster debian has the latest version on unstable for this one, we should build it anyway or use the one at debian?

Dec 20 2020, 09:11 · Restricted Project

Dec 18 2020

Wayne added a comment to T979: python-libxml2 is missing from amber repository.

No. The package does not appear to be in the actual repos (repo.puri.sm), even though 'apt' and your link say it should be there.

Dec 18 2020, 12:18
jeremiah.foster added a comment to T979: python-libxml2 is missing from amber repository.

But the issue is not that you can't see it in the repos - just that it won't install on your machine, right?

Dec 18 2020, 11:35
jeremiah.foster added a comment to T848: Package Shortwave for the Librem 5.

No, please complete or report here if you are having issues.

Dec 18 2020, 11:33 · Restricted Project
alvesadrian added a comment to T848: Package Shortwave for the Librem 5.

@jeremiah.foster Yes, I should stop?

Dec 18 2020, 08:29 · Restricted Project
Wayne added a comment to T979: python-libxml2 is missing from amber repository.

This is what I see for that command:

Dec 18 2020, 04:11
kaylee402 updated kaylee402.
Dec 18 2020, 03:28

Dec 17 2020

jeremiah.foster added a comment to T979: python-libxml2 is missing from amber repository.

Amber is Buster, yes.

Dec 17 2020, 16:36
Wayne added a comment to T979: python-libxml2 is missing from amber repository.

Thanks. I understand there is a transition here. I will close this, but

Dec 17 2020, 11:37
jeremiah.foster claimed T973: Package Markets for the Librem 5.
Dec 17 2020, 10:50 · Restricted Project
jeremiah.foster added a comment to T979: python-libxml2 is missing from amber repository.

This may be caught in a transition from python2.7 to python3 in Debian. python2.7 is approaching end of life and will be deprecated soon. I see that libxml2 is support with another library for python3;

python3-lxml - pythonic binding for the libxml2 and libxslt libraries

It may be that the chirp application has not yet updated their python dependencies.

Dec 17 2020, 10:46
jeremiah.foster triaged T979: python-libxml2 is missing from amber repository as Normal priority.
Dec 17 2020, 10:42
jeremiah.foster added a comment to T848: Package Shortwave for the Librem 5.

@alvesadrian Have you started on this one yet?

Dec 17 2020, 10:41 · Restricted Project

Dec 14 2020

Wayne created T979: python-libxml2 is missing from amber repository.
Dec 14 2020, 13:05

Dec 12 2020

FaiscaOS added a comment to T943: WiFi adapter not found.

Good morning, i have installed Linux PureOS in pc but the WiFi icon does not exist on PureOS, it said that 'WiFi adapter not found. I have a High Gain Wireless Usb adapter TP-LINK, TL-WN722N, V1.10. I´ m new in Linux. Please help me.

Dec 12 2020, 08:15 · Librem BIOS

Dec 10 2020

jeremiah.foster triaged T975: Iceweasel showing in PureOS Store rather than Firefox as High priority.
Dec 10 2020, 11:03
jeremiah.foster triaged T978: Confirm whether "Software & Upgrades" portion of GNOME Software can control unattended-upgrades settings as Normal priority.
Dec 10 2020, 11:02 · Restricted Project, Restricted Project
jeremiah.foster added a comment to T978: Confirm whether "Software & Upgrades" portion of GNOME Software can control unattended-upgrades settings.

I agree with Matthias here - having updates on by default brings security fixes quickly and is something that many folks now have come to expect. Much better to request that users opt out of secure default settings. This comports with Todd's stated policy of "smart defaults".

Dec 10 2020, 11:02 · Restricted Project, Restricted Project
jeremiah.foster triaged T920: BIOS Does Not "See" Correctly Created LiveUSB as Normal priority.
Dec 10 2020, 11:00
jeremiah.foster added a comment to T957: Package Shortwave for the Librem 5.

closing as a duplicate

Dec 10 2020, 10:58 · Restricted Project
jeremiah.foster closed T957: Package Shortwave for the Librem 5 as Resolved.
Dec 10 2020, 10:58 · Restricted Project
jeremiah.foster assigned T848: Package Shortwave for the Librem 5 to alvesadrian.
Dec 10 2020, 10:57 · Restricted Project
jeremiah.foster added a comment to T957: Package Shortwave for the Librem 5.

Plan is to package as flatpak.

Dec 10 2020, 10:57 · Restricted Project
jeremiah.foster assigned T957: Package Shortwave for the Librem 5 to alvesadrian.
Dec 10 2020, 10:56 · Restricted Project

Dec 7 2020

mak changed the status of T978: Confirm whether "Software & Upgrades" portion of GNOME Software can control unattended-upgrades settings from Open to Incomplete.

Why? We want the users to stay secure by default, and disabling automatic upgrades is the opposite of that. So I think disabling updates is a huge disservice and definitely not beginner-friendly. Users who want to disable autoupdates can always do that via the respective GUI (software-properties-gtk).

Dec 7 2020, 13:01 · Restricted Project, Restricted Project
joao.azevedo updated subscribers of T978: Confirm whether "Software & Upgrades" portion of GNOME Software can control unattended-upgrades settings.

@mak ping! This is the issue ticket about unattended upgrades

Dec 7 2020, 12:52 · Restricted Project, Restricted Project
joao.azevedo created T978: Confirm whether "Software & Upgrades" portion of GNOME Software can control unattended-upgrades settings.
Dec 7 2020, 12:49 · Restricted Project, Restricted Project

Dec 6 2020

mjbecze awarded T23: PureOS 3 + Librem13 = NO BlueTooth a Yellow Medal token.
Dec 6 2020, 10:35

Dec 1 2020

jeremiah.foster closed T961: Create aarch64 container images for Librem 5 development as Resolved.
Dec 1 2020, 09:05 · Restricted Project
jeremiah.foster added a comment to T961: Create aarch64 container images for Librem 5 development.

Available https://hub.docker.com/repository/docker/pureos/byzantium-arm64

Dec 1 2020, 09:04 · Restricted Project
jeremiah.foster assigned T963: Package Tootle for the Librem 5 to alvesadrian.
Dec 1 2020, 08:24 · Restricted Project

Nov 30 2020

jeremiah.foster added a comment to T974: gnome-software fails to install FreeCAD.

Ah, okay. That is a good catch, I've never seen that behavior before. I'll have to investigate and it may be a bug in GNOME-SOFTWARE, or, as you point out, it may be in the packaging.

Nov 30 2020, 17:43
Dwaff added a comment to T974: gnome-software fails to install FreeCAD.

I can install freecad via the command line. apt-get install freecad gives a functional installation. Clicking install button in gnome-software results in only freecad-common package being installed, which is not enough to run freecad.

Nov 30 2020, 17:42
jeremiah.foster triaged T974: gnome-software fails to install FreeCAD as Normal priority.
Nov 30 2020, 17:37
jeremiah.foster added a comment to T974: gnome-software fails to install FreeCAD.

Thanks for filing the bug. I'm not sure of the issue - can you install freecad via the command line?

Nov 30 2020, 17:37
jeremiah.foster closed T960: Byzantium on the mini reports 404s for certain packages as Resolved.
Nov 30 2020, 17:34
jeremiah.foster added a comment to T960: Byzantium on the mini reports 404s for certain packages.

Removing the contents of /var/lib/apt/lists removes out of date files. Re-running apt update brings in new Release file and one can download all packages again.

Nov 30 2020, 17:34
jeremiah.foster added a comment to T960: Byzantium on the mini reports 404s for certain packages.

I can reproduce on the L13;

Nov 30 2020, 08:26
jeremiah.foster added a comment to T960: Byzantium on the mini reports 404s for certain packages.

Cannot reproduce on my mini running byzantium.

Nov 30 2020, 08:26

Nov 28 2020

mladen edited the content of Mobile-optimized apps from 3rd party repos.
Nov 28 2020, 13:16
mladen added a comment to PureOS Frequently Asked Questions FAQ.

Thanks, corrected.

Nov 28 2020, 13:11
mladen edited the content of PureOS Frequently Asked Questions FAQ.
Nov 28 2020, 13:11

Nov 27 2020

jeremiah.foster added a comment to T876: youtube-dl out-of-date and non-functional - fast track newer package into Amber.

@joao.azevedo I'll have to update and/or repackage youtube-dl ASAP.

Nov 27 2020, 17:12
nochelibre added a comment to PureOS Frequently Asked Questions FAQ.

Hi mladen,

Nov 27 2020, 01:51
joao.azevedo added a comment to T876: youtube-dl out-of-date and non-functional - fast track newer package into Amber.

@jeremiah.foster youtube-dl_2020.09.14 is no longer functional with YouTube.

Nov 27 2020, 01:09

Nov 26 2020

mak closed T976: PureOS Store showing duplicates as Resolved.
Nov 26 2020, 10:37
guido added a comment to T976: PureOS Store showing duplicates.

yes, that is fixed in the recent upload and a tagged version is uploaded to amber-phone-staging.

Nov 26 2020, 10:30
mak updated subscribers of T976: PureOS Store showing duplicates.

I think @adrien.plazas pushed a workaround for this recently: https://source.puri.sm/Librem5/pureos-store/-/merge_requests/14

Nov 26 2020, 10:28
alvesadrian updated subscribers of T975: Iceweasel showing in PureOS Store rather than Firefox.

it looks like a metadata repo issue, we should update the repos. @theodotos.andreou

Nov 26 2020, 08:45