Page MenuHomePureOS Tracker

PureOS Installer - Partitions - Manual partitioning - Issues
Open, HighPublic


  1. Selecting an existing LUKS partition for the / (root) mount point doesn't allow to provide an encryption password. Neither for the "Keep" nor for the "Format" option. The installation will later crash without an error.
  2. Selecting an existing partition in combination with the "Format" option allows to select "luks" as the "File System" which doesn't make sense and causes the installation to crash later on. Because the user can't provide an encryption password nor specify the actual filesystem (e.g. ext4) to be used within the luks container. Therefore this option doesn't make sense at all and should not be available in the "File System" dropdown.
  3. Selecting an existing partition in combination with the "Format" option doesn't allow to setup encryption for the root mount point or swap partition. The "Encrypt" checkbox is only available when you create a new partition but is missing when you want to format or reuse an existing partition.
  4. If you "Edit" a to-be-created encrypted LUKS partition again, you can't change the LUKS password anymore and the installation will later on crash. (I guess the previously setup encryption password is lost when you hit the edit button for a partition again.)

Event Timeline

pruflyos created this task.Apr 24 2019, 05:27
pruflyos updated the task description. (Show Details)
jeremiah.foster triaged this task as High priority.Apr 24 2019, 08:41

I just ran into this issue. I have installed PureOS with encrypted root before and dont remember allowing it to create the partitions but it seems that way based on reading this. I would prefer not to delete the partitions every time I have to re-install (with PureOS is about every 6 months).

I just tried to delete the partitions and let the installer create them. It still does not ask for a LUKS passphrase and crashes. I also tried manually setting up partitions, LUKS, LVM and various combinations before running the installer. I don't know how I got this to work before but it always crashes now. Seems that PureOS no longer likes me (it was a difficult relationship to begin with).

drs added a subscriber: drs.Jan 13 2021, 12:52