Page MenuHomePureOS Tracker

Byzantium on the mini reports 404s for certain packages
Closed, ResolvedPublic

Description

I tried to update the system and install some software:

sudo apt update
sudo apt-upgrade
gives a lot of 404s - here some examples:
E: Fehlschlag beim Holen von
https://repo.pureos.net/pureos/pool/main/libg/libgphoto2/libgphoto2-l10n_2.5.26-1_all.deb
404 Not Found [IP: 138.201.228.45 443]
E: Fehlschlag beim Holen von
https://repo.pureos.net/pureos/pool/main/v/vde2/libvdeplug2_2.3.2+r586-7_amd64.deb
404 Not Found [IP: 138.201.228.45 443]
E: Fehlschlag beim Holen von
https://repo.pureos.net/pureos/pool/main/o/openvpn/openvpn_2.5~rc2-1_amd64.deb
404 Not Found [IP: 138.201.228.45 443]
E: Fehlschlag beim Holen von
https://repo.pureos.net/pureos/pool/main/p/pyyaml/python3-yaml_5.3.1-2+b1_amd64.deb
404 Not Found [IP: 138.201.228.45 443]
E: Fehlschlag beim Holen von
https://repo.pureos.net/pureos/pool/main/a/apparmor/apparmor_2.13.4-3+b1_amd64.deb
404 Not Found [IP: 138.201.228.45 443]

Event Timeline

jeremiah.foster triaged this task as Normal priority.Nov 5 2020, 11:39
jeremiah.foster created this task.

Cannot reproduce on my mini running byzantium.

I can reproduce on the L13;

E: Failed to fetch https://repo.pureos.net/pureos/pool/main/b/bash/bash_5.1~rc1-2_amd64.deb  404  Not Found [IP: 138.201.228.45 443]
E: Failed to fetch https://repo.pureos.net/pureos/pool/main/g/glib2.0/libglib2.0-dev_2.66.2-1_amd64.deb  404  Not Found [IP: 138.201.228.45 443]
E: Failed to fetch https://repo.pureos.net/pureos/pool/main/g/glib2.0/libglib2.0-dev-bin_2.66.2-1_amd64.deb  404  Not Found [IP: 138.201.228.45 443]
E: Failed to fetch https://repo.pureos.net/pureos/pool/main/g/glib2.0/libglib2.0-data_2.66.2-1_all.deb  404  Not Found [IP: 138.201.228.45 443]
E: Failed to fetch https://repo.pureos.net/pureos/pool/main/g/glib2.0/libglib2.0-bin_2.66.2-1_amd64.deb  404  Not Found [IP: 138.201.228.45 443]
E: Failed to fetch https://repo.pureos.net/pureos/pool/main/g/glib2.0/libglib2.0-0_2.66.2-1_amd64.deb  404  Not Found [IP: 138.201.228.45 443]
E: Failed to fetch https://repo.pureos.net/pureos/pool/main/libr/libreoffice/libridl-java_7.0.2-4_all.deb  404  Not Found [IP: 138.201.228.45 443]
E: Failed to fetch https://repo.pureos.net/pureos/pool/main/libr/libreoffice/libjurt-java_7.0.2-4_all.deb  404  Not Found [IP: 138.201.228.45 443]
E: Failed to fetch https://repo.pureos.net/pureos/pool/main/libr/libreoffice/libjuh-java_7.0.2-4_all.deb  404  Not Found [IP: 138.201.228.45 443]

Removing the contents of /var/lib/apt/lists removes out of date files. Re-running apt update brings in new Release file and one can download all packages again.

jeremiah.foster closed this task as Resolved.Mon, Nov 30, 17:34