Fix Ublock in PureBrowser
Open, Unbreak Now!Public

Description

I noticed that you migrated the distribution from Green to Amber. Amber is more or less like Debian Stable, frozen in amber :-) Fine, not an issue but please renew the wiki https://tracker.pureos.net/w/development/pureos_archive_layout/ asap and re-define the OS accordingly. The issue is that the current PureBrowser is in fact protecting our privacy much less than stock Firefox. The most annoying issue, but definitely not the only one, is that although YOUR Ublock is installed, it does not show up in PureBrowser and the issue doesn't appear to be serviceable by the user. PureBrowser is not recognized by Moxilla as being Firefox, hence one can't even install THEIR Ublock. Not that I would like to do that. Oh, lol, I don't want to see Facebook in PureBrowser. I'm not sure whether telemetry has been removed or not and the rest.

Otherwise, a lovely distribution. That's why I'm here, right? Right.

Squid created this task.Fri, Sep 6, 3:27 PM
jeremiah.foster closed this task as "Wontfix".Fri, Sep 6, 3:31 PM

The plan is actually to deprecate PureBrowser as Mozilla doesn't share the same goals we put forward and that makes it a lot of work to ensure that our user's privacy is protected.

Squid added a comment.Fri, Sep 6, 4:21 PM

The plan is actually to deprecate PureBrowser as Mozilla doesn't share the same goals we put forward and that makes it a lot of work to ensure that our user's privacy is protected.

@jeremiah.foster That's a good plan but it's not yet ready, is it? This hiatus is not acceptable. I suggest fixing PureBrowser and overtime you can replace it by GNOME Web (I'm sure it will not look splendid in Plasma though). Anyways, when can we expect GNOME Web to be up to the job?
Lol!


GNOME Web as well as Falkon suffer from the same issue. They are not being developed by people who specialize in browsers. Can we hope that we will find the necessary expertise in a reasonable amount of time?! If at all?! This is pretty major because in a privacy-oriented distribution, such as PureOS, the browser is one of the most important pieces of software. Best wishes and hopefully things will turn for the better.

Squid added a subscriber: todd.Fri, Sep 6, 5:04 PM

@todd If we can't deal with this issue in-house, maybe we should out-source it to people who specialize in browsers. What do you think?

WebKit is in fact the same browser engine that Apple's Safari uses. https://webkitgtk.org/

The changes in PureBrowser come from changes done upstream by Mozilla. It is resource intensive to continue to use their browser when we're investing in GNOME Web (which runs WebKit.)

Squid added a comment.Sat, Sep 7, 10:11 PM

I've just checked GNOME Web and it is not ready for real-world usage. It is very basic and has absolutely no tracking protection whatsoever. Currently the only browser that is usable is Chromium. With Ublock from Google :-)

Squid added a comment.Sun, Sep 8, 10:58 AM

Until you've got something that is good enough to replace PureBrowser, you should absolutely fix PureBrowser. I've been thinking that Falkon is underdeveloped. Well, with all due respect, GNOME Web is even more underdeveloped. Are you even using it at all? Can we please think deeply and rationally for a second? Can we please not give in to our emotions and think from a technical perspective? Please have PureBrowser fixed! Close it down if it makes you happy but I suggest you leave it on the board. Thank you.

Squid reopened this task as "Open".Sun, Sep 8, 10:58 AM
jonas.smedegaard removed jonas.smedegaard as the assignee of this task.Sun, Sep 8, 11:28 AM
jonas.smedegaard added a subscriber: jonas.smedegaard.
jonas.smedegaard removed a subscriber: jonas.smedegaard.
Squid added a comment.EditedSun, Sep 8, 6:14 PM

Neither KDE nor Gnome can make browsers because neither of the 2 communities are in the browser business. Deny it! So it makes perfect sense to re-use the code base of either Firefox or Chromium with some adjustments. That's what all sane projects are doing. If you don't want to deal with Firefox anymore, then may I suggest making ungoogled-chromium the successor PureBrowser? I'm kindly submitting to your attention the following link and all the links within the link: https://chromium.woolyss.com/ Thank you.

Until recently T814 we didn't know whether it was a PureBrowser issue or a Ublock issue. I think it is fair to assume that as soon as Ublock gets re-packaged in Amber, we can close this down. Some relevant aspects have been touched upon, although not strictly related to the task. A task should never diverge from its intended purpose or duplicate another task. It is indeed easier to merge than to split although enforcing separation is not always easy or even possible.

@jonas.smedegaard Provided that my style or the lack thereof has irritated you, I'm sorry for that.

Either this is a needless duplicate of T814 or it is a call to leadership about special-treating T814. In either case my participation is irrelevant.

@Squid Please respect my unsubscribing from this issue. Please don't subscribe me again.

Squid added a comment.EditedTue, Sep 10, 4:14 PM

Please respect my unsubscribing from this issue. Please don't subscribe me again.

Deal.

An error occurred during a connection to error.woolyss.com.
This problem can sometimes be caused by disabling or refusing to accept cookies.

{F333687}Hmm. I only know that I had been previously able to access it without issues on Chromium with uBlock Origin and HTTPS Everywhere from Google As a side note, uBlock Origin from Google was significantly more tolerant to trackers. Needless to say that I don't intend to re-install Chromium or ever again get any add-ons from Google.

louis added a subscriber: louis.Thu, Sep 12, 2:49 PM

Add Comment