Page MenuHomePureOS Tracker

PureBrowser: uBlock Origin fails to load
Open, HighPublic

Description

Since the introduction of PureBrowser 68.x, UBlock Origin (as shipped with PureOS!) fails to load.

As per user from the forum: https://forums.puri.sm/t/purebrowser-update/6856

Hey folks, what’s the deal with the new Purebrowser update? Now I have Pocket, Sync, etc. that I didn’t have before, and don’t really want. Was this a deliberate update or did somebody make a mistake?
Oh geez, and I just realized now I don’t have ublock going anymore. What the heck happened here?

I noticed that uBlock Origin is missing from my update as well.

Event Timeline

jonas.smedegaard changed the task status from Open to Incomplete.Aug 28 2019, 08:23
jonas.smedegaard added a subscriber: jonas.smedegaard.

The package currently in PureOS green - 68.0.2esr-1pureos3 - depends on webext-ublock-origin, and the addon loads fine on my system.

Please elaborate what exactly is experienced as broken regarding uBlock Origin, and also please double-check which version of PureBrowser is installed - e.g. with apt list purebrowser in a terminal.

(and please file other issues than uBlock Origin separately)

My output:

purebrowser/green,now 68.0.2esr-1pureos3 amd64 [installed,automatic]

uBlock Origin is no longer present in my PureBrowser installation. João confirmed the same thing on his end.

Thanks for the clarification.

Sorry, I have no idea why the addon gets suppressed on your systems. It _is_ installed, but evidently gets ignored by the browser in your setups but doesn't in mine.

jonas.smedegaard triaged this task as High priority.EditedAug 28 2019, 10:43

This might be related: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=931640

@richard.kolla Could you please try the following (in that order, stopping if you get some sort of success):

Quit PureBrowser, open a terminal and purge the browser cache with the command ~/.cache/purism, and start PureBrowser again - and check if uBlock Origin appears now.

Quit PureBrowser, open a terminal and run purebrowser from there - and check if it mentions anything about uBlock Origin.

Quit PureBrowser, rename the directory .purism to e.g. .purism.off, and start PureBrowser again - and see if uBlock Origin now works (on my system it is _disabled_ by default but shows with an icon in the right side).

Don't know if it adds any new information to this issue. But i got uBlock Origin back by reinstalling it. Removed it and then install again

@joao.azevedo thanks - what is probably more interesting is what you did in-between: Did you start PureBrowser while the addon was removed? Or did you have PureBrowser running while removing and reinstalling the addon?

Reason I ask is that the addon package does not mess with the data in your $HOME so it is unlikely to be fix this issue but more likely it triggered some refresh routine that fixed it.

but already, getting fixed by only (?) removing and reinstalling the addon indicates that this is a bug in the addon rather than Firefox trying to suppress it (e.g. due to that new Mozilla content blocker perhaps conflicting with it).

richard.kolla added a comment.EditedAug 28 2019, 20:18

Step 1 did not work.

Here is the output from Step 2

. It does mention of uBlock Origin about half way down.

Step 3 did not work either and I lost all my precious tabs :-( Then again, easier than closing them all manually.

jonas.smedegaard added a comment.EditedAug 28 2019, 23:46

@richard.kolla Thanks for testing!

Sorry that I didn't make that clear before: You can revive your old setup like this:
Quit PureBrowser, rename the directory .purism to e.g. .purism.new-can-be-deleted, rename the directory .purism.oldto .purism, and start PureBrowser again.

@richard.kolla I made a typo in the first test - please try this:

Quit PureBrowser, open a terminal and purge the browser cache with the command rm -rf ~/.cache/purism, and start PureBrowser again - and check if uBlock Origin appears now.

@jonas.smedegaard

thanks - what is probably more interesting is what you did in-between: Did you start PureBrowser while the addon was removed?

So i retraced my steps by doing the process again from an image in GNOME Boxes.

1 - did a sudo apt update && sudo apt dist-upgrade, only update available was purebrowser 68.0.2esr-1pureos3

2 - launched purebrowser, uBlock Origin was not available

3 - Followed this tutorial to enable Firefox compatibility mode so i can install addons: firefox_compat_mode

4 - reloaded the addons page, from that point on i was able to install more addons

5 - installed uBlock Origin

6 - uBlock Origin automatically appeared

All these steps in Purebrowser were done without closing it and launching it again. Just reloading the about:config page after enabling Firefox compatibility mode, and then reloading the about.addons page.

In this process i did noticed other things that i do not know if they are normal:

Purebrowser presented what seemed to be Firefox home page with quick links to stuff like facebook, and the icon for the Firefox account (see the first picture bellow).

Bellow are the pictures of the different steps of this process

As an additional piece of information to this puzzle, a user has reported in the forums that uBlock Origin was also removed from his Firefox, but not blocked so the user could reinstall it as well:

This is the Forum post:

https://forums.puri.sm/t/purebrowser-update/6856/7

Gonna try to confirm this story

Thanks for the details.

It is however *not* an acceptable solution to install addons from Mozilla - regardless of possibly being acceptable for you personally.

It is helpful if you can try distinguish stories that involve wandering off of PureOS and (re)installing things from elsewhere, from stories about solely using software provided as part of PureOS.

It is however *not* an acceptable solution to install addons from Mozilla

I am aware of that, and i also do not consider it an acceptable solution for Purism.

Like i said, i tried to retrace my steps from a new ISO image in a VM. If it was the wrong sequence of steps to help provide information on this issue, then i am sorry for the waste of time

I am repeating the process in a VM with PureOS, with a version of purebrowser that does not have Firefox compatibility mode enabled

Ok, testing from a VM image with purebrowser with no firefox compatibility mode, i was not able to reinstall uBlock Origin.

Also did a second test purging the cache with rm -rf .cache/purism and restarting purebrowser, it had no effect.

Did a third test, doing rm -rf with the .purism folder and the .cache/purism and restarted purebrowser, also with no effect.

What i got from the terminal output was this:

I hope it helps.

In any case like i mentioned in the above posts, what appears to be Firefox home page is present, and also the button for firefox sync. If that is unrelated i can open a another ticket about that

no no, as I tried to communicate, the provided info is appreciated.

I just wanted to explicitly point out that while helpful for debugging it should not - by others following along - I assumed you were well aware, @joao.azevedo - be taken as a solution.

Please do open separate issue reports for each of those other issues.

It is far easier to merge than to split issue reports.

See T815 for what is likely _causing_ these issues to reappear.

Now that i am back online in front of a laptop, just to leave it registered here :)

Could this issue be related to the webext-ublock-origin version that is 1.18.4 in both amber and green?

There is this bug report in Debian bugs.debian.org of the same issue happening with Firefox 66 esr:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=925337

Debian Testing has a more recent version of webext-ublock-origin: https://packages.qa.debian.org/u/ublock-origin/news/20190713T043928Z.html

@joao.azevedo Yes, that could quite likely be same issue as this one!

jonas.smedegaard changed the task status from Incomplete to Open.Sep 3 2019, 01:43

If it is the same issue then according to that issue tracker thread it should be fixed with ublock-origin/1.18.10+dfsg-1

emmes added a subscriber: emmes.Sep 3 2019, 08:46

emmes would like to comment on his experience with purebrowser-68.02esr from the amber repository.
I was able to install webext-ublock-origin and it initially worked as it should. After an exit and relaunch, the icon was missing from the menu toolbar and the add-on did not work. It can be made to work by going to Add-ons, disabling it and then renabling it. A second problem with purebrowser, which may or may not be related, is that once Privacy badger is installed, it cannot be uninstalled or reported.

Thanks for your additional info, @emmes

Please note, however, that this issue specifically is about uBlock Origin packaged for PureOS.

Therefore, a) could you please clarify from where you installed a working uBlock Origin, and b) please file your notes about Privacy Badger as a separate issue or clarify how they are directly(!) related to this issue).

Thanks again for your help.

emmes added a comment.Sep 3 2019, 12:55

I installed three different versions of webext-ublock-origin. 1 from pureOS amber. 2 from github. 3) from gnu. In my hands, they all behaved the same as I described.

The only commonality with the privacy badger problem is that they both appeared simultaneously with the latest update. I'll be happy to file a separate issue with privacy badger.

I should be clear what I mean by a working version. It works well so long as the icon appears in the menu bar. Since all versions I installed had the habbit of disappearing from the menu bar, calling them working when there clearly is a serious problem, needs this explaining. i only meant that when they are in the menu bar, tthey perform blocking as advertized.

The latest vesrion I installed is 1.22 from github. If that lasts any longer than the previously installed versions, I will get back to you, since that provides information as to whether the problem was solved in 1.18.10.

@emmes Which version did you install from PureOS Amber? Info should be available in /var/log/dpkg.log even if you since removed it again.

(as already mentioned, what is the focus of this issue is uBlock Origin packaged for PureOS)

emmes added a comment.Sep 3 2019, 22:40

Dear @jonas.smedegaard ,
I joined this thread because I had two problems I thought were related to the subject matter. I apologize for not providing more information about version numbers, but not for going off-focus. I think you should pay attention, as you have, to what I report for two reasons; I have been solving (and causing) programming problems since likely before you were born, and I have solved the problems I initially told you about.

HISTORY and ACTIONS:
Before starting, I set in about:config xpinstall.signatures.required and xpinstall.whitelist. required to false from their defaiult of true.

Although off-focus, this allowed me to finally uninstall privacy-badger, not from within purebrowser, but using apt purge webext-privacy-badger.

I then did apt purge webext-ublock-origin, which for some reason not clear to me also removed purebrowser-68.0.2-1pureos3 as well as version 1.18.4+dfsg-2 of ublock, the same version I installed previously from amber.

I then did apt-clean followed by apt install purebrowser which then reinstalled the two!! packages I had purged. This failed to put ublock origin in the list of enabled extensions at about:addons

I then installed webext-ublock-origin-1.22.0 from GNU FSF and this did put ublock in the list of enabled addons. Furthermore, ublock then behaved as it did prior to the latest update of purebrowser to version 68.0.02-1pureos3, in remaining enabled after exiting and reopening the browser and in filtering as it should.

While everything I report may not be totally on focus, I strongly believe, and hope, it will help in solving any problems using ublock-origin in the PureOS environment.

I appreciate your politeness and apologize for any of my testiness about remaining on-focus.

jonas.smedegaard added a comment.EditedSep 4 2019, 01:09

Thanks for your details about PureOS.

Thanks also for your lesser related notes, including vague references to your and my age (you win the pissing contest when including your Fortran experience even if "behind" by ~11 years on linux - more power to you).

I don't need or asked for apology, only inform what is helping. To spell it out for you, it has already been identified that newer-than-packaged-for-PureOS versions of uBlock Origin seem to solve this issue, and what then (i.e. where you came along) helps is to know if also packaged-for-PureOS versions solve it.

For further (beyond what has already been established here by now, which is appreciated) sharing and discussing and comparing _workarounds_ mixing PureOS with outside-of-PureOS code I recommend to do so at https://forums.puri.sm/ where others might appreciate such details.

The inability to remove uBlock Origin independently of PureBrowser is a management decision which I personally disagree with but have obeyed (see e.g. beginning of T272 for brief hints on that topic).

@joao.azevedo Could you please test if installing uBlock Origin package from Debian testing on top of an up-to-date (and clean, no Mozilla or other non-PureOS-origin code added) PureOS amber install fixes this issue?

@jonas.smedegaard

I just tested installing webext-ublock-origin_1.19.0+dfsg-2_all.deb from bullseye in a new image of PureOS Amber in a VM.

It worked. webext-ublock-origin_1.19.0 solves the problem. After installed uBlock Origin works again.

My steps for this were:

1 - Download the latest image of PureOS Amber: pureos-8.0-gnome-live_20190830-amd64.hybrid.iso

2 - Do the installation procedure of the Image in a VM (Gnome Boxes), did not performed any update nor added any software source (not even addons.mozilla.org)

3 - Opened Purebrowser to confirm that the problem with Ublock Origin persisted in this image

4 - Downloaded webext-ublock-origin_1.19.0+dfsg-2_all.deb from Debian Testing (Bullseye), more specifically from: https://packages.debian.org/bullseye/all/webext-ublock-origin/download

5 - Confirmed that the installed version in PureOS was 1.18.4+dfsg-2

6 - Ran sudo dpkg -i *.deb to install webext-ublock-origin_1.19.0+dfsg-2_all.deb

7 - Reopened Purebrowser, the addon uBlock Origin was now present, it needed to be enabled in about:addons, but (this is me speculating again), that might be related with the fact that i opened purebrowser with 1.18.4 before installing 1.19. 0

Here is a screenshot:

Here is a screenshot:

Now the screenshot :)

I will repeat this process, but this time without opening Purebrowser before updating, to see if ublock loads automatically

@jonas.smedegaard Ok, just repeated the steps above. The only difference was that i did not opened purebrowser before installing the 1.19.0 package from bullseye.

After updating the package, when i opened purebrowser for the first time in the VM image uBlock loaded automatically, it was enabled.

sudo dpkg -i webext-ublock-origin_1.19.0+dfsg-2_all.deb
[sudo] password for squid:
(Reading database ... 152660 files and directories currently installed.)
Preparing to unpack webext-ublock-origin_1.19.0+dfsg-2_all.deb ...
Unpacking webext-ublock-origin (1.19.0+dfsg-2) over (1.18.4+dfsg-2) ...
Setting up webext-ublock-origin (1.19.0+dfsg-2) ...

@joao.azevedo Works. Thank you so much!

Squid added a subscriber: mak.Sep 10 2019, 09:51

@mak Could you, please, package this thing in Amber so we can move on? Much appreciated in advance.

@joao.azevedo Can I ask you to please confirm that PureBrowser as of today fixes tis issue, specifically?

@jonas.smedegaard uBlock Origin is back in my PureBrowser.

I never did the work around to enable it manually for this situation.

@joao.azevedo please confirm in your VM.

jonas.smedegaard renamed this task from uBlock Origin not in PureBrowser 68 to PureBrowser: uBlock Origin fails to load.Sep 18 2019, 08:36
jonas.smedegaard claimed this task.
jonas.smedegaard updated the task description. (Show Details)
jonas.smedegaard added a project: Restricted Project.

Thanks, that's quite helpful @richard.kolla !

One thing to note, my profile seems to have reset because I lost my tabs and history. That is probably due to the stuff we did before but wanting to confirm whether this has that happened to anyone else after this update?

Ouch!

I sure hope that it was our messing directly with the configfiles (as per my instructions) that caused that - and that package downgrade does *not* cause any such surprises!

@richard.kolla Did you see my follow-up note on how to revive your put-aside configfiles? Did you try that?

Obviously, by now, there's the tradeoff that reverting back to your old configfiles will have you loose what you might have accumulated _since_ the experiment.

Sorry for the mess!

@jonas.smedegaard i just tried the upgrade in a vm in a fresh instalation. And i lost my profile as well.

I started the vm, opened purebrowser and went to some websites to create a history,

updated,

lost the browsing history and the folder i made

richard.kolla added a comment.EditedSep 18 2019, 14:42

I had a VM that was still on PureOS Green. Ran an upgrade, didn't lose my profile but did lose uBlock Origin. Ran a second upgrade, uBlock Origin came back but I did NOT lose my profile. Really weird.

@joao.azevedo Please file a separate issue about loss of profile (because that is clearly a different issue from being told here as a debugging aid to rename a profile folder).

@richard.kolla Not sure I understand. Did you make a copy of a VM and tried upgrade it twice where first time uBlock Origin disappeared whereas second time it didn't? Or did you try with two _different_ VMs behaving differently?

It seems the issue has gone away. Fresh-installed from image released on 2019-05-04.

Agreed. For now it has though we'll see what happens when upstream support for 60.9.0esr is done and we forced to go back to 68esr.