Page MenuHomePureOS Tracker

Kernel panic — not syncing: VFS: unable to mount root fs with linux-image 4.16.0-1-amd64
Open, HighPublic

Description

Some users reported that they cannot boot after latest updates.

Event Timeline

mladen created this task.May 27 2018, 02:23
mladen created this object with edit policy "Restricted Project (Project)".
mladen updated the task description. (Show Details)May 27 2018, 02:26

(Do we have any more info? For example, which packages were upgraded?)

mladen added a comment.May 27 2018, 07:01

It appears that this is already described in forums: https://forums.puri.sm/t/kernel-panic-after-recent-update/3171/

I am waiting for more info about this from users.

In T448#7988, @mladen.pejakovic wrote:

It appears that this is already described in forums: https://forums.puri.sm/t/kernel-panic-after-recent-update/3171/

I've added a link from there to here too for 100% clarity.

chris.lamb renamed this task from Kernel panic — not syncing: VFS: unable to mount root fs to Kernel panic — not syncing: VFS: unable to mount root fs with linux-image 4.16.0-1-amd64 .May 28 2018, 10:19

Appears to be 4.16.0-1-amd64 related (see forum). Retitling bug to match.

I cannot reproduce this - am running 4.16.0-1-amd64 with no issues.

mladen added a comment.Jun 3 2018, 14:43

Customer reported that they cannot reproduce this after update. Closing as a duplicate.

mladen closed this task as Resolved.Jun 3 2018, 14:45
mladen claimed this task.

@mladen.pejakovic Duplicate of what, sorry?

mladen added a comment.EditedJun 3 2018, 14:46

@chris.lamb This turns out to be the same issue that was already fixed (but I cannot find it now).

Either way, customer(s) do not have this problem anymore.

@mladen.pejakovic Would be very interested to know the problem. Could you spend a brief moment trying to locate it, otherwise this information will be lost in time..

mladen added a comment.Jun 4 2018, 13:05

@chris.lamb I thought this was related to T433, but it obviously isn't. But I know I have seen this somewhere before, most likely in community forums, I'll try to find the topic.

mladen reopened this task as Open.EditedJun 17 2018, 00:31

Reopened, because it has happened again. From a user:

today when turn on my Librem 13 it showed 30 updates to install. I gave permission to "restart and Install" the picture attached is what appears now when I turn on my laptop. I can access in safe mode...

Waiting for further info from the user.

I believe this is an isolated issue which was fixed, and is surfacing for users who didn't update for a long time (it happens for people who update via GNOME Software Center, AFAIK update via apt doesn't trigger the bug).

That's … odd. They should be calling the exact same thing. Can you provide the background etc. for your rationale?

mladen added a comment.Jun 18 2018, 14:18

Can you provide the background etc. for your rationale?

Well, the user managed to boot into rescue mode, from there they issued sudo apt update && sudo apt full-upgrade and got the following:

282 packages can be updated  to see run 'apt list' upgradable
E: dpkg was interrupted, you must manually run 'sudo dpkg -- configure -a' to correct the problem.

After they run sudo dpkg -- configure -a and right after that sudo apt update && sudo apt full-upgrade, the system started normally after restart.

Something happened while updating via GNOME Software Center to cause the interruption. This hasn't happened to users who update via apt (at least I didn't get any reports).

Thanks. So getting the logs of the Software Center failure would be the next step to resolving this, ie. working out why/what it is failing there and fixing that.

roshii added a subscriber: roshii.EditedJan 9 2019, 05:30

I did experience the same kernel panic as described above with brand new laptop at several occasion:

  1. When rebooting after setting up PureOS on a Librem 13 v2, out of the box
  2. When rebooting after upgrade to latest updates (kernel4.18) via Software Center
  3. When rebooting after setting up PureOS following fresh install
  4. When rebooting after upgrade to latest updates (kernel4.18) via apt with sudo apt update && sudo apt remove libavcodec-extra57 && sudo apt upgrade

At every occasion I just had to force shutdown and switch it back on. No need for any other action.

I have removed the 128 GB Intel SATA SSD and replaced it with a 500 GB Samsung 970 Evo NVMe M.2.
I did install PureOS from scratch and did not encounter any kernel panic.

Issue related to Intel SATA SSD?

I'm also experiencing this problem. After showing the Purism logo, the screen remains black for a couple minutes, then displays the same kernel panic.
I have a Librem13v4 with the 128GB SATA SSD.

Also, the kernel panic does not happen all the time! I'd say it happens 30% of the time. The rest of the time, the system boots normally.

I tried the multiple update commands in this thread, to no avail.

@mladen I'm able to reproduce in case you need me to provide more details

@mladen I reproduced the bug again while booting in verbose mode. The system sometimes hangs at Loading Linux 4.19.0-5-amd64, sometimes at Loading initial ramdisk.... Then after a couple minutes, the following line is shown:

error: failure reading sector 0x802 from `hd0'

and then the stack trace described above.

I ran some checks with the Disks utility, but the disk is looking ok.

Any ideas?

louis added a comment.EditedAug 19 2019, 17:13

So I reinstalled PureOS on the Librem13v4 again using the OEM usb key, and this time went for a apt full-upgrade directly, and the issue still occurs. I also tried installing PureOS using the live version and no swap, and after the installation, the problem occurs at every boot, without the couple minutes hanging time. Finally, I tried installing with the live version and hibernate swap (I think it's the default option when installing from the OEM usb key), and the behaviour is the same as originally (happens 30-40% of the time).

@mladen Is this still being investigated? It's kind of a disappointment to have to start a brand new laptop multiple times before it actually boots.

mladen added a comment.Aug 19 2019, 22:09

@louis I suggest that you use the latest ISO image: http://downloads.puri.sm/oem/gnome/2019-07-14/

This comment was removed by louis.

@mladen I just tried reinstalling with the latest OEM ISO as you suggested, and the issue persists. Configuration was the same (swap with hibernate, disk encryption enabled).

What's next?

mladen added a comment.Aug 20 2019, 09:29

Do you have two disks in your laptop?

Nope, only one, which is the 128 GB SATA SSD that came with the laptop.

mladen added a comment.Aug 20 2019, 09:46

I can only suggest that you try with live PureOS, download the latest version from here please: http://downloads.puri.sm/live/gnome/2019-07-14/

I already tried with that exact version of live PureOS, and the same problem occurs.

mladen added a comment.Aug 20 2019, 10:32

@louis You are doing something wrong, 2019-07-14 live ISO version has 4.19.0-5 kernel version.

@mladen could you please provide details regarding what I'm doing wrong exactly?
Are you expecting 4.19.0-5 to not be affected by this issue, or the opposite?

mladen added a comment.Aug 20 2019, 10:42

@louis This means you are not using the latest live PureOS install ISO, which probably has this issue fixed.

negative, the issue occurs with 4.19.0-5 (See my comment above from Aug 13)

louis added a comment.EditedAug 20 2019, 12:52

@mladen I just installed Ubuntu 19.04, sporting kernel version 5.0.0-25 and the issue persists!! The laptop fails to boot intermittently, the only difference is that the following error message is displayed before the panic stack trace

error: failure reading sector 0x802 from `hd0'

Press any key to continue...

which was also displayed with PureOS when quiet mode was disabled.

mladen added a comment.Aug 20 2019, 12:57

This may indicate that your disk is failing. Start a live media (PureOS or Ubuntu) and check it for errors:

https://askubuntu.com/questions/528072/how-can-i-check-the-smart-status-of-a-ssd-or-hdd-on-current-versions-of-ubuntu-1

@mladen I already ran the Disks disk check utility (see comment Aug 13) and the disk is OK.
Ran it again, still OK.

@mladen any other suggestions?
I could try with an even newer version of the kernel, like 5.2.9, would that make sense?

mladen added a comment.Aug 21 2019, 12:42

If you run "Self-Test" from GNOME Disks then I do not see any other course but to try another disk. If your device is still under warranty contact Purism support, we'll handle there. (I see that your laptop is Librem.)