Kernel panic — not syncing: VFS: unable to mount root fs with linux-image 4.16.0-1-amd64
Open, HighPublic

Description

Some users reported that they cannot boot after latest updates.

mladen created this task.May 27 2018, 9:23 AM
mladen created this object with edit policy "Restricted Project (Project)".
mladen edited the task description. (Show Details)May 27 2018, 9:26 AM

(Do we have any more info? For example, which packages were upgraded?)

It appears that this is already described in forums: https://forums.puri.sm/t/kernel-panic-after-recent-update/3171/

I am waiting for more info about this from users.

In T448#7988, @mladen.pejakovic wrote:

It appears that this is already described in forums: https://forums.puri.sm/t/kernel-panic-after-recent-update/3171/

I've added a link from there to here too for 100% clarity.

chris.lamb changed the title from "Kernel panic — not syncing: VFS: unable to mount root fs" to "Kernel panic — not syncing: VFS: unable to mount root fs with linux-image 4.16.0-1-amd64 ".May 28 2018, 5:19 PM

Appears to be 4.16.0-1-amd64 related (see forum). Retitling bug to match.

I cannot reproduce this - am running 4.16.0-1-amd64 with no issues.

mladen added a comment.Jun 3 2018, 9:43 PM

Customer reported that they cannot reproduce this after update. Closing as a duplicate.

mladen closed this task as "Resolved".Jun 3 2018, 9:45 PM
mladen claimed this task.

@mladen.pejakovic Duplicate of what, sorry?

mladen added a comment.EditedJun 3 2018, 9:46 PM

@chris.lamb This turns out to be the same issue that was already fixed (but I cannot find it now).

Either way, customer(s) do not have this problem anymore.

@mladen.pejakovic Would be very interested to know the problem. Could you spend a brief moment trying to locate it, otherwise this information will be lost in time..

mladen added a comment.Jun 4 2018, 8:05 PM

@chris.lamb I thought this was related to T433, but it obviously isn't. But I know I have seen this somewhere before, most likely in community forums, I'll try to find the topic.

mladen reopened this task as "Open".EditedJun 17 2018, 7:31 AM

Reopened, because it has happened again. From a user:

today when turn on my Librem 13 it showed 30 updates to install. I gave permission to "restart and Install" the picture attached is what appears now when I turn on my laptop. I can access in safe mode...

Waiting for further info from the user.

I believe this is an isolated issue which was fixed, and is surfacing for users who didn't update for a long time (it happens for people who update via GNOME Software Center, AFAIK update via apt doesn't trigger the bug).

That's … odd. They should be calling the exact same thing. Can you provide the background etc. for your rationale?

Can you provide the background etc. for your rationale?

Well, the user managed to boot into rescue mode, from there they issued sudo apt update && sudo apt full-upgrade and got the following:

282 packages can be updated  to see run 'apt list' upgradable
E: dpkg was interrupted, you must manually run 'sudo dpkg -- configure -a' to correct the problem.

After they run sudo dpkg -- configure -a and right after that sudo apt update && sudo apt full-upgrade, the system started normally after restart.

Something happened while updating via GNOME Software Center to cause the interruption. This hasn't happened to users who update via apt (at least I didn't get any reports).

Thanks. So getting the logs of the Software Center failure would be the next step to resolving this, ie. working out why/what it is failing there and fixing that.

roshii added a subscriber: roshii.EditedJan 9 2019, 1:30 PM

I did experience the same kernel panic as described above with brand new laptop at several occasion:

  1. When rebooting after setting up PureOS on a Librem 13 v2, out of the box
  2. When rebooting after upgrade to latest updates (kernel4.18) via Software Center
  3. When rebooting after setting up PureOS following fresh install
  4. When rebooting after upgrade to latest updates (kernel4.18) via apt with sudo apt update && sudo apt remove libavcodec-extra57 && sudo apt upgrade

At every occasion I just had to force shutdown and switch it back on. No need for any other action.

I have removed the 128 GB Intel SATA SSD and replaced it with a 500 GB Samsung 970 Evo NVMe M.2.
I did install PureOS from scratch and did not encounter any kernel panic.

Issue related to Intel SATA SSD?

Add Comment