Chromium crashes in pure os
Closed, WontfixPublic

Description

bent@LibremBT:~$ chromium
[14211:14249:1215/175944.007790:ERROR:nss_util.cc(725)] After loading Root Certs, loaded==false: NSS error code: -8018
ATTENTION: default value of option force_s3tc_enable overridden by environment.
Received signal 11 SEGV_MAPERR 000000000010
#0 0x560b92619f56 <unknown>
#1 0x560b911e6a58 <unknown>
#2 0x560b9261a2dc <unknown>
#3 0x7fe8547883b0 <unknown>
#4 0x560b91b0b5ba <unknown>
#5 0x560b91b0c43d <unknown>
#6 0x560b91b0ca4d <unknown>
#7 0x560b91b0cbb5 <unknown>
#8 0x560b9267df19 <unknown>
#9 0x560b9261b136 <unknown>
#10 0x560b9263a318 <unknown>
#11 0x560b9263aa1f <unknown>
#12 0x560b9263b6c6 <unknown>
#13 0x560b9263d822 <unknown>
#14 0x560b92662ffb <unknown>
#15 0x560b92682d58 <unknown>
#16 0x560b9267de10 <unknown>
#17 0x7fe85477d519 start_thread
#18 0x7fe849102a5f clone
  r8: 0000000000000001  r9: 0000560b953b590c r10: 0000560b953b5910 r11: 00007fe849186e20
 r12: 0000000000000008 r13: 00007fe815e2ddd0 r14: 00007fe815e2dfe0 r15: 0000000000000000
  di: 0000000000000000  si: 00007fe815e2ddd0  bp: 00007fe815e2def0  bx: 0000000000000008
  dx: 0000000000000004  ax: 00001c5bff2efd50  cx: 0000000000000000  sp: 00007fe815e2dd70
  ip: 0000560b91b0b5ba efl: 0000000000010202 cgf: 002b000000000033 erf: 0000000000000004
 trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000010
[end of stack trace]
Calling _exit(1). Core file will not be generated.
bent@LibremBT:~$

Hi @ben.trister, thank you for the report. After some experimentation I am unable to reproduce this. Can you let me know:

  • What version of chromium you are running? (eg "apt-cache policy chromium-browser")
  • How you got hold of this version?
  • Is this a recent regression or has it always happened?
  • Can you try temporarily moving your config directory out of the way? (eg "mv ~/.config/chromium ~/.config/chromium.old")
  • Can you try disabling extensions with "chromium --disable-extensions"?
  • Any output in "dmesg" ?
  • You may get a better traceback by installing the "chromium-browser-dbg" package.

Thanks!

I moved the config directory as you suggested and it seems to have fixed the problem. Thanks!

chris.lamb closed this task as "Resolved".Dec 21 2017, 9:40 PM

Thanks for the update. So, this is quite a common problem that affects Chromium generally (Google it!) and, alas, has an almost infinite number of causes AFAICT.

I'm seeing the same issue.

Where would I find the config file you mention?

[3541:3579:0109/104738.386790:ERROR:nss_util.cc(725)] After loading Root Certs, loaded==false: NSS error code: -8018
ATTENTION: default value of option force_s3tc_enable overridden by environment.
Received signal 11 SEGV_MAPERR 000000000010
#0 0x55c051c37f56 <unknown>
#1 0x55c050804a58 <unknown>
#2 0x55c051c382dc <unknown>
#3 0x7f296d5993b0 <unknown>
#4 0x55c0511295ba <unknown>
#5 0x55c05112a43d <unknown>
#6 0x55c05112aa4d <unknown>
#7 0x55c05112abb5 <unknown>
#8 0x55c051c9bf19 <unknown>
#9 0x55c051c39136 <unknown>
#10 0x55c051c58318 <unknown>
#11 0x55c051c58a1f <unknown>
#12 0x55c051c596c6 <unknown>
#13 0x55c051c5b822 <unknown>
#14 0x55c051c80ffb <unknown>
#15 0x55c051ca0d58 <unknown>
#16 0x55c051c9be10 <unknown>
#17 0x7f296d58e519 start_thread
#18 0x7f2961f19a4f clone

r8: 0000000000000001  r9: 000055c0549d390c r10: 000055c0549d3910 r11: 00007f2961f9de20

r12: 0000000000000008 r13: 00007f292e720dd0 r14: 00007f292e720fe0 r15: 0000000000000000

di: 0000000000000000  si: 00007f292e720dd0  bp: 00007f292e720ef0  bx: 0000000000000008
dx: 0000000000000004  ax: 00002fae9878b840  cx: 0000000000000000  sp: 00007f292e720d70
ip: 000055c0511295ba efl: 0000000000010202 cgf: 002b000000000033 erf: 0000000000000004

trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000010
[end of stack trace]
Calling _exit(1). Core file will not be generated.

@james.rufer wrote:

Where would I find the config file you mention?

It's a config directory, not a file. It resides at ~/.config/chromium. :)

Thanks Chris. Moved the file as suggested above. Uninstall/reinstall with same result as before.

Terminal:

root@Librem13v2-Enterprise:~# chromium
[6802:6802:0109/134456.489569:ERROR:zygote_host_impl_linux.cc(88)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.

without root:

james@Librem13v2-Enterprise:~$ chromium
[6869:6907:0109/134904.685632:ERROR:nss_util.cc(725)] After loading Root Certs, loaded==false: NSS error code: -8018
ATTENTION: default value of option force_s3tc_enable overridden by environment.
Received signal 11 SEGV_MAPERR 000000000010
#0 0x563a58de9f56 <unknown>
#1 0x563a579b6a58 <unknown>
#2 0x563a58dea2dc <unknown>
#3 0x7ff9756f23b0 <unknown>
#4 0x563a582db5ba <unknown>
#5 0x563a582dc43d <unknown>
#6 0x563a582dca4d <unknown>
#7 0x563a582dcbb5 <unknown>
#8 0x563a58e4df19 <unknown>
#9 0x563a58deb136 <unknown>
#10 0x563a58e0a318 <unknown>
#11 0x563a58e0aa1f <unknown>
#12 0x563a58e0b6c6 <unknown>
#13 0x563a58e0d822 <unknown>
#14 0x563a58e32ffb <unknown>
#15 0x563a58e52d58 <unknown>
#16 0x563a58e4de10 <unknown>
#17 0x7ff9756e7519 start_thread
#18 0x7ff96a072a4f clone

r8: 0000000000000001  r9: 0000563a5bb8590c r10: 0000563a5bb85910 r11: 00007ff96a0f6e20

r12: 0000000000000008 r13: 00007ff936879dd0 r14: 00007ff936879fe0 r15: 0000000000000000

di: 0000000000000000  si: 00007ff936879dd0  bp: 00007ff936879ef0  bx: 0000000000000008
dx: 0000000000000004  ax: 00003c4fbb12ff30  cx: 0000000000000000  sp: 00007ff936879d70
ip: 0000563a582db5ba efl: 0000000000010202 cgf: 002b000000000033 erf: 0000000000000004

trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000010
[end of stack trace]
Calling _exit(1). Core file will not be generated.

Can you confirm this is being run with *no* ~/.config/chromium ? (eg. moved out of the way prior to running?) I cannot reproduce this, alas.

I was getting the same error message as @ben.trister

Moving the /.config/chromium directory fixes it temporarily, but as soon as I log in I can only work in an open window. If I close a window I cannot relaunch from the terminal or GUI icon. Links expecting to open a browser window also fail as Chromium has made itself my default browser.

ben@delta:~$ apt-cache policy chromium
chromium:
  Installed: 62.0.3202.89-1
  Candidate: 62.0.3202.89-1
  Version table:
 *** 62.0.3202.89-1 500
        500 https://repo.puri.sm/pureos green/main amd64 Packages
        100 /var/lib/dpkg/status

Installed today via terminal command sudo apt install chromium

Running chromium --disable-extensions succeeds temporarily, but after closing the window, I cannot launch the application from the icon.
sudo dmesg generates copious amounts of information but nothing clearly indicating chromium
I was unable to install chromium-browser-dbg package. (Unable to locate package.)

chromium-browser-dbg

We do not ship / generate this package. Are you following some outdated documentation?

I'm following the advice you gave to Ben Trister on 12/19.

Can you confirm this is being run with *no* ~/.config/chromium ? (eg. moved out of the way prior to running?) I cannot reproduce this, alas.

I experienced the Chromium crashing issue again and revisited this ticket. If I move the config folder (placed on desktop) and re launch Chromium, it will then run. Looking back in the original ~/.config folder, I discover a new /chromium folder. Everything works.

james.rufer reopened this task as "Open".Mar 1 2018, 3:13 PM
james.rufer triaged this task as "Normal" priority.

This issue seems to resurface after an update to Chromium. Removing the /.config folder works temporarily but the crashing issue re-occurs.

This issue seems to have been resolved for me in the latest PureOS update, version 8.0
Thank you for your work!

mladen added a subscriber: mladen.Jun 13 2018, 11:53 AM

I am proposing for this to be closed, chromium is no longer in our repo.

chris.lamb closed this task as "Wontfix".Jun 13 2018, 12:04 PM

Agreed. Changing status to "wontfix"..

Add Comment