Page MenuHomePureOS Tracker

fwupd fails to update to 1.5.7-4pureos0.1 because fwupd-amd64-signed “Depends: fwupd (= 1.5.7-4)”
Open, Needs TriagePublic

Description

the installed version of fwupd is 1.5.7-4. the latest available version of fwupd is 1.5.7-4pureos0.1. “aptitude upgrade” says:

Resolving dependencies...                

fwupd-amd64-signed depends upon fwupd (= 1.5.7-4) -> Installing fwupd 1.5.7-4 (now)

The following packages will NOT be UPGRADED:
  fwupd{a} (R: secureboot-db, S: gir1.2-fwupd-2.0, R: fwupdate, R: gir1.2-dfu-1.0, R: libdfu-dev, R: libdfu1)  
No packages will be installed, upgraded, or removed.

i believe this failure is happening because fwupd-amd64-signed requires an exact version of fwupd:

Depends: fwupd (= 1.5.7-4)

hope this report helps get this unblocked.

Event Timeline

jbw created this task.Dec 19 2021, 06:03
ctowne added a subscriber: ctowne.Wed, Dec 29, 22:01

another report:

The following packages have unmet dependencies:
 fwupd-amd64-signed : Depends: fwupd (= 1.5.7-4) but 1.5.7-4pureos0.1 is to be installed
E: Unable to correct problems, you have held broken packages.

Another report from a user:

Hello, I just updated fwupd package via Synaptic, problem solved.

ctowne added a comment.Mon, Jan 3, 08:11

Distribution upgrade worked for me.

sudo apt dist-upgrade
jbw added a comment.Tue, Jan 4, 06:12
In T1091#20414, @ctowne wrote:

Distribution upgrade worked for me.

sudo apt dist-upgrade

doesn't that leave you with a broken dependency? the fwupd-amd64-signed package will still have a hard dependency on an older version. as far as i can tell, the only way to fix this is to have a pureos version of fwupd-amd64-signed with a different dependency. if i am wrong, it would be helpful if someone could explain.

ctowne added a comment.Thu, Jan 20, 01:24

I have see this message, "failed to update metadata for lvfs" a couple times now when checking for a software update. It doesn't happen often but running the following command seems to help.

fwupdmgr refresh

mak added a subscriber: mak.Sat, Jan 22, 14:55

This is an annoying issue, as it is extremely hard (if not impossible currently) to fix properly. A proper fix would be to re-sign the fwupd-amd64-signed binary package, but we can not do that as we do not have any EFI signing facilities for PureOS...
This package has been removed from PureOS (as we don't support UEFI with secure boot signing enabled properly anyways), but users who have installed the package manually before will of course run into this issue now until they run an apt purge fwupd-amd64-signed. We could force the removal of this package via conflicts, but that may also not be an ideal solution here :-/

mak claimed this task.Sat, Jan 22, 14:56
jbw added a comment.Sun, Jan 23, 06:37

@mak does this mean that the most correct solution for many people will be to simply uninstall fwupd because it is useless for them? i don't remember installing it. it is "Recommends:" by pureos-gnome and gnome-software, but i don't have things configured to automatically install packages simply because they are mentioned in "Recommends:" fields. i think it came preinstalled on my librem 14.

so perhaps a public advisory to uninstall "fwupd"? how will someone know if they need and/or are using this package? i haven't had time to investigate this myself. is there a quick recipe for finding out? can this be automated, or at least semi-automated so that the user will be presented with a query asking whether they want to solve the problem by uninstalling fwupd?