Page MenuHomePureOS Tracker

kodi-bin - outdated mariadb dependency
Open, HighPublic

Description

Installing all updates would have lead to removal of kodi.

I assume the dependency of kodi simply has to be changed from mariadbclient18 to libmariadb3, as in upstream?

Event Timeline

Caliga created this task.May 21 2019, 17:01
jonas.smedegaard triaged this task as Normal priority.
jonas.smedegaard raised the priority of this task from Normal to High.

@jonas.smedegaard

I tried to install Kodi with aptitude in an updated image of PureOS Amber and had several errors with dependencies:

kodi-bin : Depends: libavcodec57 (>= 7:3.4.1) which is a virtual package and is not provided by any available package
 or
                     libavcodec-extra57 (>= 7:3.4.1) which is a virtual package and is not provided by any available package

            Depends: libavfilter6 (>= 7:3.4.1) which is a virtual package and is not provided by any available package
 or
                     libavfilter-extra6 (>= 7:3.4.1) which is a virtual package and is not provided by any available package

            Depends: libavformat57 (>= 7:3.4.1) which is a virtual package and is not provided by any available package

            Depends: libavutil55 (>= 7:3.4.1) which is a virtual package and is not provided by any available package

            Depends: libcdio17 (>= 1.0.0) which is a virtual package and is not provided by any available package

            Depends: libmariadbclient18 (>= 10.1.28) which is a virtual package and is not provided by any available package

            Depends: libpostproc54 (>= 7:3.4.1) which is a virtual package and is not provided by any available package

            Depends: libswresample2 (>= 7:3.4.1) which is a virtual package and is not provided by any available package

            Depends: libswscale4 (>= 7:3.4.1) which is a virtual package and is not provided by any available package

Seems the mariadbclient18 to libmariadb3 os not the only dependency that needs changing

ChriChri added a subscriber: ChriChri.Nov 2 2019, 02:53

Looks like a lot of the dependencies use old versions.

---------------------------------------------------------------------------------

Depends: libavcodec57 (>= 7:3.4.1) but it is not installable or

                     libavcodec-extra57 (>= 7:3.4.1) but it is not installable

Should be: libavcodec58 and libavcodec-extra58

---------------------------------------------------------------------------------

Depends: libavfilter6 (>= 7:3.4.1) but it is not installable or

                     libavfilter-extra6 (>= 7:3.4.1) but it is not installable

Should be: libavfilter7 libavfilter-extra7

---------------------------------------------------------------------------------

            Depends: libavformat57 (>= 7:3.4.1) but it is

Should be: libavformat58

---------------------------------------------------------------------------------

            Depends: libavutil55 (>= 7:3.4.1) but it is not installable

Should be: libavutil56

---------------------------------------------------------------------------------

            Depends: libcdio17 (>= 1.0.0) but it is not installable

Should be: libcdio18

---------------------------------------------------------------------------------

            Depends: libmariadbclient18 (>= 10.1.28) but it is not installable

Should be: libmariadb3

---------------------------------------------------------------------------------

            Depends: libpostproc54 (>= 7:3.4.1) but it is not installable

Should be: libpostproc55

---------------------------------------------------------------------------------

            Depends: libswresample2 (>= 7:3.4.1) but it is not installable

Should be: libswresample3

---------------------------------------------------------------------------------

            Depends: libswscale4 (>= 7:3.4.1) but it is not installable

Should be: libswscale5

Where are the versions coming from? I was hoping to find them in https://source.puri.sm/pureos/packages/kodi/blob/master/debian/control

Can we retry this with the later Byzantium images? This bug was filed before there was an updated image.

reg added a subscriber: reg.Fri, Jul 17, 00:27
reg added a comment.EditedFri, Jul 17, 00:58

Tried to install Kodi on Byzantium this morning, here's what I got:

$ sudo apt install kodi
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kodi-bin : Depends: libavcodec57 (>= 7:3.4.1) but it is not installable or
                     libavcodec-extra57 (>= 7:3.4.1) but it is not installable
            Depends: libavfilter6 (>= 7:3.4.1) but it is not installable or
                     libavfilter-extra6 (>= 7:3.4.1) but it is not installable
            Depends: libavformat57 (>= 7:3.4.1) but it is not installable
            Depends: libavutil55 (>= 7:3.4.1) but it is not installable
            Depends: libcdio17 (>= 1.0.0) but it is not installable
            Depends: libmariadbclient18 (>= 10.1.28) but it is not installable
            Depends: libpostproc54 (>= 7:3.4.1) but it is not installable
            Depends: libswresample2 (>= 7:3.4.1) but it is not installable
            Depends: libswscale4 (>= 7:3.4.1) but it is not installable
            Recommends: libcec4 (>= 2.1.4) but it is not going to be installed
            Recommends: libnfs8 (>= 1.9.7) but it is not installable
E: Unable to correct problems, you have held broken packages.