Page MenuHomePureOS Tracker

HDMI output limited to 1080p
Open, NormalPublic

Description

Hardware: Librem 13 v2
Software: PureOS 8.0 with the latest kernel and updates
Desktop: Default Gnome with Wayland (also tested with Gnome + X11)

Problem: When I connect an external 4k monitor over HDMI, the GUI display configuration tool maxes out at 1920x1080--the same resolution as my laptop display. This would make sense if I were mirroring displays but in this case I'm selecting "Join Displays".

I also logged out and tried this with Gnome and X11 with the same result. When using X11, xrandr will not show any monitor modes higher than 1920x1080 for the HDMI display.

Reproduction Steps:

  • Connect external display with a native resolution greater than 1920x1080.
  • Launch Gnome Display configuration tool.
  • Select Join Displays.
  • Select the connected monitor instead of "Built-in Display"
  • Note the available resolutions in the "Resolution" drop-down menu. You should see no resolutions higher than 1920x1080.

Event Timeline

I've tested this so far with a few other Live disks including Tails (4.14.12-2 kernel), Fedora 27 (4.13.9-300.fc27.x86_64), Ubuntu 17.10 (4.13.0-21) and Ubuntu 16.04 (4.10.0-28-generic). All of those live disks had the same 1080p limitation.

I was able to get a higher resolution out of HDMI in Qubes 3.2 which uses an older Fedora userspace. I will continue to test older live CDs and see if I can find one that works like Qubes 3.2.

The Ubuntu 14.04 Live disk was able to see the full suite of resolutions from my external monitor up to 3840x2160 @ 30hz and 2560x1440 @ 60hz. It uses the 3.19.0-25-generic kernel so perhaps we are seeing some regression with Skylake on more recent 4.x kernels.

I noticed someone else complaining about a similar issue with Skylake on a Dell XPS: https://www.reddit.com/r/Dell/comments/4sjcyk/dell_xps_skylake_with_da200_only_1080p/

I was able to get a Librem 13v2 to output at 2560x1440 by switching to GNOME on Xorg at the GDM login prompt for my user and using the steps from here to generate a custom modeline.

In particular what I did to add the ideal resolution for my monitor was:

$ cvt -r 2560 1440
# 2560x1440 59.95 Hz (CVT 3.69M9-R) hsync: 88.79 kHz; pclk: 241.50 MHz
Modeline "2560x1440R"  241.50  2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync
$ xrandr --newmode "2560x1440R"  241.50  2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync
$ xrandr --addmode HDMI-1 2560x1440R
$ xrandr --output HDMI-1 --mode 2560x1440R

At this point the new mode shows up in GNOME's GUI "Displays" setting window. I also was able to follow the process in the above link to make it permanent by creating an /etc/X11/xorg.conf.d/ directory:

$ sudo mkdir /etc/X11/xorg.conf.d

and then creating an /etc/X11/xorg.conf.d/10-monitor.conf file with the following contents:

Section "Monitor"
        Identifier "HDMI-1"
        # 2560x1440 59.95 Hz (CVT 3.69M9-R) hsync: 88.79 kHz; pclk: 241.50 MHz
        Modeline "2560x1440R"  241.50  2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync
        Option "PreferredMode" "2560x1440R"
EndSection

Again, note that this is only a workaround if you are using Xorg and not Wayland (xrandr is read-only in Wayland).

From what I've read on https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/EDID/HOWTO.txt the kernel only includes EDIDs up to 1920x1080:

As a remedy for such situations, the kernel configuration item CONFIG_DRM_LOAD_EDID_FIRMWARE was introduced. It allows to provide an individually prepared or corrected EDID data set in the /lib/firmware directory from where it is loaded via the firmware interface. The code (see drivers/gpu/drm/drm_edid_load.c) contains built-in data sets for commonly used screen resolutions (800x600, 1024x768, 1280x1024, 1600x1200, 1680x1050, 1920x1080) as binary blobs, but the kernel source tree does not contain code to create these data. In order to elucidate the origin of the built-in binary EDID blobs and to facilitate the creation of individual data for a specific misbehaving monitor, commented sources and a Makefile environment are given here.

Since we maintain our own kernel for PureOS, I'm wondering whether we could add modes for 2560x1440, 2880x1800 and 3840x2160 within the kernel since clearly the kernel is too picky about EDIDs it is getting about higher resolutions from monitors.

I have tried several 4k monitors and and 3 OS's (pureos qubes and even windows 10) trying go get 4k on my new machine (it just arrived 5 days ago) and was getting concerned without having any positive results. I am anxiously looking for a way to achieve the 3840x2160 and 2560x1440 resolutions from this machine.

@netnut404 If you are willing to use X instead of Wayland, you can switch to that and follow my steps above to generate modelines for the resolutions you want.

@kyle.rankin Thanks using xorg is a good work around for now. Just picking that at login is simple enough I thought it was going to require a more substantial and permanent tweak / swap between wayland / xorg

jonkri added a subscriber: jonkri.EditedMar 12 2018, 16:10

I tried to use cvt -r 3840 2160 in order to produce a modeline for my system, and while I can see the resolution in the XFCE Display settings (after having configured xorg), I can't switch to it.

The modeline is:

Modeline "3840x2160R"  533.00 3840 3888 3920 4000  2160 2163 2168 2222 +hsync -vsync

If I'm trying to switch to the mode with xrandr --output HDMI-1 --mode 3840x2160R, I'm getting this error:

xrandr: Configure crtc 0 failed

I'm using Linux 4.14.18-1 with Qubes OS.

Any hints would be appreciated!

I have now tried using both Arch Linux and the latest Ubuntu installer in addition to Qubes OS, but I still have not been able to get a 4K resolution on a Librem13 laptop (ordered in January 2018).

Here's my 10-montors.conf file:

Section "Monitor"
        Identifier "HDMI-1"
        Modeline "3840x2160R"  533.00  3840 3888 3920 4000  2160 2163 2168 2222 +hsync -vsync
        Option "PreferredMode" "3840x2160R"
EndSection

I can see the resolution in XFCE's and GNOME's display utilities, but I can't activate it.

Trying to active the resolution using xrandr --output HDMI-1 --mode 3840x2160R produces the following error:

xrandr: Configure crtc 0 failed

If someone could provide me with a working modeline, or any other hints on how to get this working, I would really appreciate it.

A quick update:

I managed to find a working modeline for 4K output running at 25.99 Hz using cvt 3840 2160 26.

max4 added a subscriber: max4.Feb 6 2019, 02:43

Any news on how to get proper Hz rate on the Librem 13v2?

I can, like @jonkri , only get 26Hz.

Sincerely
Max

jeremiah.foster closed this task as Resolved.Feb 12 2019, 07:58

@jonkri Is it possible that there is a typo in the file name that prevents your window manager from picking it up? I ask that because you posted the contents of '10-montors.conf' and if that is the actual name of the file perhaps that is not getting read properly?

While I'm using a Librem, it is a 13v3 which is a version later than yours and don't have access to a v2 at the moment. I have no problem with higher resolutions however using GNOME Settings in the manner you specify;

jeremiah.foster reopened this task as Open.Feb 12 2019, 08:30
jeremiah.foster triaged this task as Normal priority.

As I believe kyle.rankin was suggesting, it would be nice to add EDID data sets to the pureos standard kernel for resolutions beyond what's already in there, especially the common "named" resolutions (like the one I need "WQXGA" aka 2560 × 1600). The named resolutions are described here: https://en.wikipedia.org/wiki/Graphics_display_resolution

I think it's not a solved problem if users have to switch from wayland to xorg or if we have to add boot parameters to make a monitor work.

If it's acceptable in this tracker I'd like to put a $50 bounty on this bug.

@actualben Thanks for your comment, this helps me. I'll try and read up a bit to understand exactly what we're bringing in and see what is required.

hansolo added a subscriber: hansolo.Feb 13 2019, 01:16
mladen added a subscriber: mladen.Apr 10 2019, 13:24

cvt 3840 2160 26 also works for me:

10-monitor.conf

Section "Monitor"
        Identifier "HDMI1"
        # 3840x2160 25.99 Hz (CVT) hsync: 57.05 kHz; pclk: 290.25 MHz
        Modeline "3840x2160_26.00"  290.25  3840 4064 4464 5088  2160 2163 2168 2195 -hsync +vsync
EndSection
richard.kolla added a subscriber: richard.kolla.EditedAug 22 2019, 10:49

E-mail below from customer having issues outputting more the 1080p on his Librem 13v4. Not running PureOS but similar issues. E-mailed back and forth a bit and he ended up running his monitor at 1080p and is no longer having issues.

Between this and the subtask added by Jeremiah, is this a hardware issue or software issue?

For the last couples of weeks I have had my Librem hooked up to an external monitor (UP2516D) by HDMI and experience some odd screen flickering. Maybe “flickering” is the wrong word, what happens is that the screen blanks at random intervals for about a second once every few minutes. I have struggled to establish any pattern, my best current guess is that it is correlated with CPU load as it becomes much more frequent once the fan starts spinning. It should also be emphasised that the laptop screen never flickers, I have confirmed this by observing flickering on the external monitor while the laptop monitored remained stable when I mirrored the output. I have investigated this issue on and off for about a week now, with no success, thus I am reaching out to you.
I run NixOS 19.03.173298.1f22d5b6f87 (Koi) – the latest stable version – and I believe [drm] Initialized i915 1.6.0 20180719 is the relevant line from the journalctl output. Based on [1,2] I believe that the latest upstream code available is running. Apologies for not running PureOS, running the same OS across my devices makes configuration easier – I am sure as heck going to run PureOS on my Librem 5 when it arrives.
[1]: https://github.com/NixOS/nixpkgs/blob/972ae117c6797e55ca4ba2f373f86683ae5dbe8c/pkgs/servers/x11/xorg/default.nix#L1966-L1977
[2]: https://cgit.freedesktop.org/xorg/driver/xf86-video-intel
There are multiple venues that I have explored to debug the issue, the first being what was mentioned about screen flickering on the PureOS wiki [3]. I have also browsed the PureOS source to see if there was anything unorthodox about the i915 setup, but I saw nothing – I could have missed something though, I am not intimately familiar with the source tree. Based on reading the Purism mailing lists, I did find a few flags to play with the i915 module, enable_rc6 and enable_psr, but both seem to have no effect on the issue. I have ruled out there being a port or cable issue on the part of the monitor as a second device works just fine with the same cable and monitor port.
[3]: https://tracker.pureos.net/w/troubleshooting/screen_flickering

Between this and the subtask added by Jeremiah, is this a hardware issue or software issue?

You're asking four questions here;

  1. Is this issue a hardware issue?
  2. Is this issue a software issue?
  3. Is the sub-issue a hardware issue?
  4. Is the sub-issue a software issue?

Each one is hard to answer on their own. :-)

Let's start with the issue that you just posted. You write that "he ended up running his monitor at 1080p and is no longer having issues." Do we need to investigate this further then? Or is this solved?

I would investigate further because we quote 4k 30Hz output on the v4 Librem Laptops and we can't if they seem to be tied down to 1920x1080p output.

It seems to be a hardware issue since in both cases users tried running in and/or editing X11 files but still can't output more than 1920x1080. Also used different distros like PureOS (GNOME, Wayland default but tried X11) and NixOS (Plasma 5, X11 default) and seemed to get the same result.

In this case;

For the last couples of weeks I have had my Librem hooked up to an external monitor (UP2516D) by HDMI and experience some odd screen flickering. Maybe “flickering” is the wrong word, what happens is that the screen blanks at random intervals for about a second once every few minutes. I have struggled to establish any pattern, my best current guess is that it is correlated with CPU load as it becomes much more frequent once the fan starts spinning. It should also be emphasised that the laptop screen never flickers, I have confirmed this by observing flickering on the external monitor while the laptop monitored remained stable when I mirrored the output. I have investigated this issue on and off for about a week now, with no success, thus I am reaching out to you.

I don't think it is a Librem 13v4 hardware issue. I have a Librem 13v3 (which runs the same graphics chipset) and I don't experience the issues he sees and I'm running at 3440x1440 (21:9). It *may* be his monitor but I can't tell and I can't debug the Nix OS issues. Nix is a great OS, but we work on PureOS of course and have to limit ourselves to that because it is complex enough.

I don't know what the next steps are for this particular case. Either he moves back to PureOS to debug the software or he tests the setup with a different monitor?

t1b0 added a subscriber: t1b0.EditedNov 22 2019, 13:11

HDMI output limited to 1080p

I confirm I have the same issue on my Librem 15 version 4 laptop (Intel HD Graphics 620 (Kaby Lake GT2)).

I have an external monitor BenQ 32" UHD 3840x2160@60. When I plug the HDMI cable, my laptop recognizes the monitor by its name, but it only outputs up to 1920x1080, not more. In the Display Settings, I tried the various Display Modes, Join Displays and Mirror, and I tried various HDMI cables, but the resolutions offered are only up to 1920x1080.

I am using the PureOS that comes with the laptop. It uses Wayland.

I tried the suggestion above by kyle.rankin, but the last command fails, maybe because it's Wayland, not X:

$ xrandr --verbose 
Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 8192 x 8192
XWAYLAND1 connected (normal left inverted right x axis y axis)
	Identifier: 0x3b0
	Timestamp:  2172374
	Subpixel:   unknown
	Clones:    
	CRTCs:      0
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
	non-desktop: 0 
		supported: 0, 1
  1920x1080 (0x3ae) 173.000MHz -HSync +VSync +preferred
        h: width  1920 start 2048 end 2248 total 2576 skew    0 clock  67.16KHz
        v: height 1080 start 1083 end 1088 total 1120           clock  59.96Hz
XWAYLAND3 connected (normal left inverted right x axis y axis)
	Identifier: 0x3b6
	Timestamp:  2172374
	Subpixel:   unknown
	Clones:    
	CRTCs:      1
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
	non-desktop: 0 
		supported: 0, 1
  1920x1080 (0x3b3) 172.750MHz -HSync +VSync +preferred
        h: width  1920 start 2048 end 2248 total 2576 skew    0 clock  67.06KHz
        v: height 1080 start 1083 end 1088 total 1120           clock  59.88Hz
  3840x2160R (0x3b4) 533.000MHz +HSync -VSync
        h: width  3840 start 3888 end 3920 total 4000 skew    0 clock 133.25KHz
        v: height 2160 start 2163 end 2168 total 2222           clock  59.97Hz

$ cvt -r 3840 2160
# 3840x2160 59.97 Hz (CVT 8.29M9-R) hsync: 133.25 kHz; pclk: 533.00 MHz
Modeline "3840x2160R"  533.00  3840 3888 3920 4000  2160 2163 2168 2222 +hsync -vsync
$ xrandr --newmode "3840x2160R"  533.00  3840 3888 3920 4000  2160 2163 2168 2222 +hsync -vsync
$ xrandr --addmode HDMI-1 3840x2160R
xrandr: cannot find output "HDMI-1"
$ xrandr --addmode XWAYLAND3 3840x2160R
$ xrandr --output XWAYLAND3 --mode 3840x2160R
xrandr: Configure crtc 1 failed
t1b0 added a comment.EditedNov 23 2019, 14:54

I tried the other half of kyle's suggestion about /etc/X11/xorg.conf.d/10-monitor.conf , then I rebooted, and I logged in with GNOME on Xorg, but it still doesn't display to the external monitor. I tried both the xrandr command and the Display Settings UI:

$ cvt -r 3840 2160
# 3840x2160 59.97 Hz (CVT 8.29M9-R) hsync: 133.25 kHz; pclk: 533.00 MHz
Modeline "3840x2160R"  533.00  3840 3888 3920 4000  2160 2163 2168 2222 +hsync -vsync
$ cat /etc/X11/xorg.conf.d/10-monitor.conf 
Section "Monitor"
        Identifier "HDMI-1"
        # 3840x2160 59.97 Hz (CVT 8.29M9-R) hsync: 133.25 kHz; pclk: 533.00 MHz
        Modeline "3840x2160R"  533.00  3840 3888 3920 4000  2160 2163 2168 2222 +hsync -vsync
        Option "PreferredMode" "3840x2160R"
EndSection
$ xrandr --addmode HDMI-1 3840x2160R
$ xrandr --output HDMI-1 --mode 3840x2160R
mladen added a comment.Nov 23 2019, 15:10

@t1b0 You have two errors:

  1. You cannot use 60Hz, try with cvt 3840 2160 26
  2. Identifier should be *HDMI1*, not *HDMI-1*
t1b0 added a comment.Nov 23 2019, 15:28

@mladen

I tried identifier HDMI1, but it doesn't work, the resolution disappears from the list, and xrandr throws this:

$ xrandr --output HDMI1 --mode "3840x2160_26.00"
warning: output HDMI1 not found; ignoring

So I'm back with identifier HDMI-1.

I tried these, but so far no luck:
2560x1440
3840x2160 26
3840x2160 30

Each time, I reboot, I login with GNOME on Xorg, and I try with the xrandr commands and the Display Settings UI.

I also tried with an Ubuntu 18.04 Live CD, and it also only offers up to 1920x1080, so the issue is not specific to PureOS.

Now that I'm GNOME on Xorg, here's the new output for xrandr, in case you spot something interesting:

$ xrandr --verbose
Screen 0: minimum 320 x 200, current 3840 x 2160, maximum 8192 x 8192
eDP-1 connected primary 3840x2160+0+0 (0x47) normal (normal left inverted right x axis y axis) 344mm x 194mm
	Identifier: 0x42
	Timestamp:  25758
	Subpixel:   unknown
	Gamma:      1.0:1.0:1.0
	Brightness: 1.0
	Clones:    
	CRTC:       0
	CRTCs:      0 1 2
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
	_MUTTER_PRESENTATION_OUTPUT: 0 
	EDID: 
		00ffffffffffff004c834b4300000000
		0018010395221378eace859e5b4c9426
		17505400000001010101010101010101
		010101010101d3cd0074f0703c803020
		250058c2100000190000000f00000000
		00000000003782054600000000fe0053
		414d53554e470a204c83464c000000fe
		00313536464c30322d3130310a20002b
	scaling mode: Full aspect 
		supported: Full, Center, Full aspect
	Broadcast RGB: Automatic 
		supported: Automatic, Full, Limited 16:235
	link-status: Good 
		supported: Good, Bad
	CONNECTOR_ID: 71 
		supported: 71
	non-desktop: 0 
		range: (0, 1)
  3840x2160 (0x47) 526.910MHz -HSync -VSync *current +preferred
        h: width  3840 start 3888 end 3920 total 3956 skew    0 clock 133.19KHz
        v: height 2160 start 2162 end 2167 total 2220           clock  60.00Hz
  3840x2160 (0x48) 712.750MHz -HSync +VSync
        h: width  3840 start 4160 end 4576 total 5312 skew    0 clock 134.18KHz
        v: height 2160 start 2163 end 2168 total 2237           clock  59.98Hz
  3840x2160 (0x49) 533.000MHz +HSync -VSync
        h: width  3840 start 3888 end 3920 total 4000 skew    0 clock 133.25KHz
        v: height 2160 start 2163 end 2168 total 2222           clock  59.97Hz
  3200x1800 (0x4a) 492.000MHz -HSync +VSync
        h: width  3200 start 3456 end 3800 total 4400 skew    0 clock 111.82KHz
        v: height 1800 start 1803 end 1808 total 1865           clock  59.96Hz
  3200x1800 (0x4b) 373.000MHz +HSync -VSync
        h: width  3200 start 3248 end 3280 total 3360 skew    0 clock 111.01KHz
        v: height 1800 start 1803 end 1808 total 1852           clock  59.94Hz
  2880x1620 (0x4c) 396.250MHz -HSync +VSync
        h: width  2880 start 3096 end 3408 total 3936 skew    0 clock 100.67KHz
        v: height 1620 start 1623 end 1628 total 1679           clock  59.96Hz
  2880x1620 (0x4d) 303.750MHz +HSync -VSync
        h: width  2880 start 2928 end 2960 total 3040 skew    0 clock  99.92KHz
        v: height 1620 start 1623 end 1628 total 1666           clock  59.97Hz
  2560x1600 (0x4e) 348.500MHz -HSync +VSync
        h: width  2560 start 2760 end 3032 total 3504 skew    0 clock  99.46KHz
        v: height 1600 start 1603 end 1609 total 1658           clock  59.99Hz
  2560x1600 (0x4f) 268.500MHz +HSync -VSync
        h: width  2560 start 2608 end 2640 total 2720 skew    0 clock  98.71KHz
        v: height 1600 start 1603 end 1609 total 1646           clock  59.97Hz
  2560x1440 (0x50) 638.250MHz -HSync +VSync DoubleScan
        h: width  2560 start 2780 end 3064 total 3568 skew    0 clock 178.88KHz
        v: height 1440 start 1441 end 1444 total 1491           clock  59.99Hz
  2560x1440 (0x51) 469.125MHz +HSync -VSync DoubleScan
        h: width  2560 start 2584 end 2600 total 2640 skew    0 clock 177.70KHz
        v: height 1440 start 1441 end 1444 total 1481           clock  59.99Hz
  2560x1440 (0x52) 312.250MHz -HSync +VSync
        h: width  2560 start 2752 end 3024 total 3488 skew    0 clock  89.52KHz
        v: height 1440 start 1443 end 1448 total 1493           clock  59.96Hz
  2560x1440 (0x53) 241.500MHz +HSync -VSync
        h: width  2560 start 2608 end 2640 total 2720 skew    0 clock  88.79KHz
        v: height 1440 start 1443 end 1448 total 1481           clock  59.95Hz
  2048x1536 (0x54) 266.950MHz -HSync +VSync
        h: width  2048 start 2200 end 2424 total 2800 skew    0 clock  95.34KHz
        v: height 1536 start 1537 end 1540 total 1589           clock  60.00Hz
  1920x1440 (0x55) 234.000MHz -HSync +VSync
        h: width  1920 start 2048 end 2256 total 2600 skew    0 clock  90.00KHz
        v: height 1440 start 1441 end 1444 total 1500           clock  60.00Hz
  1856x1392 (0x56) 218.300MHz -HSync +VSync
        h: width  1856 start 1952 end 2176 total 2528 skew    0 clock  86.35KHz
        v: height 1392 start 1393 end 1396 total 1439           clock  60.01Hz
  1792x1344 (0x57) 204.800MHz -HSync +VSync
        h: width  1792 start 1920 end 2120 total 2448 skew    0 clock  83.66KHz
        v: height 1344 start 1345 end 1348 total 1394           clock  60.01Hz
  2048x1152 (0x58) 406.500MHz -HSync +VSync DoubleScan
        h: width  2048 start 2220 end 2444 total 2840 skew    0 clock 143.13KHz
        v: height 1152 start 1153 end 1156 total 1193           clock  59.99Hz
  2048x1152 (0x59) 302.500MHz +HSync -VSync DoubleScan
        h: width  2048 start 2072 end 2088 total 2128 skew    0 clock 142.15KHz
        v: height 1152 start 1153 end 1156 total 1185           clock  59.98Hz
  2048x1152 (0x5a) 197.000MHz -HSync +VSync
        h: width  2048 start 2184 end 2400 total 2752 skew    0 clock  71.58KHz
        v: height 1152 start 1155 end 1160 total 1195           clock  59.90Hz
  2048x1152 (0x5b) 156.750MHz +HSync -VSync
        h: width  2048 start 2096 end 2128 total 2208 skew    0 clock  70.99KHz
        v: height 1152 start 1155 end 1160 total 1185           clock  59.91Hz
  1920x1200 (0x5c) 193.250MHz -HSync +VSync
        h: width  1920 start 2056 end 2256 total 2592 skew    0 clock  74.56KHz
        v: height 1200 start 1203 end 1209 total 1245           clock  59.88Hz
  1920x1200 (0x5d) 154.000MHz +HSync -VSync
        h: width  1920 start 1968 end 2000 total 2080 skew    0 clock  74.04KHz
        v: height 1200 start 1203 end 1209 total 1235           clock  59.95Hz
  1920x1080 (0x5e) 356.375MHz -HSync +VSync DoubleScan
        h: width  1920 start 2080 end 2288 total 2656 skew    0 clock 134.18KHz
        v: height 1080 start 1081 end 1084 total 1118           clock  60.01Hz
  1920x1080 (0x5f) 266.500MHz +HSync -VSync DoubleScan
        h: width  1920 start 1944 end 1960 total 2000 skew    0 clock 133.25KHz
        v: height 1080 start 1081 end 1084 total 1111           clock  59.97Hz
  1920x1080 (0x60) 173.000MHz -HSync +VSync
        h: width  1920 start 2048 end 2248 total 2576 skew    0 clock  67.16KHz
        v: height 1080 start 1083 end 1088 total 1120           clock  59.96Hz
  1920x1080 (0x61) 138.500MHz +HSync -VSync
        h: width  1920 start 1968 end 2000 total 2080 skew    0 clock  66.59KHz
        v: height 1080 start 1083 end 1088 total 1111           clock  59.93Hz
  1600x1200 (0x62) 162.000MHz +HSync +VSync
        h: width  1600 start 1664 end 1856 total 2160 skew    0 clock  75.00KHz
        v: height 1200 start 1201 end 1204 total 1250           clock  60.00Hz
  1680x1050 (0x63) 146.250MHz -HSync +VSync
        h: width  1680 start 1784 end 1960 total 2240 skew    0 clock  65.29KHz
        v: height 1050 start 1053 end 1059 total 1089           clock  59.95Hz
  1680x1050 (0x64) 119.000MHz +HSync -VSync
        h: width  1680 start 1728 end 1760 total 1840 skew    0 clock  64.67KHz
        v: height 1050 start 1053 end 1059 total 1080           clock  59.88Hz
  1600x1024 (0x65) 103.125MHz +HSync +VSync
        h: width  1600 start 1600 end 1656 total 1664 skew    0 clock  61.97KHz
        v: height 1024 start 1024 end 1029 total 1030           clock  60.17Hz
  1400x1050 (0x66) 122.000MHz +HSync +VSync
        h: width  1400 start 1488 end 1640 total 1880 skew    0 clock  64.89KHz
        v: height 1050 start 1052 end 1064 total 1082           clock  59.98Hz
  1600x900 (0x67) 246.000MHz -HSync +VSync DoubleScan
        h: width  1600 start 1728 end 1900 total 2200 skew    0 clock 111.82KHz
        v: height  900 start  901 end  904 total  932           clock  59.99Hz
  1600x900 (0x68) 186.500MHz +HSync -VSync DoubleScan
        h: width  1600 start 1624 end 1640 total 1680 skew    0 clock 111.01KHz
        v: height  900 start  901 end  904 total  926           clock  59.94Hz
  1600x900 (0x69) 118.250MHz -HSync +VSync
        h: width  1600 start 1696 end 1856 total 2112 skew    0 clock  55.99KHz
        v: height  900 start  903 end  908 total  934           clock  59.95Hz
  1600x900 (0x6a) 97.500MHz +HSync -VSync
        h: width  1600 start 1648 end 1680 total 1760 skew    0 clock  55.40KHz
        v: height  900 start  903 end  908 total  926           clock  59.82Hz
  1280x1024 (0x6b) 108.000MHz +HSync +VSync
        h: width  1280 start 1328 end 1440 total 1688 skew    0 clock  63.98KHz
        v: height 1024 start 1025 end 1028 total 1066           clock  60.02Hz
  1440x900 (0x6c) 106.500MHz -HSync +VSync
        h: width  1440 start 1520 end 1672 total 1904 skew    0 clock  55.93KHz
        v: height  900 start  903 end  909 total  934           clock  59.89Hz
  1400x900 (0x6d) 103.500MHz -HSync +VSync
        h: width  1400 start 1480 end 1624 total 1848 skew    0 clock  56.01KHz
        v: height  900 start  903 end  913 total  934           clock  59.96Hz
  1400x900 (0x6e) 86.500MHz +HSync -VSync
        h: width  1400 start 1448 end 1480 total 1560 skew    0 clock  55.45KHz
        v: height  900 start  903 end  913 total  926           clock  59.88Hz
  1280x960 (0x6f) 108.000MHz +HSync +VSync
        h: width  1280 start 1376 end 1488 total 1800 skew    0 clock  60.00KHz
        v: height  960 start  961 end  964 total 1000           clock  60.00Hz
  1440x810 (0x70) 198.125MHz -HSync +VSync DoubleScan
        h: width  1440 start 1548 end 1704 total 1968 skew    0 clock 100.67KHz
        v: height  810 start  811 end  814 total  839           clock  60.00Hz
  1440x810 (0x71) 151.875MHz +HSync -VSync DoubleScan
        h: width  1440 start 1464 end 1480 total 1520 skew    0 clock  99.92KHz
        v: height  810 start  811 end  814 total  833           clock  59.97Hz
  1368x768 (0x72) 85.250MHz -HSync +VSync
        h: width  1368 start 1440 end 1576 total 1784 skew    0 clock  47.79KHz
        v: height  768 start  771 end  781 total  798           clock  59.88Hz
  1368x768 (0x73) 72.250MHz +HSync -VSync
        h: width  1368 start 1416 end 1448 total 1528 skew    0 clock  47.28KHz
        v: height  768 start  771 end  781 total  790           clock  59.85Hz
  1360x768 (0x74) 84.750MHz -HSync +VSync
        h: width  1360 start 1432 end 1568 total 1776 skew    0 clock  47.72KHz
        v: height  768 start  771 end  781 total  798           clock  59.80Hz
  1360x768 (0x75) 72.000MHz +HSync -VSync
        h: width  1360 start 1408 end 1440 total 1520 skew    0 clock  47.37KHz
        v: height  768 start  771 end  781 total  790           clock  59.96Hz
  1280x800 (0x76) 174.250MHz -HSync +VSync DoubleScan
        h: width  1280 start 1380 end 1516 total 1752 skew    0 clock  99.46KHz
        v: height  800 start  801 end  804 total  829           clock  59.99Hz
  1280x800 (0x77) 134.250MHz +HSync -VSync DoubleScan
        h: width  1280 start 1304 end 1320 total 1360 skew    0 clock  98.71KHz
        v: height  800 start  801 end  804 total  823           clock  59.97Hz
  1280x800 (0x78) 83.500MHz -HSync +VSync
        h: width  1280 start 1352 end 1480 total 1680 skew    0 clock  49.70KHz
        v: height  800 start  803 end  809 total  831           clock  59.81Hz
  1280x800 (0x79) 71.000MHz +HSync -VSync
        h: width  1280 start 1328 end 1360 total 1440 skew    0 clock  49.31KHz
        v: height  800 start  803 end  809 total  823           clock  59.91Hz
  1152x864 (0x7a) 81.620MHz -HSync +VSync
        h: width  1152 start 1216 end 1336 total 1520 skew    0 clock  53.70KHz
        v: height  864 start  865 end  868 total  895           clock  60.00Hz
  1280x720 (0x7b) 156.125MHz -HSync +VSync DoubleScan
        h: width  1280 start 1376 end 1512 total 1744 skew    0 clock  89.52KHz
        v: height  720 start  721 end  724 total  746           clock  60.00Hz
  1280x720 (0x7c) 120.750MHz +HSync -VSync DoubleScan
        h: width  1280 start 1304 end 1320 total 1360 skew    0 clock  88.79KHz
        v: height  720 start  721 end  724 total  740           clock  59.99Hz
  1280x720 (0x7d) 74.500MHz -HSync +VSync
        h: width  1280 start 1344 end 1472 total 1664 skew    0 clock  44.77KHz
        v: height  720 start  723 end  728 total  748           clock  59.86Hz
  1280x720 (0x7e) 63.750MHz +HSync -VSync
        h: width  1280 start 1328 end 1360 total 1440 skew    0 clock  44.27KHz
        v: height  720 start  723 end  728 total  741           clock  59.74Hz
  1024x768 (0x7f) 133.475MHz -HSync +VSync DoubleScan
        h: width  1024 start 1100 end 1212 total 1400 skew    0 clock  95.34KHz
        v: height  768 start  768 end  770 total  794           clock  60.04Hz
  1024x768 (0x80) 65.000MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock  48.36KHz
        v: height  768 start  771 end  777 total  806           clock  60.00Hz
  960x720 (0x81) 117.000MHz -HSync +VSync DoubleScan
        h: width   960 start 1024 end 1128 total 1300 skew    0 clock  90.00KHz
        v: height  720 start  720 end  722 total  750           clock  60.00Hz
  928x696 (0x82) 109.150MHz -HSync +VSync DoubleScan
        h: width   928 start  976 end 1088 total 1264 skew    0 clock  86.35KHz
        v: height  696 start  696 end  698 total  719           clock  60.05Hz
  896x672 (0x83) 102.400MHz -HSync +VSync DoubleScan
        h: width   896 start  960 end 1060 total 1224 skew    0 clock  83.66KHz
        v: height  672 start  672 end  674 total  697           clock  60.01Hz
  1024x576 (0x84) 98.500MHz -HSync +VSync DoubleScan
        h: width  1024 start 1092 end 1200 total 1376 skew    0 clock  71.58KHz
        v: height  576 start  577 end  580 total  597           clock  59.95Hz
  1024x576 (0x85) 78.375MHz +HSync -VSync DoubleScan
        h: width  1024 start 1048 end 1064 total 1104 skew    0 clock  70.99KHz
        v: height  576 start  577 end  580 total  592           clock  59.96Hz
  1024x576 (0x86) 46.500MHz -HSync +VSync
        h: width  1024 start 1064 end 1160 total 1296 skew    0 clock  35.88KHz
        v: height  576 start  579 end  584 total  599           clock  59.90Hz
  1024x576 (0x87) 42.000MHz +HSync -VSync
        h: width  1024 start 1072 end 1104 total 1184 skew    0 clock  35.47KHz
        v: height  576 start  579 end  584 total  593           clock  59.82Hz
  960x600 (0x88) 96.625MHz -HSync +VSync DoubleScan
        h: width   960 start 1028 end 1128 total 1296 skew    0 clock  74.56KHz
        v: height  600 start  601 end  604 total  622           clock  59.93Hz
  960x600 (0x89) 77.000MHz +HSync -VSync DoubleScan
        h: width   960 start  984 end 1000 total 1040 skew    0 clock  74.04KHz
        v: height  600 start  601 end  604 total  617           clock  60.00Hz
  960x540 (0x8a) 86.500MHz -HSync +VSync DoubleScan
        h: width   960 start 1024 end 1124 total 1288 skew    0 clock  67.16KHz
        v: height  540 start  541 end  544 total  560           clock  59.96Hz
  960x540 (0x8b) 69.250MHz +HSync -VSync DoubleScan
        h: width   960 start  984 end 1000 total 1040 skew    0 clock  66.59KHz
        v: height  540 start  541 end  544 total  555           clock  59.99Hz
  960x540 (0x8c) 40.750MHz -HSync +VSync
        h: width   960 start  992 end 1088 total 1216 skew    0 clock  33.51KHz
        v: height  540 start  543 end  548 total  562           clock  59.63Hz
  960x540 (0x8d) 37.250MHz +HSync -VSync
        h: width   960 start 1008 end 1040 total 1120 skew    0 clock  33.26KHz
        v: height  540 start  543 end  548 total  556           clock  59.82Hz
  800x600 (0x8e) 81.000MHz +HSync +VSync DoubleScan
        h: width   800 start  832 end  928 total 1080 skew    0 clock  75.00KHz
        v: height  600 start  600 end  602 total  625           clock  60.00Hz
  800x600 (0x8f) 40.000MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock  37.88KHz
        v: height  600 start  601 end  605 total  628           clock  60.32Hz
  800x600 (0x90) 36.000MHz +HSync +VSync
        h: width   800 start  824 end  896 total 1024 skew    0 clock  35.16KHz
        v: height  600 start  601 end  603 total  625           clock  56.25Hz
  840x525 (0x91) 73.125MHz -HSync +VSync DoubleScan
        h: width   840 start  892 end  980 total 1120 skew    0 clock  65.29KHz
        v: height  525 start  526 end  529 total  544           clock  60.01Hz
  840x525 (0x92) 59.500MHz +HSync -VSync DoubleScan
        h: width   840 start  864 end  880 total  920 skew    0 clock  64.67KHz
        v: height  525 start  526 end  529 total  540           clock  59.88Hz
  864x486 (0x93) 32.500MHz -HSync +VSync
        h: width   864 start  888 end  968 total 1072 skew    0 clock  30.32KHz
        v: height  486 start  489 end  494 total  506           clock  59.92Hz
  864x486 (0x94) 30.500MHz +HSync -VSync
        h: width   864 start  912 end  944 total 1024 skew    0 clock  29.79KHz
        v: height  486 start  489 end  494 total  500           clock  59.57Hz
  800x512 (0x95) 51.562MHz +HSync +VSync DoubleScan
        h: width   800 start  800 end  828 total  832 skew    0 clock  61.97KHz
        v: height  512 start  512 end  514 total  515           clock  60.17Hz
  700x525 (0x96) 61.000MHz +HSync +VSync DoubleScan
        h: width   700 start  744 end  820 total  940 skew    0 clock  64.89KHz
        v: height  525 start  526 end  532 total  541           clock  59.98Hz
  800x450 (0x97) 59.125MHz -HSync +VSync DoubleScan
        h: width   800 start  848 end  928 total 1056 skew    0 clock  55.99KHz
        v: height  450 start  451 end  454 total  467           clock  59.95Hz
  800x450 (0x98) 48.750MHz +HSync -VSync DoubleScan
        h: width   800 start  824 end  840 total  880 skew    0 clock  55.40KHz
        v: height  450 start  451 end  454 total  463           clock  59.82Hz
  640x512 (0x99) 54.000MHz +HSync +VSync DoubleScan
        h: width   640 start  664 end  720 total  844 skew    0 clock  63.98KHz
        v: height  512 start  512 end  514 total  533           clock  60.02Hz
  720x450 (0x9a) 53.250MHz -HSync +VSync DoubleScan
        h: width   720 start  760 end  836 total  952 skew    0 clock  55.93KHz
        v: height  450 start  451 end  454 total  467           clock  59.89Hz
  700x450 (0x9b) 51.750MHz -HSync +VSync DoubleScan
        h: width   700 start  740 end  812 total  924 skew    0 clock  56.01KHz
        v: height  450 start  451 end  456 total  467           clock  59.96Hz
  700x450 (0x9c) 43.250MHz +HSync -VSync DoubleScan
        h: width   700 start  724 end  740 total  780 skew    0 clock  55.45KHz
        v: height  450 start  451 end  456 total  463           clock  59.88Hz
  640x480 (0x9d) 54.000MHz +HSync +VSync DoubleScan
        h: width   640 start  688 end  744 total  900 skew    0 clock  60.00KHz
        v: height  480 start  480 end  482 total  500           clock  60.00Hz
  640x480 (0x9e) 25.175MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock  31.47KHz
        v: height  480 start  490 end  492 total  525           clock  59.94Hz
  720x405 (0x9f) 22.500MHz -HSync +VSync
        h: width   720 start  744 end  808 total  896 skew    0 clock  25.11KHz
        v: height  405 start  408 end  413 total  422           clock  59.51Hz
  720x405 (0xa0) 21.750MHz +HSync -VSync
        h: width   720 start  768 end  800 total  880 skew    0 clock  24.72KHz
        v: height  405 start  408 end  413 total  419           clock  58.99Hz
  684x384 (0xa1) 42.625MHz -HSync +VSync DoubleScan
        h: width   684 start  720 end  788 total  892 skew    0 clock  47.79KHz
        v: height  384 start  385 end  390 total  399           clock  59.88Hz
  684x384 (0xa2) 36.125MHz +HSync -VSync DoubleScan
        h: width   684 start  708 end  724 total  764 skew    0 clock  47.28KHz
        v: height  384 start  385 end  390 total  395           clock  59.85Hz
  680x384 (0xa3) 42.375MHz -HSync +VSync DoubleScan
        h: width   680 start  716 end  784 total  888 skew    0 clock  47.72KHz
        v: height  384 start  385 end  390 total  399           clock  59.80Hz
  680x384 (0xa4) 36.000MHz +HSync -VSync DoubleScan
        h: width   680 start  704 end  720 total  760 skew    0 clock  47.37KHz
        v: height  384 start  385 end  390 total  395           clock  59.96Hz
  640x400 (0xa5) 41.750MHz -HSync +VSync DoubleScan
        h: width   640 start  676 end  740 total  840 skew    0 clock  49.70KHz
        v: height  400 start  401 end  404 total  415           clock  59.88Hz
  640x400 (0xa6) 35.500MHz +HSync -VSync DoubleScan
        h: width   640 start  664 end  680 total  720 skew    0 clock  49.31KHz
        v: height  400 start  401 end  404 total  411           clock  59.98Hz
  576x432 (0xa7) 40.810MHz -HSync +VSync DoubleScan
        h: width   576 start  608 end  668 total  760 skew    0 clock  53.70KHz
        v: height  432 start  432 end  434 total  447           clock  60.06Hz
  640x360 (0xa8) 37.250MHz -HSync +VSync DoubleScan
        h: width   640 start  672 end  736 total  832 skew    0 clock  44.77KHz
        v: height  360 start  361 end  364 total  374           clock  59.86Hz
  640x360 (0xa9) 31.875MHz +HSync -VSync DoubleScan
        h: width   640 start  664 end  680 total  720 skew    0 clock  44.27KHz
        v: height  360 start  361 end  364 total  370           clock  59.83Hz
  640x360 (0xaa) 18.000MHz -HSync +VSync
        h: width   640 start  664 end  720 total  800 skew    0 clock  22.50KHz
        v: height  360 start  363 end  368 total  376           clock  59.84Hz
  640x360 (0xab) 17.750MHz +HSync -VSync
        h: width   640 start  688 end  720 total  800 skew    0 clock  22.19KHz
        v: height  360 start  363 end  368 total  374           clock  59.32Hz
  512x384 (0xac) 32.500MHz -HSync -VSync DoubleScan
        h: width   512 start  524 end  592 total  672 skew    0 clock  48.36KHz
        v: height  384 start  385 end  388 total  403           clock  60.00Hz
  512x288 (0xad) 23.250MHz -HSync +VSync DoubleScan
        h: width   512 start  532 end  580 total  648 skew    0 clock  35.88KHz
        v: height  288 start  289 end  292 total  299           clock  60.00Hz
  512x288 (0xae) 21.000MHz +HSync -VSync DoubleScan
        h: width   512 start  536 end  552 total  592 skew    0 clock  35.47KHz
        v: height  288 start  289 end  292 total  296           clock  59.92Hz
  480x270 (0xaf) 20.375MHz -HSync +VSync DoubleScan
        h: width   480 start  496 end  544 total  608 skew    0 clock  33.51KHz
        v: height  270 start  271 end  274 total  281           clock  59.63Hz
  480x270 (0xb0) 18.625MHz +HSync -VSync DoubleScan
        h: width   480 start  504 end  520 total  560 skew    0 clock  33.26KHz
        v: height  270 start  271 end  274 total  278           clock  59.82Hz
  400x300 (0xb1) 20.000MHz +HSync +VSync DoubleScan
        h: width   400 start  420 end  484 total  528 skew    0 clock  37.88KHz
        v: height  300 start  300 end  302 total  314           clock  60.32Hz
  400x300 (0xb2) 18.000MHz +HSync +VSync DoubleScan
        h: width   400 start  412 end  448 total  512 skew    0 clock  35.16KHz
        v: height  300 start  300 end  301 total  312           clock  56.34Hz
  432x243 (0xb3) 16.250MHz -HSync +VSync DoubleScan
        h: width   432 start  444 end  484 total  536 skew    0 clock  30.32KHz
        v: height  243 start  244 end  247 total  253           clock  59.92Hz
  432x243 (0xb4) 15.250MHz +HSync -VSync DoubleScan
        h: width   432 start  456 end  472 total  512 skew    0 clock  29.79KHz
        v: height  243 start  244 end  247 total  250           clock  59.57Hz
  320x240 (0xb5) 12.587MHz -HSync -VSync DoubleScan
        h: width   320 start  328 end  376 total  400 skew    0 clock  31.47KHz
        v: height  240 start  245 end  246 total  262           clock  60.05Hz
  360x202 (0xb6) 11.250MHz -HSync +VSync DoubleScan
        h: width   360 start  372 end  404 total  448 skew    0 clock  25.11KHz
        v: height  202 start  204 end  206 total  211           clock  59.51Hz
  360x202 (0xb7) 10.875MHz +HSync -VSync DoubleScan
        h: width   360 start  384 end  400 total  440 skew    0 clock  24.72KHz
        v: height  202 start  204 end  206 total  209           clock  59.13Hz
  320x180 (0xb8)  9.000MHz -HSync +VSync DoubleScan
        h: width   320 start  332 end  360 total  400 skew    0 clock  22.50KHz
        v: height  180 start  181 end  184 total  188           clock  59.84Hz
  320x180 (0xb9)  8.875MHz +HSync -VSync DoubleScan
        h: width   320 start  344 end  360 total  400 skew    0 clock  22.19KHz
        v: height  180 start  181 end  184 total  187           clock  59.32Hz
DP-1 disconnected (normal left inverted right x axis y axis)
	Identifier: 0x43
	Timestamp:  25758
	Subpixel:   unknown
	Clones:     HDMI-1
	CRTCs:      0 1 2
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
	Content Protection: Undesired 
		supported: Undesired, Desired, Enabled
	Broadcast RGB: Automatic 
		supported: Automatic, Full, Limited 16:235
	audio: auto 
		supported: force-dvi, off, auto, on
	link-status: Good 
		supported: Good, Bad
	CONNECTOR_ID: 78 
		supported: 78
	non-desktop: 0 
		range: (0, 1)
HDMI-1 connected (normal left inverted right x axis y axis)
	Identifier: 0x44
	Timestamp:  25758
	Subpixel:   unknown
	Clones:     DP-1
	CRTCs:      0 1 2
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
	EDID: 
		00ffffffffffff0009d1208045540000
		031a0103804728782e7690a8544d9f25
		0e5054a56b80d1c081c081008180a9c0
		b3000101010104740030f2705a80b058
		8a00c48f2100001a000000ff00453147
		3030353439534c300a20000000fd001e
		4c1e581e000a202020202020000000fc
		0042656e51204c43440a202020200114
		020324f14f9005040302011112131406
		0715161f2309070767030c001000383c
		83010000023a801871382d40582c4500
		c48f2100001f011d8018711c1620582c
		2500c48f2100009f011d007251d01e20
		6e285500c48f2100001e8c0ad08a20e0
		2d10103e9600c48f21000018565e00a0
		a0a0295030203500c48f2100001a00fb
	Content Protection: Undesired 
		supported: Undesired, Desired, Enabled
	content type: No Data 
		supported: No Data, Graphics, Photo, Cinema, Game
	aspect ratio: Automatic 
		supported: Automatic, 4:3, 16:9
	Broadcast RGB: Automatic 
		supported: Automatic, Full, Limited 16:235
	audio: auto 
		supported: force-dvi, off, auto, on
	link-status: Good 
		supported: Good, Bad
	CONNECTOR_ID: 84 
		supported: 84
	non-desktop: 0 
		range: (0, 1)
  3840x2160_26.00 (0xba) 290.250MHz -HSync +VSync +preferred
        h: width  3840 start 4064 end 4464 total 5088 skew    0 clock  57.05KHz
        v: height 2160 start 2163 end 2168 total 2195           clock  25.99Hz
  1920x1080 (0xbb) 148.500MHz +HSync +VSync
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  67.50KHz
        v: height 1080 start 1084 end 1089 total 1125           clock  60.00Hz
  1920x1080 (0xbc) 148.500MHz +HSync +VSync
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  67.50KHz
        v: height 1080 start 1084 end 1089 total 1125           clock  60.00Hz
  1920x1080 (0xbd) 148.500MHz +HSync +VSync
        h: width  1920 start 2448 end 2492 total 2640 skew    0 clock  56.25KHz
        v: height 1080 start 1084 end 1089 total 1125           clock  50.00Hz
  1920x1080 (0xbe) 148.352MHz +HSync +VSync
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  67.43KHz
        v: height 1080 start 1084 end 1089 total 1125           clock  59.94Hz
  1920x1080i (0xbf) 74.250MHz +HSync +VSync Interlace
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  33.75KHz
        v: height 1080 start 1084 end 1094 total 1125           clock  60.00Hz
  1920x1080i (0xc0) 74.250MHz +HSync +VSync Interlace
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  33.75KHz
        v: height 1080 start 1084 end 1094 total 1125           clock  60.00Hz
  1920x1080i (0xc1) 74.250MHz +HSync +VSync Interlace
        h: width  1920 start 2448 end 2492 total 2640 skew    0 clock  28.12KHz
        v: height 1080 start 1084 end 1094 total 1125           clock  50.00Hz
  1920x1080i (0xc2) 74.176MHz +HSync +VSync Interlace
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  33.72KHz
        v: height 1080 start 1084 end 1094 total 1125           clock  59.94Hz
  1680x1050 (0x64) 119.000MHz +HSync -VSync
        h: width  1680 start 1728 end 1760 total 1840 skew    0 clock  64.67KHz
        v: height 1050 start 1053 end 1059 total 1080           clock  59.88Hz
  1600x900 (0xc3) 108.000MHz +HSync +VSync
        h: width  1600 start 1624 end 1704 total 1800 skew    0 clock  60.00KHz
        v: height  900 start  901 end  904 total 1000           clock  60.00Hz
  1280x1024 (0xc4) 135.000MHz +HSync +VSync
        h: width  1280 start 1296 end 1440 total 1688 skew    0 clock  79.98KHz
        v: height 1024 start 1025 end 1028 total 1066           clock  75.02Hz
  1280x1024 (0x6b) 108.000MHz +HSync +VSync
        h: width  1280 start 1328 end 1440 total 1688 skew    0 clock  63.98KHz
        v: height 1024 start 1025 end 1028 total 1066           clock  60.02Hz
  1280x800 (0x79) 71.000MHz +HSync -VSync
        h: width  1280 start 1328 end 1360 total 1440 skew    0 clock  49.31KHz
        v: height  800 start  803 end  809 total  823           clock  59.91Hz
  1152x864 (0xc5) 108.000MHz +HSync +VSync
        h: width  1152 start 1216 end 1344 total 1600 skew    0 clock  67.50KHz
        v: height  864 start  865 end  868 total  900           clock  75.00Hz
  1280x720 (0xc6) 74.250MHz +HSync +VSync
        h: width  1280 start 1390 end 1430 total 1650 skew    0 clock  45.00KHz
        v: height  720 start  725 end  730 total  750           clock  60.00Hz
  1280x720 (0xc7) 74.250MHz +HSync +VSync
        h: width  1280 start 1390 end 1430 total 1650 skew    0 clock  45.00KHz
        v: height  720 start  725 end  730 total  750           clock  60.00Hz
  1280x720 (0xc8) 74.250MHz +HSync +VSync
        h: width  1280 start 1720 end 1760 total 1980 skew    0 clock  37.50KHz
        v: height  720 start  725 end  730 total  750           clock  50.00Hz
  1280x720 (0xc9) 74.176MHz +HSync +VSync
        h: width  1280 start 1390 end 1430 total 1650 skew    0 clock  44.96KHz
        v: height  720 start  725 end  730 total  750           clock  59.94Hz
  1024x768 (0xca) 78.750MHz +HSync +VSync
        h: width  1024 start 1040 end 1136 total 1312 skew    0 clock  60.02KHz
        v: height  768 start  769 end  772 total  800           clock  75.03Hz
  1024x768 (0x80) 65.000MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock  48.36KHz
        v: height  768 start  771 end  777 total  806           clock  60.00Hz
  832x624 (0xcb) 57.284MHz -HSync -VSync
        h: width   832 start  864 end  928 total 1152 skew    0 clock  49.73KHz
        v: height  624 start  625 end  628 total  667           clock  74.55Hz
  800x600 (0xcc) 49.500MHz +HSync +VSync
        h: width   800 start  816 end  896 total 1056 skew    0 clock  46.88KHz
        v: height  600 start  601 end  604 total  625           clock  75.00Hz
  800x600 (0x8f) 40.000MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock  37.88KHz
        v: height  600 start  601 end  605 total  628           clock  60.32Hz
  720x576 (0xcd) 27.000MHz -HSync -VSync
        h: width   720 start  732 end  796 total  864 skew    0 clock  31.25KHz
        v: height  576 start  581 end  586 total  625           clock  50.00Hz
  720x576 (0xce) 27.000MHz -HSync -VSync
        h: width   720 start  732 end  796 total  864 skew    0 clock  31.25KHz
        v: height  576 start  581 end  586 total  625           clock  50.00Hz
  720x576i (0xcf) 13.500MHz -HSync -VSync Interlace
        h: width   720 start  732 end  795 total  864 skew    0 clock  15.62KHz
        v: height  576 start  580 end  586 total  625           clock  50.00Hz
  720x576i (0xd0) 13.500MHz -HSync -VSync Interlace
        h: width   720 start  732 end  795 total  864 skew    0 clock  15.62KHz
        v: height  576 start  580 end  586 total  625           clock  50.00Hz
  720x480 (0xd1) 27.027MHz -HSync -VSync
        h: width   720 start  736 end  798 total  858 skew    0 clock  31.50KHz
        v: height  480 start  489 end  495 total  525           clock  60.00Hz
  720x480 (0xd2) 27.027MHz -HSync -VSync
        h: width   720 start  736 end  798 total  858 skew    0 clock  31.50KHz
        v: height  480 start  489 end  495 total  525           clock  60.00Hz
  720x480 (0xd3) 27.000MHz -HSync -VSync
        h: width   720 start  736 end  798 total  858 skew    0 clock  31.47KHz
        v: height  480 start  489 end  495 total  525           clock  59.94Hz
  720x480 (0xd4) 27.000MHz -HSync -VSync
        h: width   720 start  736 end  798 total  858 skew    0 clock  31.47KHz
        v: height  480 start  489 end  495 total  525           clock  59.94Hz
  720x480 (0xd5) 27.000MHz -HSync -VSync
        h: width   720 start  736 end  798 total  858 skew    0 clock  31.47KHz
        v: height  480 start  489 end  495 total  525           clock  59.94Hz
  720x480i (0xd6) 13.514MHz -HSync -VSync Interlace
        h: width   720 start  739 end  801 total  858 skew    0 clock  15.75KHz
        v: height  480 start  488 end  494 total  525           clock  60.00Hz
  720x480i (0xd7) 13.514MHz -HSync -VSync Interlace
        h: width   720 start  739 end  801 total  858 skew    0 clock  15.75KHz
        v: height  480 start  488 end  494 total  525           clock  60.00Hz
  720x480i (0xd8) 13.500MHz -HSync -VSync Interlace
        h: width   720 start  739 end  801 total  858 skew    0 clock  15.73KHz
        v: height  480 start  488 end  494 total  525           clock  59.94Hz
  720x480i (0xd9) 13.500MHz -HSync -VSync Interlace
        h: width   720 start  739 end  801 total  858 skew    0 clock  15.73KHz
        v: height  480 start  488 end  494 total  525           clock  59.94Hz
  640x480 (0xda) 31.500MHz -HSync -VSync
        h: width   640 start  656 end  720 total  840 skew    0 clock  37.50KHz
        v: height  480 start  481 end  484 total  500           clock  75.00Hz
  640x480 (0xdb) 25.200MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock  31.50KHz
        v: height  480 start  490 end  492 total  525           clock  60.00Hz
  640x480 (0x9e) 25.175MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock  31.47KHz
        v: height  480 start  490 end  492 total  525           clock  59.94Hz
  640x480 (0xdc) 25.175MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock  31.47KHz
        v: height  480 start  490 end  492 total  525           clock  59.94Hz
  720x400 (0xdd) 28.320MHz -HSync +VSync
        h: width   720 start  738 end  846 total  900 skew    0 clock  31.47KHz
        v: height  400 start  412 end  414 total  449           clock  70.08Hz
HDMI-2 disconnected (normal left inverted right x axis y axis)
	Identifier: 0x45
	Timestamp:  25758
	Subpixel:   unknown
	Clones:    
	CRTCs:      0 1 2
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
	Content Protection: Undesired 
		supported: Undesired, Desired, Enabled
	content type: No Data 
		supported: No Data, Graphics, Photo, Cinema, Game
	aspect ratio: Automatic 
		supported: Automatic, 4:3, 16:9
	Broadcast RGB: Automatic 
		supported: Automatic, Full, Limited 16:235
	audio: auto 
		supported: force-dvi, off, auto, on
	link-status: Good 
		supported: Good, Bad
	CONNECTOR_ID: 89 
		supported: 89
	non-desktop: 0 
		range: (0, 1)
t1b0 added a comment.EditedNov 23 2019, 15:36

@mladen , it did actually work with 3840 2160 26. I don't know what I had missed earlier. I now have 4K on my external monitor, Join Displays and Mirror, both work. Thanks!!!

$ cvt 3840 2160 26
# 3840x2160 25.99 Hz (CVT) hsync: 57.05 kHz; pclk: 290.25 MHz
Modeline "3840x2160_26.00"  290.25  3840 4064 4464 5088  2160 2163 2168 2195 -hsync +vsync
$ cat /etc/X11/xorg.conf.d/10-monitor.conf 
Section "Monitor"
        Identifier "HDMI-1"
        # 3840x2160 25.99 Hz (CVT) hsync: 57.05 kHz; pclk: 290.25 MHz
        Modeline "3840x2160_26.00"  290.25  3840 4064 4464 5088  2160 2163 2168 2195 -hsync +vsync
        Option "PreferredMode" "3840x2160_26.00"
EndSection
$ xrandr --addmode HDMI-1 "3840x2160_26.00"
$ xrandr --output HDMI-1 --mode "3840x2160_26.00"
siraaj added a subscriber: siraaj.Nov 24 2019, 11:56
siraaj added a comment.EditedNov 24 2019, 12:18

None of the above-mentioned modelines have worked for me on Librem 15v4 with a 3440x1440 monitor. Only the autodetected 1920x1080 outputs anything at all on the screen. Running Xorg and Debian 10.