Page MenuHomePureOS Tracker

External screens (HDMI) only up to fullHD - no 4k at all
Open, Needs TriagePublic

Description

A user reported in our forums:
https://forums.puri.sm/t/no-4k-output-with-external-monitor/6653

I tried that some time ago (back in May IIRC) and it worked on the 4k TV we have in the office. I tried that with my L13 laptop and my home built kernel and Todd tried with his L13 and vanilla PureOS and both presented 4k@30Hz options. Current PureOS with PureOS kernel and upgrade 5.3 kernel does not come present a 4k option in Gnome. I checked with edid-decode, the screen is properly detected and 4k resolutions are defined in EDID.

I tried on some laptops here locally, I am pretty sure this is unrelated to hardware. I can not exactly pinpoint the time of breakage though. Interesting the latest PureOS booted from USB does work (IIRC this is the latest ISO).

Related Objects

Event Timeline

nicole created this task.Sep 18 2019, 12:36
nicole added a comment.Sep 19 2019, 18:17

This is getting weirder and weirder, just tried the same USB stick on a L15V4 I got in hands and it also does not detect the 4k@30Hz which makes me start to believe it is not software (i.e. PureOS) related. Need to investigate more.

mladen added a subscriber: mladen.Oct 23 2019, 09:08

@nicole We are already tracking this here: https://tracker.pureos.net/T298

siraaj added a subscriber: siraaj.Sun, Nov 24, 12:26