Thunderbird/Enigmail freezes
Closed, ResolvedPublic

Description

Issue:

New install (updated as of today) of PureOS and Thunderbird/Enigmail. Enigmail fails upon importing key.

Reproduce:

Uninstall/reinstall Thunderbird/Enigmail with same result.
Attempted single key/multiple keys with same result.
Uninstall/reinstall of PureOS/Thunderbird/Enigmail same result.

Steps:

Install OS and software
Import keys through Enigmal wizard
Upon hitting next, Enigmail freezes, thunderbird freezes, processors peg at near 100% and requires restart

Hi @james.rufer
Unfortunately, I can't reproduce this. I have successfully imported both of my keys (as well as singly) using the Enigmail setup wizard into PureOS's Thunderbird but cannot see this freeze, alas.
(Can you clarify exactly what import/export mechanism you are using? Enigmail offers a couple with very similar names.)

Full update of PureOS 8 as of today 01-08-18.

The freezing and processor pegging issue is no longer occurring. However, both the Enigmail/Key management/import keys from file method AND utilizing Seahorse/File/import neither seemingly do anything.

This is intended as a import of the full Purism keyring for a new setup. I've done this before utilizing Enigmail method on multiple occasions without issue.

That's very curious. Could it, perhaps, be trying to access the internet? I wonder if this was doing it in a GUI thread previously and (now) no longer, so the underling problem remains but the symptoms have simply moved around.

I'm not sure. What would you like me to look into?

I'm afraid I'm out of ideas I'm afraid. Anyone else?

Can you outline/link to exactly the keyring you are importing? Perhaps it's specific to that one - you didn't mention it was the Purism keyring before so I simply imported my key..

I'm not sure. What would you like me to look into?

Maybe the log could help understanding what's happening, look here to know how to create log file for Enigmail :
Enigmail Log

QiZhi added a subscriber: QiZhi.Jan 16 2018, 12:19 PM

@james.rufer are you still experiencing the issue?

No. This could be closed unless you have reason to keep it open.

zlatan.todoric closed this task as "Resolved".Jun 21 2018, 2:55 PM

Add Comment