purebrowser: refuses to install Firefox-identified addons
Closed, DuplicatePublic

Description

When trying to install add-ons for Purebrowser, there is a message that these add-ons are available "Only with Firefox — Get Firefox Now!"

Please make Purebrowser compatible with Firefox addons.

patata created this task.Sep 22 2017, 11:52 PM
d3vid added a subscriber: d3vid.EditedSep 29 2017, 10:12 AM

AMO example: https://addons.mozilla.org/en-US/firefox/addon/umatrix/

This actually stopped happening a little while ago but now it's back. It could be related to the user-agent string? I noticed that Debian Iceweasel used to include both Firefox and Iceweasel in the string:

Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20121202 Firefox/17.0 Iceweasel/17.0.1

whereas we currently include only PureBrowser:

Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 PureBrowser/46.2.0

Either option still makes our browser fingerprint quite unique. (The UA string above is reported as 1 in 56499.75 at https://panopticlick.eff.org ). Is it worth dropping the "PureBrowser" part altogether? Moved this discussion to https://tracker.pureos.net/T247 This ticket remains purely for "does AMO work or not?"

jonas.smedegaard closed this task as "Resolved".
jonas.smedegaard added a subscriber: chris.lamb.

This issue is believed fixed with the recent upgrade of PureBrowsr to version 52.5.0esr-1pureos1.

Please shout if the issue still persist.

jonas.smedegaard reopened this task as "Open".Jan 16 2018, 11:56 AM

apparently green does not yet include PureBrowser 52.5.0esr-1pureos1 - or mysteriously reverted to include the older version again.

jonas.smedegaard changed the title from "PureBrowser Add-ons" to "purebrowser: refuses to install addons due to identifier mismatch".Jan 16 2018, 12:11 PM
jonas.smedegaard changed the title from "purebrowser: refuses to install addons due to identifier mismatch" to "purebrowser: refuses to install Firefox-identified addons".
jwolf added a subscriber: jwolf.Feb 22 2018, 5:59 PM

This issue persists on purebrowser 52.6.0esr-2pureos1.

jwolf added a comment.Mar 6 2018, 3:38 PM

Found a temporary workaround on 52.6.0esr-2pureos1:

Go into about:config (accept the warning about risks) and search "useragent" - there's a boolean named

general.useragent.compatMode.firefox

Set this to True. This will allow you to install addons from AMO that work with Firefox 52. In the case of some extensions, you may have to choose an older version (which was my case with Greasemonkey). I'd recommend flipping it back to False after installing the needed extensions.

Maybe in later versions of Purebrowser, a toggle can be included to easily switch FF compatibility off and on.

d3vid added a comment.Jul 6 2018, 10:07 AM

It appears the compatMode boolean no longer resolves this issue (tested with the uMatrix link above). I'm not sure what has changed, possibly AMO now requires a newer version of Firefox?

The useragent flag changes, well, the user-agent. And only that.

I suspect AMO requiring a newer version is tied to whether or not the browser plugins are Quantum or not.

Wayne added a subscriber: Wayne.Jul 6 2018, 12:37 PM

I happened to see the last posts scroll by....

I thought it might be helpful to point out that one can successfully install these extensions without the changing the user-agent or compatMode setting. Instead of using "Get Add-ons", one can add them from the Search box in the "Extensions" panel. I describe this in the Purism Forum here. It worked for me and it seems to work for others.

I hope providing this bit of information might help isolate the problem. There is something different about searching in "Get Add-ons" and in "Extensions". It may be related to Quantum., but could it have something more to do with data presented in the search string to obtain the results?

jonas.smedegaard closed this task as "Resolved".Aug 7 2018, 9:41 AM

This issue is solved since release 52.9.0esr-1pureos2 (see T247), uploaded to landing on July 5th (and likely entering green ~10 days later).

NB! This issue is *only* about Mozilla addons service refusing to serve addons to browsers not identifying themselves as being (at least derived from) Firefox). In particular, this issue is *not* about Mozilla addons service refusing to serve WebExt addons (a.k.a. Quantum) to browsers consuming Xulrunner addons.

So this issue still exists for me, namely I'm unable to install extensions. Here is the user agent that PureBrowser left in my logs;

75.127.226.99  TLSv1.2 ECDHE-RSA-AES128-GCM-SHA256 - - [06/Dec/2018:17:57:36 +0100] "GET /images/jf.favicon.ico HTTP/1.1" 200 790 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0 PureBrowser/60.1.0" 370 1147

I wonder if we want to have an acceptance criteria for this issue since while it is "closed" it is not "solved" perhaps.

I wonder if we want to have an acceptance criteria for this issue since while it is "closed" it is not "solved" perhaps.

Would be great. Please let's discuss that over at T553 :-)

Add Comment