Page MenuHomePureOS Tracker

Lollypop in byzantium has a bug affecting adeptive mode
Closed, ResolvedPublic

Description

Lollypop in byzantium In the Lollypop package there's a bug in the package in
byzantium/bullseye which affects the adaptive mode of the application
(which is bad for the phone interface of course).

Upstream bug #2778 [1] (fixed in 1.4.19-2 in debian, in upstream in
1.4.20, while 1.4.14-1 is currently in byzantium/bullseye).

It's two commits upstream [2][3] merged to one patch in the debian fix
[4].

If I can, I would like to fix this in byzantium - what's the preferred
way to do this?

Cherry-picking the fix and adding to 1.4.14-1, or simply backporting
the latest (or maybe just the first one with the fix) to byzantium?

I would gladly provide an updated package.

1: https://gitlab.gnome.org/World/lollypop/-/issues/2778
2: https://gitlab.gnome.org/World/lollypop/-/commit/5e0cbc686e3754a5a3c6e05315b0c13f7d564e6b
3: https://gitlab.gnome.org/World/lollypop/-/commit/8cd6117a597be5ee276dca7b9991317f9a15169e
4: https://salsa.debian.org/python-team/packages/lollypop/-/commit/bdad22d541d932a1bd620034115b01dd364d84f3

Event Timeline

gusnan created this task.Thu, Sep 23, 05:16
gusnan added a comment.Thu, Sep 23, 06:15

I was intructed on the pureos-project mailinglist that if the latest package in Debian is a clean backport and I haven't seen any regressions, then the simplest solution is to simply backport that from unstable to byzantium.

And that is indeed the case, I am backporting the latest sid version after uploading to unstable to my own personal repository for bullseye backports which I use daily, and it doesn't need any changes or additional dependencies, and I have not seen any regressions.

jonas.smedegaard triaged this task as Normal priority.

Thanks, @gusnan

@carsten.schoenert, will you have the honour?

guido added a subscriber: guido.Thu, Sep 23, 07:13

@carsten.schoenert i've created https://source.puri.sm/pureos/packages/lollypop by mirroring https://salsa.debian.org/python-team/packages/lollypop.git (see https://source.puri.sm/Librem5/librem5-dev-tools/-/issues/1 for the steps) since i wasn't sure if you have all the permissions set up yet.

I did *not* do any packaging changes so you can hack on from here.

@jonas.smedegaard
Let's call it a first challenge. ;)

@gusnan
I did a quick simple rebuild in a byzantium chroot and yes, technically the package is simply rebuildable. So straight backport of the most recent version is doable.

@guido
Thanks for the setup, I'm unsure if I do have the required access right as don't needed to do such forking. We can check this (if you can/would guide me) by doing the equivalent steps for T1076.

@carsten.schoenert Excellent!

Please beware of keeping version bump to a minimum - i.e. use ~ as first appended character to version string (see T938) to allow later switch back to tracking Debian packages (see T1029 and T724).

guido added a comment.Fri, Sep 24, 03:42

@carsten.schoenert happy to help here, first good step would be a MR against the above repo with the necessary changes. I usually do

  • adjust `d/gbp.conf
  • add d/pureos-ci.yml
  • add a changelog entry

We can discuss the rest in the MR with those changes to not clutter this report.

mak added a project: Restricted Project.Sun, Oct 3, 09:45
carsten.schoenert closed this task as Resolved.Mon, Oct 4, 00:11

With the help by Guido we managed to get this addition into landing. So closing this issue.
https://software.pureos.net/package/src/landing/lollypop

thanks, @carsten.schoenert

Please (for future sake, if not this one) note that this issue tracker should be tracking user-visible targets, not staging targets like "landing".
I.e. not option e) but option g) at https://tracker.pureos.net/T553#18719

@jonas.smedegaard
Ahh, right! Thanks for pointing. I happily agree an that.