PureBrowser gives "Secure connection failed" error on certain sites
Open, LowPublic

Description

I can't access my online banking website at https://op.fi . When I try to go there, PureBrowser gives a "Secure Connection Failed" error message. Chrome works fine on the same Librem 13, as does Gnome Web.

I've updated everything with "sudo apt-get update && sudo apt-get upgrade", and I've rebooted the laptop several times.

  • The exact error message is

"Secure Connection Failed
The connection to the server was reset while the page was loading.
The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem."

  • My PureBrowser is 60.5.0esr (64-bit)
  • I have another laptop with Ubuntu on it, and its Firefox 66.0.2 (64-bit) works fine.

After emailing support, I've also done this in PureBrowser:

  • Tried dropping max TLS version from 4 to 3
  • Checked that no proxy is in use
  • Disabled IPv6
  • Tried in private browsing mode
  • Cleared all history

The situation is still the same; Trying to access op.fi returns the error.

xird created this task.Apr 25 2019, 10:20 AM
xird edited the task description. (Show Details)
xird edited the task description. (Show Details)

I too get "secure connection failed" in PureBrowser. I don't know why that happens. I downloaded the certificate but I see no apparent issues with the cert.

jeremiah.foster triaged this task as "Low" priority.Apr 26 2019, 1:48 PM

Add Comment