Update hplip package
Open, NormalPublic

Description

From a user:

My goal was to be able to use programs like xsane or simple-scan to scan
from an HP All-in-One printer (model 8720) connected wirelessly. These
programs, and also sane-find-scanner could not find any installed scanners.

One solution I tried, was to get system-config-printer to install a
scanner, but I could not figure out how to do this. If this is indeed possible,
I would appreciate if you could tell me how.

The second solution I tried was to use apt to install hplip from the PureOS
green repository. This failed with the error message

Some packages could not be installed. This may mean that you have
 requested an impossible situation or if you are using the unstable
 distribution that some required packages have not yet been created
 or been moved out of Incoming.
 The following information may help to resolve the situation:
 
 The following packages have unmet dependencies:
  hplip : Depends: python3 (< 3.7) but 3.7.1-2 is to be installed
          Recommends: printer-driver-postscript-hp but it is not going to be installed
 E: Unable to correct problems, you have held broken packages."

This error message is very surprising to me considering how easy it was for
me to install hplip without using the PureOS repositories. aptitude -V -s
revealed that the repositories had hplip-3.17.10+repack0-5.

My problem was solved by downloading the hplip-3.18.12 tarball, unpacking
it, cding to the hplip-3.18.12 directory and then doing ./configure, make, and
make install. If I remember correctly, the only package I needed to add from
the PureOS green repository was libsnmp-dev, in order to have detection of
networked printers. Afterward, hp-setup -i, as always previously, detected my
wireless all-in-one hp printer, and installed both a "printer" and a
"fax/scanner".

Rather than format this as a complaint or bug-report, I will just give my
opinion that:

a) It would be desirable for system-config-printer to be able to install a
fax/scanner as easily as it currently installs printers,

and b) It would seem desirable to update the Purism repository to
hplip-3.18.12, which at least for me seemed to compile easily.

mladen created this task.Dec 25 2018, 9:08 PM
Wayne added a subscriber: Wayne.Dec 29 2018, 1:41 PM

I think the problem in general is that python3 was upgraded to 3.7 and several packages are dependent on python3 being less than 3.7. (Note the "Depends" line above. hplip also shows python3<<3.7 if one runs apt show on it.) I have the same problem with apparmor-utils and opened a new task, not having previously looked at this one. I noticed hplip--I don't use it to my knowledge--was also uninstalled for me on 12/20. This was the same update with python3 going to 3.7. Unfortunately, I am dependent on a Purism-modified package for python3-libapparmor. (The one in buster shows python3 << 3.8 as the dependency.)

This may also explain why I lost gnome-software, which I do not use directly, but I have not pulled that thread.

apt show hplip

shows, among other dependencies, this line;

wget, python3 (<< 3.7), xz-utils, python3 (>= 3.6~),

which seems to imply you won't be able to install this unless your python is higher or equal to version 3.6.* but not 3.7. I don't know how many releases of python there were like that but I can't imagine many.

jeremiah.foster triaged this task as "Low" priority.Jan 3 2019, 7:54 PM
Wayne added a comment.Jan 4 2019, 12:56 PM

I do not understand your last statement.

I don't know how many releases of python there were like that but I can't imagine many.

As I mentioned in my previous remark, it appears PureOS was at a 3.6.*, but updated to 3.7 on 12/20. This has caused problems for me, though it was my stupid mistake for updating, because hplip and another of mine were uninstalled.

The latter is a PureOS-modified package, python3-libapparmor, so I am stuck until Purism updates the dependencies. Buster already has. (https://tracker.pureos.net/T668) Unless I am misunderstanding, the problem may be bigger than you think as even other packages might be affected.

In T666#12337, @Wayne wrote:

I do not understand your last statement.

I don't know how many releases of python there were like that but I can't imagine many.

I was trying to point out that there likely weren't that many releases of python between 3.6.0 and 3.7, but I apologize because that is irrelevant information.

As I mentioned in my previous remark, it appears PureOS was at a 3.6.*, but updated to 3.7 on 12/20. This has caused problems for me, though it was my stupid mistake for updating, because hplip and another of mine were uninstalled.

The latter is a PureOS-modified package, python3-libapparmor, so I am stuck until Purism updates the dependencies. Buster already has. (https://tracker.pureos.net/T668) Unless I am misunderstanding, the problem may be bigger than you think as even other packages might be affected.

I think your understanding is correct. I'll try and get an idea as to how long it will take for updates from Debian to come into PureOS.

Wayne added a comment.Jan 5 2019, 12:33 PM

Thanks. I understand now.

I was trying to be patient, because I knew we were in the holiday season and people had probably taken off. This defect is related to mine, so when I saw its priority set to 'low,' I was worried it might take a long while for the dependencies to work through. As I said, I should have stopped updating my system, though python is important, but I am not dead-in-the-water.

jeremiah.foster raised the priority of this task from "Low" to "Normal".Jan 5 2019, 4:50 PM

Thanks Wayne, I'm glad to hear you're not dead in the water. Thank you for your patience as well. Sadly I didn't have time to drill down and find out more about the situation with dependencies yesterday, I hope to try and get some clarity on this today, but no guarantees as its a weekend. :-)

I reset this to 'normal' given that I think it is a normal issue, something that needs to be addressed, of course, if this is a pressing issue for you, we can set this to a higher priority. I do want you to know that just because I set it to 'low' does not mean it'll be ignored.

jeremiah.foster added a project: Restricted Project.Jan 5 2019, 4:50 PM

Add Comment