PureOS does not support partitions larger then 2TB without EFI
Incomplete, NormalPublic

Description

When trying to create a new partition on an external hard drive, Disks fails and gives me an obscure error message. I tried a variety of settings (ext4, ntfs, with and without LUKS) so I don't think it's related to any specific configuration.

tbernard created this task.Sep 25 2018, 2:47 PM
mak added a subscriber: mak.Feb 22 2019, 9:15 PM

4TB disks/partitions can not be supported, unless we switch from BIOS to UEFI with GPT support, or adding GPT support to the Librem's BIOS by other means.
See https://en.wikipedia.org/wiki/GUID_Partition_Table

Partitioning the large disk into smaller partitions of sizes below 2TB might work though.

jeremiah.foster changed the title from "Error when trying to create new partition on 4TB extenal disk" to "PureOS does not support partitions larger then 2TB without EFI".Feb 24 2019, 5:16 PM
jeremiah.foster closed this task as "Resolved".

@jeremiah.foster I recommend to put as issue subject the issue (not its solution), and not rename to its solution when closed either: Example: References will then sensibly show the _problem_ as striked out, not confusingly that the solution is striked out.

I believe it is only the install routines for PureOS that has problems with EFI, the installed PureOS works fine with EFI.

A possible - dirty! - workaround may be to install onto a smaller disk, transfer the installed disk onto the bigger disk, resize the partition, and finally resize the filesystem inside the partition.
An additional complications is hardware that require a BIOS-based bootloader (e.g. Purism laptops), needing another dirty hack to trick the BIOS-based bootloader into booting a GPT-formatted disk - e.g. using a Hybrid format: https://www.rodsbooks.com/gdisk/hybrid.html

Another workaround is to install Debian testing, switch /etc/apt/sources.list to instead track PureOS, install pureos-* packages, and remove any packages left over from Debian.

scott.booth added a comment.EditedFeb 25 2019, 7:20 AM

Thanks for the info, @jonas.smedegaard

Alright, I was successful (finally) getting PureOS reliably installed on to a 4TB SSD about 4 hours ago. However, in the end, it did require me to make two 1.8TB GUID (GPT) partitions and allow the system to create a small 2.8MB boot sector. The customer may not be happy he can't utilize one large partition on this L15v4, but after 4 days of trying just about everything to reasonably address this somewhat uncommon situation (until we find a solid solution for supporting large 2TB+ single partition SSD's) this is the most logical and time friendly course of action.

I can now load the OEM/Live image in under 10 minutes, run coreboot, QC the system functionality, reboot and allow the installer to format the SSD and reload the OS so the system is fresh and ready for packaging within another 10 minutes.

For the record (as I understand time's up for your concrete case), use of Logical Volume Management (LVM) can provide a user experience of a single "virtual" partition, stitched together from multiple underlying physical "volume" partitions.

@jeremiah.foster It does not make sense to me why/how this bug is closed.

Framed by its original subject I can understand it being closed - but then only as "invalid": It is not a bug but a wrong expectation of our current installer to try use it with too big disk.

Framed by its current subject (reading that as the issue, not as a solution - see my previous remark about that) it is neither invalid nor solved however: It continues to be an issue that PureOS (installer, not system itself!) is limited like that.

jeremiah.foster reopened this task as "Incomplete".Feb 25 2019, 2:51 PM
jeremiah.foster triaged this task as "Normal" priority.

Add Comment