"powertop --auto-tune" in purism-power-optimisations disabling external USB inputs
Closed, ResolvedPublic

Description

After the last software update of my librem 15 v3, my usb mouse loses control of the cursor after a few seconds of inactivity, and I have to click any button to reactive control. The trackpad continues to control the cursor without any intervention required.

Another user on the purism forums suggested that connecting USB devices after disk decryption would mitigate this issue (https://forums.puri.sm/t/usb-mouse-suspension/3742).

johenry created this task.Sep 3 2018, 10:29 PM
Caliga added a subscriber: Caliga.Sep 5 2018, 12:02 AM

I would describe the symptoms slightly different, but I'd say it has the same cause. (Assuming purism-power-optimisations)

After rebooting, my Logitech mouse is dead. I had that before the last update, too, but then it was sufficient to unplug/replug the mouse.
After powering on today, this had no effect. The mouse LED stayed off. I noticed that clicking turned the LED on, but the mouse was still not working.
A reboot seemed to have fixed it, or at least re-plugging it was then sufficient to make it work.

mak reassigned this task from mak to chris.lamb.Sep 15 2018, 1:28 PM
mak added a subscriber: mak.

@Chris, can you look into this and see if it indeed has anything to do with purism-power-optimisations? (that's the only thing that would make sense to me, but it could also be a kernel issue in general. Encryption being the culprit seems highly unlikely to me though).

Hi @johenry, thanks for filing this issue. Whilst I can't reproduce this, like
@mak I suspect this might be be the powertop parts of the purism-power-optmisations. After you reboot and you /cannot/ reproduce, can you try running powertop --auto-tune as root and let me know whether this causes the issue to return?

(In the meantime I've uploaded a new version of purism-power-optimisations that adds better logging output but that is somewhat unrelated)

Example logging output

Hi @chris.lamb. I rebooted and ran powertop --auto-tune and my usb mouse and keyboard stopped responding until I detached and reattached the cables.

That's exactly my issue (Librem 13v3). After boot I have to plug-cycle the mouse once for it to become usable

Great stuff; this helps in tracking it down. On it..

chris.lamb changed the title from "USB disabled after disk decryptions" to ""powertop --auto-tune" in purism-power-optimisations disabling external USB inputs".Sep 17 2018, 9:13 AM

So, I can't exactly figure out exactly which USB device, etc. I need to disable this for (presumbly the "root hub", but I can't reproduce that bit).. plus I managed to reproduce this with the internal trackpad so I've gone ahead and disabled application of the Powertop profile for now in purism-power-optimisations version 0.5.3.

I also noticed that if we can come up with a new saved_parameters.powertop we will need to ensure that we actually override it in /var/cache - we only copy it once via Only_once (!).

chris.lamb closed this task as "Resolved".Sep 17 2018, 6:59 PM

Add Comment