Links From Thunderbird Won't Open in Purebrowser
Closed, ResolvedPublic

Description

Hi, I'm facing an issue with links clicked in Thunderbird not opening
when default browser is set to Purebrowser. They open fine when I change
the default browser (checked with Gnome Web). I haven't done much set up
after getting my new Librem, just configured my account in Thunderbird
and the problem already existed. I've described the issue on the
Thunderbird's support forum as well:
https://support.mozilla.org/en-US/questions/1191385 Can you please
advise on how I can solve that issue? I was trying to create a ticket on
the public PureOS tracker, though had to wait for account registration
approval so I decided to write an email instead. Cheers, Marek

marekoid created this task.Nov 29 2017, 3:15 PM

Tried to check if the same will happen with Puremail (Thunderbird fork) but after installation can't even run it:

marek@librem:~$ puremail
XPCOMGlueLoad error for file /usr/lib/puremail/libxul.so:
libhunspell-1.4.so.0: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

I have the exact same issues. I am not able to run Puremail and I have problems with PGP key import and links with Thunderbird.

It looks like AppArmor is blocking Thunderbird. Here are my logs :

Dec 10 21:35:06 librem13 kernel: audit: type=1400 audit(1512938106.807:48557268): apparmor="DENIED" operation="file_inherit" profile="thunderbird//gpg" name="/usr/share/thunderbird/omni.ja" pid=13681 comm="gpg" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
Dec 10 21:35:10 librem13 kernel: audit: type=1400 audit(1512938110.166:48557272): apparmor="DENIED" operation="exec" profile="thunderbird" name="/usr/lib/purebrowser/purebrowser" pid=13746 comm="thunderbird" requested_mask="x" denied_mask="x" fsuid=1000 ouid=0
Dec 10 21:35:10 librem13 thunderbird[13453]: Could not launch default application for URI: Failed to execute child process “purebrowser” (Permission denied)
jonas.smedegaard removed a project: Restricted Project.Dec 27 2017, 8:45 PM
jonas.smedegaard added a subscriber: jonas.smedegaard.

Based on francois' findings this seems to be an issue with Thinderbird, not PureBrowser.

@francois Can you still reproduce this after the Thunderbird apparmor fixes? :)

@chris.lamb I've installed the latest updates through the Software app (including some OS updates) and I'm still observing the same issue, in the kernel log the same line is added as the one already provided by @francois

@chris.lamb the version I have is 52.4.0 and it seems to be the latest on PureOS (green). Unfortunately, the problem is still there for me too.

chris.lamb closed this task as "Resolved".Jan 15 2018, 10:16 PM

Pretty certain this is the same as T293, so merging there!

@chris.lamb I have just tested Thunderbird 52.5.2 from Debian Sid and it fixes the AppArmor issue indeed.
So I guess that it is just a question of days before the fix gets to PureOS?

Pini added a subscriber: Pini.Mar 26 2018, 7:21 PM

Well, 2 months later Thunderbird is still 1:52.4.0 in PureOS :/

Add Comment