Pure OS continually disconnects my computer from VPN
Open, Needs TriagePublic

Description

I use a VPN, and I'm constantly disconnected from it, whether I use the VPN developer's own application, or GNOME's OpenVPN. It will connect successfully, and then a few seconds/minutes later, I will be disconnected. I have actually tried using two different VPN providers, and the same thing happens with both: Private Internet Access and Mullvad.

Pure OS is up-to-date; I've run apt-get update && apt-get upgrade, and I'm told as much.

ezs777 created this task.Sep 16 2017, 2:20 PM
QiZhi added a subscriber: QiZhi.Oct 5 2017, 2:21 PM

Same issue for me and I have another VPN provider as ezs777 mentioned above.

I am currently using Debian 9.1 (Stretch) on a Libreboot x200, and while I still have problems with the Mullvad appliation, the connection is stable when I use OpenVPN: only disconnecting every once in a while. Presently, It's been going continuously since this morning (9am), without any issues.

I think this might point to the problem being with the versions of OpenVPN and NetworkManager used by PureOS, rather than being related to the GNOME desktop environment itself.

d3vid added a comment.Nov 6 2017, 2:52 PM

I've been using the GNOME desktop for VPN access for a few weeks now. Running up-to-date PureOS-green on a Librem 15v3. Currently using openvpn 2.4.4, network-manager-openvpn-gnome 1.2.8, network-manager-gnome 1.8.4.

I only experience issues when my access point itself has connectivity issues (typically on a public access point like a coffee shop). On stable access point, I do not encounter problems.

I know that the PIA client is non-free and I couldn't get it to install last time I tried (they support Ubuntu but not Debian). I'd suggest just importing OVPN files with GNOME Network Manager.

@QiZhi @ezs777 Are you still experiencing issues on known stable access points? Is it possible there's been a package update that has resolved the issue?

I'd suggest just importing OVPN files with GNOME Network Manager.

Just as a quick FYI I've found PIA's OpenVPN files (or at least the .zip you can readily find) to be incomplete or outdated. IIRC there is a "strong" version of the zip, for some reason.

In the end I ended up basing some of my connections on the openvpn files and https://helpdesk.privateinternetaccess.com/hc/en-us/articles/225274288-Which-encryption-auth-settings-should-I-use-for-ports-on-your-gateways-

@d3vid, my connection is stable. I have no problems when not connected to the VPN; the connection never just suddenly drops, like it does when I am using it. Also, my packages are all up-to-date, and the problem still persists into this morning.

So, which VPN provider are you using? I only used PIA to test whether it was an issue with the specific client, the hardware, or with the network-manager software; I would prefer to not use any non-free software.

Add Comment