Page MenuHomePureOS Tracker

unable to boot
Closed, ResolvedPublic

Description

I recently received my librem 15. After booting it up for the first time and following the setup prompts, and setting up a disk encryption passphrase, I ran apt-get update and apt-get upgrade to make sure the system was up to date.

Now when I reboot the machine and press esc to view the console output it says:

firmware: failed to load i915/kb_dmc_ver1_04

Followed by several lines that look something like this:

No key available with this passphrase.
cryptsetup: ERROR: luks-<SOME UUID>: cryptsetup failed, bad password or options?

It repeats this error about 30 times and ultimately boots up to BusyBox / initramfs.

The end of the log says:

ALERT! UUID=e2ba8..... does not exist. Dropping to a shell!

I can see that the UUID is correct by looking at the volume in the 'disks' application when I start the machine from a PureOS thumb drive.

The above errors look similar to what I've seen on other systems when I accidentally key the wrong disk encryption passphrase but in this case I'm not being prompted to enter the passphrase at all. It's like it is getting the passphrase from some other source of input.

screen shot

There is only one entry in the grub bootloader, so I can't boot an older kernel.

It's easy enough to just reinstall the OS from a thumb drive, but I would like to solve this problem now so that I can be confident that PureOS won't break every time I run apt upgrade.

Event Timeline

gforceg updated the task description. (Show Details)
jeremiah.foster triaged this task as Normal priority.Oct 1 2019, 09:42
jeremiah.foster added a subscriber: jeremiah.foster.

The first kernel message regarding firmware can be safely ignored.
The second message from cryptsetup needs to be resolved by ensuring that you give the correct password (in the correct case and with the correct keyboard layout, e.g. NumLK off, etc.)

For the last error, can you tell me what

ls -l /dev/mapper/

says?

Also, what does /etc/fstab have in it?

Thanks for your response.

ls -l /dev/mapper/

says:

total 0
crw------ 1 root 0 <date> control

/etc/fstab is empty

(this is all from initramfs btw)

Just to reiterate. I am not actually prompted to enter the pass phrase to decrypt the filesystem. It just keeps printing the error AS IF it is getting input from somewhere.

So I'm not sure what's happening here but it cannot boot because it can't find your disks. Usually /dev/mapper maps your disk UUIDs to the luks encryption and /etc/fstab holds the info on your boot disk. Those are unavailable for some reason on your system.

Did you install Fedora on this before? (Fedora does some magic with disk UUIDs.)

What does /proc/cmdline say? (Mine has pointers to the UUIDs of my disks).

No, I turned it on for the first time followed the prompts, wrote down my passwords / passphrases and ran the typical sudo apt update and sudo apt upgrade.

cat /proc/cmdline says:

BOOT_IMAGE=/vmlinuz-4.19.0-5-amd64 root=UUID=e2ba8c79-c317-4fd1-b92a-30aedbb64e05

I think that the upgrade may have brought in a new kernel and changed boot files. You may need to run update-initramfs or follow one of these solutions: https://tracker.pureos.net/w/troubleshooting/broken_upgrade/

In my experience our new version of PureOS (available for download here) has helped with this issue so you should not see problems like this if you choose to re-install.

gforceg added a comment.EditedWed, Oct 23, 19:15

There's no older kernel to boot from so I can't run update-initramfs. Looks like I would need to reinstall if I want to use PureOS. Thanks for your help.

gforceg closed this task as Resolved.Wed, Oct 23, 19:17
gforceg claimed this task.