Page MenuHomePureOS Tracker

Make memtest functional
Closed, ResolvedPublic

Description

When I navigate to memtest and hit Enter nothing happens other than a brief visual glitch.

Event Timeline

Gnutella created this task.May 6 2019, 11:03
jeremiah.foster triaged this task as Normal priority.May 10 2019, 09:51
jeremiah.foster added a subscriber: MrChromebox.

best I can tell, this is an issue with compiling memtest86+ with gcc-8, and not something that can be easily fixed within the framework of current coreboot toolchain

nicole added a subscriber: nicole.EditedJul 14 2019, 11:37

@MrChromebox I am not sure if this issue relates to Coreboot. I see exactly this issue when e.g. booting from the OEM or live image and choose the memtest from the Grub menu.
And yes, I would also like to see this fixed since being able to run a memtest from a USB stick would be very helpful. I have not yet tested if this issue also applies to a PureOS installation.
(tested with latest OEM image 2019-07-14)

@nicole this isn't a coreboot issue. If you boot a Qubes 4.0.1 ISO (eg) and run memtest from there, it works perfectly fine.

The issue with memtest bundled with coreboot (removed for current 4.9-1 release) is the toolchain used to compile memtest. That causes a freeze at the start of testing. With the PureOS ISO, memtest is failing to run at all. Given the different symptoms, I suspect a different root cause. But either way, unrelated to our coreboot firmware.

nicole added a comment.Jul 15 2019, 09:38

That's what I wrote?
This is not Coreboot, it is a PureOS issue.

Since memtest was removed from Coreboot, I assume for good reason, we need to get the PureOS memtest (started from Grub) working again.

@nicole you said "I am not sure if this issue relates to Coreboot," I was simply confirming that it does not / is a different issue altogether :)

nicole added a comment.Jul 18 2019, 18:42

Just FYI - in latest PureOS live/OEM images memtest (and also HW detect) are not working from the Grub menu.
This should either be fixed or the menu entries removed from Grub.

This is most likely not a coreboot issue. I tested on a machine that has proprietary firmware and memtest did not work.

On the KDE Plasma release from 31 August when I try to run the memtest menu entry it merely says "/live/memtest not found." I'll test the latest build from today but are we including the memtest binary?

mak closed this task as Resolved.Thu, Sep 26, 05:57
mak claimed this task.
mak added subscribers: jeremiah.foster, mak.

This is fixed in PureOS 9.0 (Amber) image build 2019-09-26.
Thank you for reporting the issue!

Thank you for fixing it.