gksu does not work
Closed, WontfixPublic

Description

gksu utility does not work in PureOS, in either default (wayland) or xorg session.

Steps to reproduce

  1. sudo apt install gksu
  2. gksu gedit

Expected results

Gedit is started in root mode.

Actual results

In wayland session: white prompt on black screen will ask for password, but the input is not accepted—when Cancel button is clicked, one can see their password typed in terminal

In Xorg session: white prompt will ask for password, character feedback is okay, but when clicked on OK button error reported is that the password is not correct.

mladen created this task.Mar 6 2019, 8:56 PM

I can reproduce this. I also get a message "Gtk-Message: 09:43:04.539: Failed to load module 'canberra-gtk-module'" when I run this so perhaps the error is there.

Nope. Installing libcanberra-gtk-module and libcanberra-gtk0 doesn't help.

mladen added a comment.Mar 7 2019, 2:49 PM

It's not, I installed the module and the same happens.

Why do PureOS distribute gksu at all? It was dropped from Debian a year ago: https://tracker.debian.org/pkg/gksu

@mak ?

mak added a comment.Mar 8 2019, 11:59 PM

@jonas.smedegaard Apparently gksu wasn't auto-removed from PureOS because sbackup had a dependency on it. That package itself is cruft though, so I just dropped both from the archive.
Interestingly, sbackup was not considered for autoremoval in PureOS, I will have to take a closer look at why that happened later (my guess is that it has something to do with the package being NMU'ed and building only arch:all binary packages).

mak added a comment.Mar 9 2019, 12:01 AM

Btw, gksu will not work at all on Wayland as wayland does not allow GUI apps to be run as root without some reconfiguration (which intentionally isn't done), and on Xorg I guess it's just broken because nobody looks at its code anymore.
So, I think we should just close this bug.

(Btw, canberra is a module for event sounds in GTK+, so those messages can easily be ignored)

jeremiah.foster closed this task as "Wontfix".Mar 11 2019, 1:45 PM
jeremiah.foster triaged this task as "Normal" priority.

Add Comment