PureOS will not connect to wifi
Closed, ResolvedPublic

Description

I just installed PureOS to my laptop, a 2018 Lenovo ideapad 320 I purchased new last year.
Installation went smoothly but it sometimes spins endlessly trying to find available wifi networks. When it does show networks and I connect to my home network, it fails to connect then gives me an error message. It did this on the live USB installation, so I hooked it up directly to my router with an ethernet cable.
No idea what could be causing this.

jgn2112 created this task.Feb 16 2019, 6:12 PM

Please, make lspci on a terminal and post the output here.

Please, make lspci on a terminal and post the output here.

I'm very new to anything linux-based, so I'm not sure what you're asking for. If you give me a command I can copy/paste into the terminal, I'll do that and post the output.
Thank you.

lspci on your terminal

Per your request.

00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series Host Bridge (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Device 5a85 (rev 0b)
00:0e.0 Audio device: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series Audio Cluster (rev 0b)
00:0f.0 Communication controller: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series Trusted Execution Engine (rev 0b)
00:0f.1 Communication controller: Intel Corporation Device 5a9c (rev 0b)
00:0f.2 Communication controller: Intel Corporation Device 5a9e (rev 0b)
00:12.0 SATA controller: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series SATA AHCI Controller (rev 0b)
00:13.0 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series PCI Express Port A #1 (rev fb)
00:14.0 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series PCI Express Port B #1 (rev fb)
00:14.1 PCI bridge: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series PCI Express Port B #2 (rev fb)
00:15.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series USB xHCI (rev 0b)
00:17.0 Signal processing controller: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series I2C Controller #5 (rev 0b)
00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series Low Pin Count Interface (rev 0b)
00:1f.1 SMBus: Intel Corporation Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series SMBus Controller (rev 0b)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 07)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter
EchedeyLR added a comment.EditedFeb 16 2019, 10:29 PM

Mmm on https://h-node.org/wifi/view/en/1941/Realtek-Semiconductor-Co---Ltd--RTL8821AE-802-11ac-PCIe-Wireless-Network-Adapter/1/1/undef/undef/undef/undef/wifi-works/RTL8821AE is reported as not run with free software but It was on Trisquel 8 (Ubuntu 16.04). Could you put lshw on your terminal and post here the *-network sections of the output?

I have no idea how to run as a superuser but it did give me a warning that the data may be incomplete unless I run the command as a superuser

*-network
                description: Wireless interface
                product: RTL8821AE 802.11ac PCIe Wireless Network Adapter
                vendor: Realtek Semiconductor Co., Ltd.
                physical id: 0
                bus info: pci@0000:03:00.0
                logical name: wlp3s0
                version: 00
                serial: ce:c0:b0:65:50:ee
                width: 64 bits
                clock: 33MHz
                capabilities: bus_master cap_list ethernet physical wireless
                configuration: broadcast=yes driver=rtl8821ae driverversion=4.17.0-3-amd64 firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
                resources: irq:130 ioport:1000(size=256) memory:91200000-91203fff
EchedeyLR added a comment.EditedFeb 16 2019, 10:50 PM

Please, upgrade your system first. Current available kernel version is about 4.19

Then, reboot and exec sudo dmesg on your terminal and post the output.

It would be great if you test the wifi again before to exec dmesg

OK...I checked for updates and it said the system was up to date. If you know how to manually update the kernel via the terminal, please let me know and I'll run the commands.
As far as the dmesg command, it returned an insanely long string where every line was the same:

[  367.628385] elan_i2c i2c-ELAN0609:00: invalid report id data (ff)

More on this in a second.
There were probably 500 lines like that, except one, which read:

[  349.969439] rtl8821ae: Init MAC failed

Now, the invalid report data id (ff) error...I've been trying non-stop for weeks to install Linux Mint to this computer and it won't install. It installs fine until it gets to the "Installing the grub2 package..." portion of the install, where it then produce an endless loop of the "invalid report data id (ff)" string in the details, preventing the completion of the install, so I have to eventually power off. That's why I'm trying to install PureOS, because Linux Mint won't install and I don't want to use Windows. And I'm now past the point of no return because I've wiped Windows off my drive now.

sudo apt update && sudo apt upgrade

show me the output before select yes

Did not run sudo apt upgrade yet. Here is sudo apt update:

Get:1 https://repo.puri.sm/pureos green InRelease [10.5 kB]
Get:2 https://repo.puri.sm/pureos green/main amd64 Packages [6,882 kB]
Get:3 https://repo.puri.sm/pureos green/main Translation-en [6,034 kB]
Get:4 https://repo.puri.sm/pureos green/main amd64 DEP-11 Metadata [2,528 kB]
Get:5 https://repo.puri.sm/pureos green/main DEP-11 64x64 Icons [7,358 kB]
Fetched 22.8 MB in 9s (2,682 kB/s)                                                  
Reading package lists... Done
Building dependency tree       
Reading state information... Done
1136 packages can be upgraded. Run 'apt list --upgradable' to see them.

I have not hit Y yet...

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  fonts-font-awesome gir1.2-mutter-2 libavahi-gobject0 libbind9-160
  libboost-atomic1.62.0 libdns1102 libenca0 libexempi3 libfolks-telepathy25
  libgail-3-0 libglew2.0 libgmime-3.0-0 libgutenprint2 libirs160 libisc169
  libisccc160 libisccfg160 liblouis16 liblvm2app2.2 liblvm2cmd2.02 liblwres160
  libmutter-2-0 libnfs11 libntfs-3g88 libopencv-core3.2 libopencv-imgproc3.2
  libphobos2-ldc-shared78 libprotobuf10 libtbb2 python-gdbm
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  fonts-noto-core fonts-noto-ui-core fonts-roboto-unhinted gir1.2-mutter-3
  gnome-settings-daemon-common intel-media-va-driver libaom0 libbind9-161
  libboost-atomic1.67.0 libboost-chrono1.67.0 libboost-date-time1.67.0
  libboost-filesystem1.67.0 libboost-system1.67.0 libboost-thread1.67.0
  libdns-export1104 libdns1104 libexempi8 libfreerdp2-2 libgail-common libgail18
  libgdbm6 libglew2.1 libgpg-error-l10n libgtk2.0-0 libgtk2.0-bin libgtk2.0-common
  libgutenprint-common libgutenprint9 libhunspell-1.7-0 libicu63 libigdgmm5
  libimagequant0 libirs161 libisc-export1100 libisc1100 libisccc161 libisccfg163
  libllvm7 liblouis17 liblvm2cmd2.03 liblwres161 libmariadb3 libmutter-3-0 libnfs12
  libnftables0 libnftnl11 libntfs-3g883 libperl5.28 libphobos2-ldc-shared82
  libpipewire-0.2-1 libpoppler82 libprotobuf17 libpython3.7 libpython3.7-minimal
  libpython3.7-stdlib libsynctex2 libuchardet0 libvidstab1.1 libwinpr2-2
  libx264-155 libx265-165 libxencall1 libxendevicemodel1 libxenevtchn1
  libxenforeignmemory1 libxengnttab1 libxenmisc4.11 libxentoolcore1 libxentoollog1
  linux-image-4.19.0-2-amd64 mariadb-common nftables perl-modules-5.28
  pureos-init-disk-crypto python3-distro python3-distro-info python3.7
  python3.7-minimal runit-helper usb.ids xdg-dbus-proxy
The following packages have been kept back:
  cups cups-bsd cups-client cups-core-drivers cups-daemon cups-ipp-utils
  evolution-data-server gir1.2-rb-3.0 hplip hplip-data libcups2 libcupsimage2
  libebackend-1.2-10 libebook-1.2-19 libebook-contacts-1.2-2 libecal-1.2-19
  libedata-book-1.2-25 libedataserver-1.2-23 libedataserverui-1.2-2 libgl1-mesa-dri
  libhpmud0 libpython3-stdlib libreoffice-avmedia-backend-gstreamer
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-gnome libreoffice-gtk3 libreoffice-impress
  libreoffice-math libreoffice-ogltrans libreoffice-pdfimport
  libreoffice-style-breeze libreoffice-style-tango libreoffice-writer
  librhythmbox-core10 libsane libsane-common libsane-hpaio libsnmp30
  printer-driver-hpcups printer-driver-postscript-hp python3 python3-apt
  python3-brlapi python3-dbus python3-gst-1.0 python3-markupsafe python3-minimal
  python3-pil python3-pycurl python3-renderpm python3-reportlab
  python3-reportlab-accel python3-uno rhythmbox rhythmbox-plugins sane-utils
The following packages will be upgraded:
  acpid adduser adwaita-icon-theme alsa-utils anacron apache2-bin apparmor
  apparmor-profiles appstream apt apt-file apt-utils aspell aspell-en at-spi2-core
  augeas-lenses avahi-autoipd avahi-daemon baobab bash bash-completion bind9-host
  binutils binutils-common binutils-x86-64-linux-gnu bolt brltty bsdutils
  bubblewrap ca-certificates cheese cheese-common chrome-gnome-shell colord
  colord-data command-not-found console-setup console-setup-linux coreutils cpp-7
  cracklib-runtime cryptsetup cryptsetup-bin cryptsetup-initramfs cryptsetup-run
  cups-common cups-ppdc cups-server-common curl dash dbus dbus-user-session
  dbus-x11 dconf-cli dconf-gsettings-backend dconf-service debconf debconf-i18n
  debian-archive-keyring debianutils deja-dup desktop-file-utils
  dictionaries-common dirmngr distro-info-data dmeventd dmidecode dmsetup
  dns-root-data dnsmasq-base dnsutils dpkg duplicity e2fslibs e2fsprogs easy-rsa ed
  enchant enigmail eog espeak-ng-data ethtool evince evince-common
  evolution-data-server-common exfat-fuse exfat-utils fdisk file file-roller
  findutils flashrom flatpak fontconfig fontconfig-config fonts-cantarell
  fonts-hack fonts-hack-ttf fonts-liberation2 fonts-noto-cjk fonts-noto-hinted
  fonts-noto-mono fonts-opensymbol fonts-roboto-hinted foomatic-db-compressed-ppds
  fuse fwupd fwupd-amd64-signed gcc-7 gcc-7-base gcc-8-base gcr gdbm-l10n gdisk
  gdm3 gedit gedit-common geoclue-2.0 geoip-database gettext-base ghostscript
  ghostscript-x gir1.2-appstream-1.0 gir1.2-atk-1.0 gir1.2-atspi-2.0
  gir1.2-champlain-0.12 gir1.2-clutter-1.0 gir1.2-clutter-gst-3.0 gir1.2-cogl-1.0
  gir1.2-coglpango-1.0 gir1.2-evince-3.0 gir1.2-freedesktop gir1.2-gck-1
  gir1.2-gcr-3 gir1.2-gdesktopenums-3.0 gir1.2-gdkpixbuf-2.0 gir1.2-gdm-1.0
  gir1.2-geoclue-2.0 gir1.2-geocodeglib-1.0 gir1.2-gfbgraph-0.2 gir1.2-glib-2.0
  gir1.2-gmenu-3.0 gir1.2-gnomebluetooth-1.0 gir1.2-gnomedesktop-3.0 gir1.2-goa-1.0
  gir1.2-gspell-1 gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gtk-3.0
  gir1.2-gtkchamplain-0.12 gir1.2-gtkclutter-1.0 gir1.2-gtksource-3.0
  gir1.2-gweather-3.0 gir1.2-javascriptcoregtk-4.0 gir1.2-json-1.0 gir1.2-nm-1.0
  gir1.2-nma-1.0 gir1.2-notify-0.7 gir1.2-packagekitglib-1.0 gir1.2-pango-1.0
  gir1.2-peas-1.0 gir1.2-polkit-1.0 gir1.2-rest-0.7 gir1.2-rsvg-2.0 gir1.2-secret-1
  gir1.2-soup-2.4 gir1.2-totem-1.0 gir1.2-totemplparser-1.0 gir1.2-upowerglib-1.0
  gir1.2-webkit2-4.0 gir1.2-wnck-3.0 gjs gkbd-capplet glib-networking
  glib-networking-common glib-networking-services gnome-backgrounds gnome-bluetooth
  gnome-boxes gnome-calculator gnome-calendar gnome-clocks gnome-contacts
  gnome-control-center gnome-control-center-data gnome-desktop3-data
  gnome-disk-utility gnome-font-viewer gnome-getting-started-docs
  gnome-initial-setup gnome-keyring gnome-keyring-pkcs11 gnome-logs gnome-maps
  gnome-online-accounts gnome-online-miners gnome-orca gnome-photos
  gnome-power-manager gnome-screenshot gnome-session gnome-session-bin
  gnome-session-canberra gnome-session-common gnome-settings-daemon gnome-shell
  gnome-shell-common gnome-shell-extensions gnome-sushi gnome-system-monitor
  gnome-todo gnome-todo-common gnome-tweaks gnome-user-docs gnome-user-share
  gnome-video-effects gnupg gnupg-l10n gnupg-utils gpg gpg-agent gpg-wks-client
  gpg-wks-server gpgconf gpgsm gpgv graphicsmagick
  graphicsmagick-imagemagick-compat grep grilo-plugins-0.3 groff-base
  gsettings-desktop-schemas gstreamer1.0-clutter-3.0 gstreamer1.0-gl
  gstreamer1.0-libav gstreamer1.0-plugins-bad gstreamer1.0-plugins-base
  gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio
  gstreamer1.0-x gtk-update-icon-cache gucharmap gvfs gvfs-backends gvfs-bin
  gvfs-common gvfs-daemons gvfs-fuse gvfs-libs gzip hdparm hostname i965-va-driver
  ibus-libpinyin ifupdown info init init-system-helpers inputattach install-info
  iproute2 iptables irqbalance isc-dhcp-client isc-dhcp-common isenkram-cli
  iso-codes iw keyboard-configuration klibc-utils kmod krb5-locales libaa1 libaacs0
  libamd2 libapparmor1 libappstream-glib8 libappstream4 libapr1 libaprutil1
  libaprutil1-dbd-sqlite3 libaprutil1-ldap libapt-inst2.0 libapt-pkg-perl
  libapt-pkg5.0 libarchive13 libargon2-1 libasan4 libasound2 libasound2-data
  libasound2-plugins libaspell15 libassuan0 libatk-adaptor libatk-bridge2.0-0
  libatk1.0-0 libatk1.0-data libatkmm-1.6-1v5 libatomic1 libatspi2.0-0
  libaudit-common libaudit1 libaugeas0 libavahi-client3 libavahi-common-data
  libavahi-common3 libavahi-core7 libavahi-glib1 libavahi-gobject0 libavcodec-extra
  libavcodec-extra58 libavfilter7 libavformat58 libavresample4 libavutil56
  libayatana-indicator3-7 libbabl-0.1-0 libbinutils libblas3 libblkid1
  libblockdev-crypto2 libblockdev-fs2 libblockdev-loop2 libblockdev-part-err2
  libblockdev-part2 libblockdev-swap2 libblockdev-utils2 libblockdev2
  libboost-atomic1.62.0 libboost-chrono1.62.0 libboost-date-time1.62.0
  libboost-filesystem1.62.0 libboost-iostreams1.62.0 libboost-locale1.62.0
  libboost-system1.62.0 libboost-thread1.62.0 libbrlapi0.6 libbrotli1 libc-bin
  libc-dev-bin libc-l10n libc6 libc6-dev libcacard0 libcairo-gobject-perl
  libcairo-gobject2 libcairo-perl libcairo2 libcairomm-1.0-1v5 libcamd2
  libcanberra-gtk3-0 libcanberra-gtk3-module libcanberra-pulse libcanberra0
  libcap-ng0 libcap2 libcap2-bin libcc1-0 libccid libccolamd2 libcdr-0.1-1 libcec4
  libchamplain-0.12-0 libchamplain-gtk-0.12-0 libcheese-gtk25 libcheese8
  libcholmod3 libchromaprint1 libcilkrts5 libclutter-1.0-0 libclutter-1.0-common
  libclutter-gst-3.0-0 libclutter-gtk-1.0-0 libcmis-0.5-5v5 libcodec2-0.8.1
  libcogl-common libcogl-pango20 libcogl-path20 libcogl20 libcolamd2 libcolord2
  libcolorhug2 libcom-err2 libcomerr2 libcrack2 libcroco3 libcryptsetup12 libcue2
  libcurl3-gnutls libcurl4 libdatrie1 libdazzle-1.0-0 libdb5.3 libdbus-1-3
  libdbus-glib-1-2 libdbusmenu-glib4 libdbusmenu-gtk3-4 libdconf1 libdebconfclient0
  libdee-1.0-4 libdevmapper-event1.02.1 libdevmapper1.02.1 libdjvulibre-text
  libdjvulibre21 libdmapsharing-3.0-2 libdouble-conversion1 libdrm-amdgpu1
  libdrm-common libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libdv4 libdw1
  libe-book-0.1-1 libedit2 libefiboot1 libefivar1 libegl-mesa0 libelf1
  libenchant1c2a libepoxy0 libespeak-ng1 libetonyek-0.1-1 libevdev2
  libevdocument3-4 libevview3-3 libext2fs2 libfdisk1 libfdt1 libffi6
  libfftw3-double3 libfftw3-single3 libflatpak0 libflite1 libfontconfig1
  libfreetype6 libfribidi0 libfstrm0 libfuse2 libfwupd2 libgail-3-0 libgbm1
  libgcab-1.0-0 libgcc-7-dev libgcc1 libgck-1-0 libgcr-base-3-1 libgcr-ui-3-1
  libgcrypt20 libgd3 libgdata-common libgdata22 libgdbm-compat4 libgdk-pixbuf2.0-0
  libgdk-pixbuf2.0-bin libgdk-pixbuf2.0-common libgdm1 libgee-0.8-2 libgegl-0.4-0
  libgegl-common libgeoclue-2-0 libgeocode-glib0 libgexiv2-2 libgfbgraph-0.2-0
  libgfortran5 libgirepository-1.0-1 libgjs0g libgl1-mesa-glx libglapi-mesa
  libglib-object-introspection-perl libglib-perl libglib2.0-0 libglib2.0-bin
  libglib2.0-data libglibmm-2.4-1v5 libglx-mesa0 libgmime-3.0-0 libgmp10
  libgnome-autoar-0-0 libgnome-bluetooth13 libgnome-desktop-3-17 libgnome-menu-3-0
  libgnome-todo libgnomekbd-common libgnomekbd8 libgnutls30 libgoa-1.0-0b
  libgoa-1.0-common libgoa-backend-1.0-1 libgom-1.0-0 libgomp1 libgovirt-common
  libgovirt2 libgpg-error0 libgpgme11 libgpgmepp6 libgphoto2-6 libgphoto2-l10n
  libgphoto2-port12 libgpod-common libgpod4 libgraphene-1.0-0
  libgraphicsmagick-q16-3 libgraphite2-3 libgrilo-0.3-0 libgs9 libgs9-common
  libgsf-1-114 libgsf-1-common libgsm1 libgsound0 libgspell-1-1 libgspell-1-common
  libgssapi-krb5-2 libgssdp-1.0-3 libgstreamer-gl1.0-0
  libgstreamer-plugins-bad1.0-0 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0
  libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk-vnc-2.0-0 libgtk3-perl libgtkd-3-0
  libgtkmm-3.0-1v5 libgtksourceview-3.0-1 libgtksourceview-3.0-common
  libgtop-2.0-11 libgtop2-common libgucharmap-2-90-7 libgupnp-1.0-4
  libgupnp-av-1.0-2 libgupnp-dlna-2.0-3 libgupnp-igd-1.0-4 libgusb2 libgvnc-1.0-0
  libgweather-3-15 libgweather-common libgxps2 libharfbuzz-icu0 libharfbuzz0b
  libhogweed4 libhtml-parser-perl libhtml-tree-perl libhunspell-1.6-0 libhyphen0
  libical3 libicu-le-hb0 libidn2-0 libiec61883-0 libimobiledevice6 libinput-bin
  libinput10 libio-socket-ssl-perl libip4tc0 libip6tc0 libiptc0 libiptcdata0
  libitm1 libiw30 libjansson4 libjavascriptcoregtk-4.0-18 libjbig2dec0 libjs-jquery
  libjson-c3 libjson-glib-1.0-0 libjson-glib-1.0-common libk5crypto3 libkeyutils1
  libklibc libkmod2 libkpathsea6 libkrb5-3 libkrb5support0 liblapack3 liblcms2-2
  liblcms2-utils libldap-2.4-2 libldap-common libldb1 liblirc-client0
  liblist-moreutils-perl libllvm6.0 liblocale-gettext-perl liblouis-data
  liblouisutdml-bin liblouisutdml-data liblouisutdml8 liblsan0 libltdl7 liblua5.3-0
  liblz4-1 liblzma5 libmagic-mgc libmagic1 libmariadbclient18 libmbim-glib4
  libmbim-proxy libmicrohttpd12 libmm-glib0 libmount1 libmpfr6 libmpx2
  libmspub-0.1-1 libmtp-common libmtp-runtime libmtp9 libnautilus-extension1a
  libncurses5 libncurses6 libncursesw5 libncursesw6 libnet-dbus-perl
  libnet-ssleay-perl libnettle6 libnewt0.52 libnghttp2-14 libnm0 libnma0 libnorm1
  libnotify-bin libnotify4 libnspr4 libnss-myhostname libnss3 libnuma1 liboauth0
  libofa0 libopenal-data libopenal1 libopencv-core3.2 libopencv-imgproc3.2
  libopenjp2-7 libopenmpt0 libopus0 liborc-0.4-0 libosinfo-1.0-0 libosinfo-bin
  libostree-1-1 libp11-kit0 libpackagekit-glib2-18 libpam-cracklib
  libpam-gnome-keyring libpam-modules libpam-modules-bin libpam-runtime
  libpam-systemd libpam0g libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0
  libpangomm-1.4-1v5 libpangoxft-1.0-0 libpaper-utils libpaper1
  libparted-fs-resize0 libparted2 libpcaudio0 libpcre2-16-0 libpcre2-8-0
  libpcsclite1 libpeas-1.0-0 libpeas-common libperl5.26 libpgm-5.2-0
  libphodav-2.0-0 libphodav-2.0-common libphonenumber7 libpinyin-data libpinyin13
  libpipeline1 libpixman-1-0 libplist3 libpng16-16 libpolkit-agent-1-0
  libpolkit-backend-1-0 libpolkit-gobject-1-0 libpoppler-glib8 libpopt0
  libpostproc55 libprotobuf-c1 libprotobuf10 libproxy1v5 libpsl5
  libpulse-mainloop-glib0 libpulse0 libpulsedsp libpwquality-common libpwquality1
  libpython-stdlib libpython2-stdlib libpython2.7 libpython2.7-minimal
  libpython2.7-stdlib libpython3.6 libpython3.6-minimal libpython3.6-stdlib
  libqmi-glib5 libqmi-proxy libqpdf21 libqt5core5a libqt5dbus5 libqt5gui5
  libqt5network5 libqt5widgets5 libquadmath0 libquvi-0.9-0.9.3 libqxp-0.0-0
  libraw19 librdf0 librest-0.7-0 librsvg2-2 librsvg2-common librygel-core-2.6-2
  librygel-db-2.6-2 librygel-renderer-2.6-2 librygel-server-2.6-2 libsasl2-2
  libsasl2-modules libsasl2-modules-db libsbc1 libsdl1.2debian libsecret-1-0
  libsecret-common libsemanage-common libsemanage1 libsgutils2-2 libsigc++-2.0-0v5
  libslang2 libsmartcols1 libsmbclient libsndio7.0 libsnmp-base libsodium23
  libsonic0 libsoundtouch1 libsoup-gnome2.4-1 libsoup2.4-1 libspandsp2 libspeechd2
  libspice-client-glib-2.0-8 libspice-client-gtk-3.0-5 libspice-server1
  libsqlite3-0 libss2 libssh-gcrypt-4 libssl1.0.2 libssl1.1
  libstartup-notification0 libstdc++6 libsuitesparseconfig5 libswresample3
  libswscale5 libsystemd0 libtag1v5 libtag1v5-vanilla libtagc0 libtalloc2 libtbb2
  libtcl8.6 libtdb1 libteamdctl0 libtesseract4 libtevent0 libtext-charwidth-perl
  libtext-iconv-perl libthai-data libthai0 libtiff5 libtinfo5 libtinfo6 libtk8.6
  libtotem-plparser-common libtotem-plparser18 libtotem0 libtracker-control-2.0-0
  libtracker-miner-2.0-0 libtracker-sparql-2.0-0 libtsan0 libubsan0 libudev1
  libudisks2-0 libumfpack5 libupower-glib3 liburi-perl libusbmuxd4 libusbredirhost1
  libusbredirparser1 libuuid-perl libuuid1 libv4l-0 libv4lconvert0 libva-drm2
  libva-x11-2 libva2 libvdeplug2 libvdpau1 libvirt-daemon libvirt0 libvisio-0.1-1
  libvisual-0.4-0 libvolume-key1 libvte-2.91-0 libvte-2.91-common libvted-3-0
  libvulkan1 libwacom-bin libwacom-common libwacom2 libwavpack1 libwayland-client0
  libwayland-cursor0 libwayland-egl1 libwayland-server0 libwbclient0
  libwebkit2gtk-4.0-37 libwildmidi-config libwildmidi2 libwmf0.2-7 libwnck-3-0
  libwnck-3-common libwpd-0.10-10 libwpg-0.3-3 libwww-perl libx11-6 libx11-data
  libx11-xcb1 libxapian30 libxatracker2 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0
  libxcb-icccm4 libxcb-present0 libxcb-randr0 libxcb-render0 libxcb-res0
  libxcb-shape0 libxcb-shm0 libxcb-sync1 libxcb-xf86dri0 libxcb-xfixes0
  libxcb-xinerama0 libxcb-xkb1 libxcb-xv0 libxcb1 libxcursor1 libxenstore3.0
  libxinerama1 libxkbcommon-x11-0 libxkbcommon0 libxklavier16 libxml-parser-perl
  libxml2 libxml2-utils libxmlsec1 libxmlsec1-nss libxss1 libxtables12 libyajl2
  libyelp0 libzapojit-0.0-0 libzbar0 libzeitgeist-2.0-0 libzmf-0.0-0 libzmq5
  libzstd1 libzvbi-common libzvbi0 lightning linux-image-amd64 linux-libc-dev
  locales lsof ltrace lua-json lvm2 man-db media-player-info mesa-utils
  mesa-va-drivers mesa-vdpau-drivers mlocate modemmanager mount mousetweaks mtools
  multiarch-support mutter mutter-common mysql-common nano nautilus nautilus-data
  ncurses-base ncurses-bin net-tools netbase netcat-openbsd network-manager
  network-manager-gnome network-manager-openvpn network-manager-openvpn-gnome
  network-manager-pptp network-manager-pptp-gnome notification-daemon ntfs-3g ntp
  openprinting-ppds opensc opensc-pkcs11 openssh-client openssl orca os-prober
  osinfo-db p11-kit p11-kit-modules packagekit packagekit-tools parted pcmciautils
  pcscd perl perl-base policykit-1 poppler-utils ppp printer-driver-foo2zjs
  printer-driver-foo2zjs-common printer-driver-gutenprint printer-driver-min12xxw
  printer-driver-sag-gdi psmisc pulseaudio pulseaudio-module-bluetooth
  pulseaudio-utils purism-power-optimisations python python-apt python-apt-common
  python-bcrypt python-cffi-backend python-gdbm python-gi python-jwt python-ldb
  python-minimal python-nacl python-oauthlib python-olefile python-openssl
  python-paramiko python-pil python-samba python-six python-talloc python-tdb
  python-urllib3 python2 python2-minimal python2.7 python2.7-minimal
  python3-certifi python3-chardet python3-cupshelpers python3-gi python3-gi-cairo
  python3-louis python3-olefile python3-pkg-resources python3-pyatspi
  python3-requests python3-six python3-speechd python3-urllib3 python3.6
  python3.6-minimal qpdf qt5-gtk-platformtheme qttranslations5-l10n rfkill
  rhythmbox-data rsync rsyslog rygel samba-common samba-common-bin samba-libs
  seabios seahorse sed shared-mime-info simple-scan sntp speech-dispatcher
  speech-dispatcher-audio-plugins speech-dispatcher-espeak-ng
  spice-client-glib-usb-acl-helper spice-vdagent squashfs-tools ssh-askpass-gnome
  strace sudo switcheroo-control system-config-printer-common
  system-config-printer-udev systemd systemd-sysv sysvinit-utils tar tasksel
  tasksel-data tcl8.6 telnet thin-provisioning-tools thunderbird tilix tilix-common
  tk8.6 totem totem-common totem-plugins tracker tracker-extract tracker-miner-fs
  tzdata ucf udev udisks2 ufw unattended-upgrades uno-libs3 update-inetd upower ure
  usbmuxd usbutils util-linux uuid-runtime va-driver-all vdpau-driver-all
  vim-common vim-tiny webext-https-everywhere webext-ublock-origin wget whiptail
  wireless-tools wpasupplicant xbrlapi xdg-desktop-portal xdg-desktop-portal-gtk
  xdg-user-dirs xdg-user-dirs-gtk xserver-common xserver-xephyr xserver-xorg-core
  xserver-xorg-input-libinput xserver-xorg-legacy xserver-xorg-video-amdgpu
  xserver-xorg-video-ati xserver-xorg-video-intel xserver-xorg-video-nouveau
  xserver-xorg-video-radeon xwayland xxd xz-utils yelp yelp-xsl zeitgeist-core
  zenity zenity-common
1076 upgraded, 81 newly installed, 0 to remove and 60 not upgraded.
Need to get 860 MB of archives.
After this operation, 647 MB of additional disk space will be used.
Do you want to continue? [Y/n]

About both errors, I saw some posts and could be related with some kernel modules. We should wait for PureOS developers.

Okay, proceed to upgrade.

I dont believe upgrade solve your problem but anyways you should maintain your system up-to-date for others reasons and make sure about both errors are not solved yet.

EchedeyLR added projects: Restricted Project, Restricted Project.Feb 17 2019, 1:03 AM

It's upgrading right now...it's going to take awhile. I'll reboot and try the wifi when the upgrade is complete and I'll let you know.

That took awhile! But the whole process ran. I rebooted (the computer wouldn't shut down properly) and tried connecting via wifi. No luck. It wont even recognize available networks, which it has done in the past.
Incidentally, the error I've been getting from when I tried installing Linux mint definitely has something to do with the touchpad, but I've tried installing LM with the touchpad turned off and no dice.
So I can't install Mint, but I can install PureOS but can't get the driver for the wifi card.
Hmmmmm. I haven't given up yet.

The first error I read it was related with some kernel modules used for the touchpad but I was not sure. Please, run lshw again and dmesg.

EchedeyLR added a comment.EditedFeb 17 2019, 2:14 AM

The driver should be provided by the kernel like the old version.

The first error I read it was related with some kernel modules used for the touchpad but I was not sure. Please, run lshw again and dmesg.

I will in the morning. I shut the computer down for the night and to hook it up to the ethernet cable is annoying because the router is in an inconvenient spot.
Thank you for your help today...to be continued in the morning.

Where are we on this? Have things connected or are there still issues that I can help with?

EchedeyLR added a comment.EditedFeb 23 2019, 1:38 AM

I asked him show lshw again to see if hardware is detected, correct driver used and capabilities detection. He said WiFi does not work now he upgraded. On the version before, it only failed to connect.

Let's close this one out guys. I wasn't able to get it working and gave up as I dont have the time.
I appreciate all the help.
Incidentally, I sold the computer to a guy who was handy with linux scripts and he said a "short" script would solve this. But again, its beyond my scope and time constraints.
PureOS seemed like a really slick OS too.
Maybe someday.

jonas.smedegaard changed the task status from "Open" to "Incomplete".Feb 24 2019, 3:34 PM
jonas.smedegaard added a subscriber: jonas.smedegaard.

Thanks for trying, @jgn2112

jonas.smedegaard closed this task as "Resolved".Feb 24 2019, 3:35 PM
jonas.smedegaard claimed this task.

(hm, not really resolved, but seems that's the option we got in this interface)

Add Comment