Add "network-manager-openvpn-gnome" to the list of preinstalled packages
Closed, ResolvedPublic

Description

"network-manager-openvpn-gnome" is required when configuring Purist Tunnel from the GNOME desktop. Please add it to the list of preinstalled packages (i.e. included by default on a fresh PureOS install).

From internal discussion:

David wants "network-manager-openvpn-gnome" to be preinstalled in
PureOS

Fine with me. From a regular PureOS GNOME installation this would only
pull in "openvpn" and "network-manager-openvpn" etc. as dependencies,
requiring 2,542KiB of extra disk space in total.

d3vid created this task.Jun 21 2018, 10:47 AM
zlatan.todoric reassigned this task from chris.lamb to mak.Jun 21 2018, 2:26 PM
zlatan.todoric added a subscriber: chris.lamb.

@zlatan.todoric Why re-assign? I did the last pureos-meta upload at least & was literally just doing this another window (have stopped, mind you..)

eh, you can do it, I assigned it to mak as he was doing all previous uploads (the ones I recall) though assigning is not at all blocker for anyone else to do it so go ahead (also on contrary, if you see some assigned bug to other person but you can fix it, go ahead).

if you see some assigned bug to other person but you can fix it, go ahead

Eek, are you sure you meant that. That sounds like a recipe for disaster, quite frankly.. Or at least unnecessary cognitive overhead that someone might swoop in and invalidate/duplicate your work. (Sure, say "oh hey, ping, okay if I take over", but that doesn't sound like what you are suggesting here)

Yeah, I did mean in collaborative way (aka ping the current maintainer, offer help etc). Thanks for noticing my not so good way of putting it out :)

chris.lamb added a subscriber: mak.

I'll take this back unless there is strong objection as it's still literally open in another window..although will upload after lunch.. :)

@d3vid

Just went to do this but network-manager-gnome-openvpn is already in the list of Recommends since 31 May 2017 and crucially is actually on the same level as network-manager-gnome. Thus, whatever installed network-manager-gnome via the recommends system should have also installed network-manager-openvpn-gnome for you.

However, this means that I don't understand how the "default install" is populated. ie. I am pretty certain I did not manually install network-manager-gnome on my system installed a few months ago, yet I do not have network-manager-gnome-openvpn.

@mak, I read your README.md (thanks!) but it seems to imply stuff on that list would just be installed? Perhaps network-manager is special-cased somewhere?

mak added a comment.EditedJun 21 2018, 10:45 PM

@chris.lamb No, if network-manager-openvpn-gnome is in the list it *will* be installed, unless there is something else pulled in that is mandatory and conflicts with the package.
It will not be explicitly seeded if it is pulled in by another package that is also seeded.

In this particular case though, there doesn't seem to be a bug here. I verified both in a chroot, on my current PureOS installation and on the current live-image that network-manager-openvpn-gnome is indeed preinstalled already. I also remember adding it a while back.
@d3vid why do you think the package is not installed by default? Maybe it was removed on your system by something else?

@mak I fear you have misread this bug report. This is about network-manager-openvpn-gnome, not network-manager-gnome.

mak added a comment.Jun 22 2018, 8:19 AM

@chris.lamb I didn't misread the report, I just mistyped the package name (fixed). The statement in itself is still true.

In that case network-manager-openvpn-gnome was definitely not installed on my new system (installed 2018-04-26). :)

d3vid added a comment.Jun 27 2018, 2:29 PM

@mak I've been meaning to file this issue for a while, so it could be the update happened between my last install and me actually filing the issue. Since you've confirmed it I'm happy to close.

As an aside, how can I check on my system (with apt?) if a package has preinstalled status or not? I'm imagining something like:

$ sudo apt update
$ sudo apt upgrade
$ sudo apt magicmagic -package packagename
packagename: marked-for-preinstall

Check the Depends and Recommends of, for example, the pureos-gnome packages (and similar).

I note that network-manager-openvpn-gnome is in Recommends, which may suggest why it is not installed. I defer to @mak as before ^^

chris.lamb triaged this task as "Normal" priority.Jun 29 2018, 5:39 PM
mak added a comment.Jun 30 2018, 6:14 PM

@chris.lamb That it's in recommends just means that a user can remove the package.

I will likely trigger a new image build today, and if the package is present by default, I will close this bug.

Please note that when we add new default applications, they only get installed on *new* installations, we don't just install random stuff on existing systems (unless a new essential package is added that the user will be unable to remove without installing the seed package anyway).
So, if your PureOS installation is older from before the package was added to the default set, it's natural and expected that the package isn't installed.

mak closed this task as "Resolved".Jun 30 2018, 10:50 PM

I just generated new images, network-manager-openvpn-gnome is preinstalled on all of them ([installed,automatic]).
I therefore think it's safe to close this issue.

Please open another one if you should ever see that the package is missing on new installations.
Thank you!

d3vid added a comment.Jul 1 2018, 5:00 AM

Thanks for confirming that @mak , much appreciated!

So if I sudo apt update and a package is in EITHER the Depends OR Recommends of pureos-gnome, then I know its on the pre-installed list, even if I didn't get it on my (older) installation. Is that correct?

mak added a comment.Jul 1 2018, 5:33 AM

@d3vid Yes - although technically, you would also need to check the recommends of the whole dependency tree that pureos-gnome (or any other package) depends on.
If the package is in the Depends line, you will have it regardless of whether the installation is new, if it is just recommended it might only be present on new installations.

Interesting, I wonder what caused network-manager-openvpn-gnome to not be installed on my new system... Ah well!

Add Comment