Page MenuHomePureOS Tracker

After an apt update, the Release file is expired or not yet valid
Incomplete, NormalPublic

Description

in apt update... release is Expired

Event Timeline

wellton created this task.May 30 2018, 07:03
mak closed this task as Resolved.Jun 2 2018, 14:09
mak claimed this task.
mak added a subscriber: mak.

That was fixed three days ago already.
Thanks for reporting the issue.

joao.azevedo reopened this task as Open.EditedApr 16 2019, 15:56
joao.azevedo added a subscriber: joao.azevedo.

This issue resurfaced. Noticed it by running an update at around 00h10 Central European Time

joao@librem:~$ sudo apt update Get:1 https://repo.puri.sm/pureos green InRelease [10,5 kB] Reading package lists... Done E: Release file for https://repo.puri.sm/pureos/dists/green/InRelease is not valid yet (invalid for another 6h 49min 42s). Updates for this repository will not be applied.

At 00h40 CET however, the problem no longer persisted. I was able to run the update.

Edit: the image used was: pureos-8.0-gnome-live_20190210-amd64.hybrid.iso downloaded from pureos.net

mak changed the task status from Open to Incomplete.Apr 16 2019, 16:08

I can reproduce this here. The timezone shouldn't actually cause any problems here, yet the Release file was apparently signed and piblished with a timestamp in the future to your system. Very strange. There is no unusual behavior going on in the archive as far as I can see.

jeremiah.foster renamed this task from Apt update, release is Expired to After an apt update, the Release file is expired or not yet valid.Apr 23 2019, 06:20
jeremiah.foster lowered the priority of this task from Unbreak Now! to Normal.

We saw this behavior again today (see internal chat system for more.) I cannot reproduce but am just noting here that others are reporting this issue.

mak added a comment.Jun 10 2019, 06:29

Hmm... I can't reproduce this either and looking at https://repo.pureos.net/pureos/dists/green/InRelease all dates are correct.