Installation process: Is my second disk encrypted?
Closed, ResolvedPublic

Description

Steps to reproduce:

  • Install PureOS from ISO on a two-disk system
  • When presented with option to encrypt installation medium, say yes

What should happen:

  • Prompted to unlock disk(s) on machine startup
  • Both disks are encrypted

What happens instead:

  • Prompted to unlock disk(s?) on machine startup
  • ???

How can I confirm that both of my disks are encrypted?

d3vid created this task.Apr 24 2018, 12:42 PM

One way to inspect what is on encrypted volumes is typing lsblk in a terminal - volumes in branches off of a *_crypt entry is encrypted.

d3vid closed this task as "Resolved".Apr 24 2018, 1:24 PM
d3vid claimed this task.

Thanks! lsblk results:

NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
loop0                                           7:0    0 239.1M  1 loop  /snap/pycharm-community/58
loop1                                           7:1    0  86.5M  1 loop  /snap/core/4407
loop2                                           7:2    0  86.6M  1 loop  /snap/core/4486
sda                                             8:0    0 232.9G  0 disk  
└─sda1                                          8:1    0 232.9G  0 part  /media/user/11111111-1111-1111-1111-111111111111
nvme0n1                                       259:0    0 465.8G  0 disk  
├─nvme0n1p1                                   259:1    0   1.1G  0 part  /boot
├─nvme0n1p2                                   259:2    0 447.5G  0 part  
│ └─luks-22222222-2222-2222-2222-222222222222 254:0    0 447.5G  0 crypt /
└─nvme0n1p3                                   259:3    0  17.1G  0 part  
  └─luks-33333333-3333-3333-3333-333333333333 254:1    0  17.1G  0 crypt [SWAP]

Suggesting that my second disk (mounted as sda1) is not encrypted. Also opened "Disks" and can see there that the partition is marked as "Ext4" not "LUKS".

I am confused: Did that actually fix the reported issue?

d3vid added a comment.Apr 24 2018, 2:07 PM

Perhaps I should have been clearer, this was just a query about *how* to check that my second disk is encrypted. You have answered my query so I closed the ticket :)

I expected that it would be encrypted, but since it isn't, I've expanded https://tracker.pureos.net/T403 to mention second-disk-encryption.

ok. Please in future use chat for guidance - or the user support forum, perhaps - as issue tracker is better suited to track issues (bugs and pseudo-bugs like wishlist requests) tied to components of the Operating system.

Add Comment