Tails website wrongly parses Purebrowser version as "0"
Closed, InvalidPublic

Description

I was attempting to download Tails through Purebrowser and the Tails site attempts to validate the browser version used before it allows you to download. Purebrowser is reporting itself as Firefox version 0 so Tails would not allow it to be downloaded.

jonas.smedegaard changed the title from "Purebrowser reports its Firefox version as "0"" to "Tails website wrongly parses Purebrowser version as "0"".Jan 26 2018, 9:30 AM
jonas.smedegaard closed this task as "Invalid".Jan 26 2018, 9:35 AM
jonas.smedegaard added a subscriber: jonas.smedegaard.

This is not a bug in PureBrowser, but instead in that specific website.

Seemingly that website makes the bogus assumption that the browser must be Firefox, and then tries to resolve which version of Firefox it is (which will obviously fail since it isn't representing itelf as such).

Closing this bugreport as bogus (outside the scope of this operating system - but at the same time tying it to T247 about choice of user-agent string as an example of the kind of collaterate issues is caused by the way we (currently - debatable at that other issue) present our browser.

Before the ticket is closed for good, could you provide a User Agent string workaround (if that would work, otherwise some other workaround) so we have steps to present to another user who runs into this or similar problems?

PureBrowser is a quite close cousin of the particular Mozilla techonlogy called "Firefox".

My advice to our users is therefore to search at https://duckduckgo.com/ for "Firefox change user agent string" (without the quotes) - that should provide excellent guides like https://www.howtogeek.com/113439/how-to-change-your-browsers-user-agent-without-installing-any-extensions/ and (to ensure that the method used is reasonably current) Mozilla's own https://support.mozilla.org/da/questions/1161844 - or install a plugin like https://addons.mozilla.org/en-US/firefox/addon/uaswitcher/ (notice that some plugins - including the most popular one for changing user agent - do not support the version of Mozilla technology that we use for PureBrowser).

jonas.smedegaard added a comment.EditedJan 27 2018, 8:29 AM

This issue is flagged as "invalid" but not "closed for good".

I am not familiar enough with this issue tracker to know when - if ever - issues are "closed for good". You and others are welcome to continue discussing here - the flag is only used as a help to track the state of the issue, not to silence conversations around it.

@kyle.rankin Do you recall more detailed how/where the Tails website broke? Is it still the case?

We consider changing User-Agent string again (see T595) and it would be interesting to have a variety of badly designed websites to test against, to know how they react to different kinds of tweaking of the User-Agent string.

Add Comment