Page MenuHomePureOS Tracker

PureOS grsecurity failing on epiphany, gnome-www-browser, or gnome-web
Closed, ResolvedPublic


I *tried* to track down Gnome "Web" (worst name ever) lib to add to paxctld, but could not get it to work.

Without grsec Epiphany "Web" works fine.
With grsec Epiphany "Web" tries to load a page and loops that page load attempt.

Event Timeline

todd created this task.Mar 13 2017, 17:02

Adding /usr/bin/epiphany-browser to paxctld doesn't solve this?

todd added a comment.Mar 14 2017, 17:06

I tried both of these:

/usr/bin/epiphany-browser                               m
/usr/bin/epiphany                                       m

Without any luck.

can you also add /usr/lib/x86_64-linux-gnu/webkit2gtk-4.0/WebKitWebProces in the list and check

If that fails, can you run this command and see
paxctl -c /usr/lib/x86_64-linux-gnu/webkit2gtk-4.0/WebKitWebProcess
paxctl -m /usr/lib/x86_64-linux-gnu/webkit2gtk-4.0/WebKitWebProcess

todd added a comment.Mar 23 2017, 13:44

Epiphany is now working by adding:

/usr/lib/x86_64-linux-gnu/webkit2gtk-4.0/WebKitWebProcess m

new revision is uploaded containing the changes mentioned above.

hema.prathaban closed this task as Resolved.Mar 31 2017, 23:48