PureOs freezing
Closed, ResolvedPublic

Description

Hi,

On several occasions the OS is freezing completely, no solution except rebooting the all system...
for example : sometimes using VLC media player the video or audio freeze totally, or using 'space bar' to visualize an .odt file, etc.

QiZhi created this task.Nov 26 2017, 6:33 PM
QiZhi edited the task description. (Show Details)

Hi QiZhi,

Following the reboot are there any relevant messages in /var/log/syslog?

Also are you using Nautilus as a file manager? I was having a similar issue recently and was getting lots of:
org.gnome.Nautilus[1027]: Failed to open VDPAU backend libvdpau_i965.so: cannot open shared object file: No such file or directory
I chose to remove Nautilus and haven't had a problem since. Possibly related to this existing upstream bug

@krisgesling Can you elaborate why Nautilus would be the culprit here?

Short answer, I was wrong...

I was investigating a similar issue. Whole computer freezing whilst using VLC in fullscreen mode. audio would loop over a short 1ish second loop.
When I checked /var/log/syslog I was seeing heaps of the VDPAU errors attributed to nautilus just before the reboot. So I uninstalled nautilus to see if it was causing the reboots and it stopped rebooting... for a period of time.

Unfortunately it's still rebooting randomly whilst using VLC in fullscreen mode. It always seems to be when I pause, enter fullscreen, or some other action - not in the middle of just playing a video. Nautilus is still uninstalled so clearly not the culprit :(

Not sure what other logs to check or other action to diagnose. Any suggestions?

@krisgesling This sounds like a lower-level issue, either in your graphics driver or there is a problem with your hardware. (Given you are playing video, it could be overheating, just as one example.) Can you briefly outline your hardware? Thanks.

It's a Librem 15v2.

It does get pretty warm, and I live in far northern Australia which is just generally hot and doesn't help things.

@krisgesling If it's doing this after watching video for a while, this might be the case. Otherwise it's likely some kind of BIOS/video card/blah interaction. Can you speak to the timings here? It could also be faulty RAM, etc. etc. :)

(I cannot reproduce this, alas!)

I ran MemTest86 v7.4 through the default 4 tests and it returned no errors.

I think I'm due for a fresh OS install, will see if it returns after that.

Thanks @krisgesling. Let me know either way.

QiZhi added a comment.EditedJan 11 2018, 11:24 AM

Having no problem regarding to heat or warm area, my problem was solved with the last update of VLC.
Thx for your concern.

chris.lamb closed this task as "Resolved".Jan 11 2018, 11:56 AM

Thanks!

Add Comment