Librem13v2 Touchpad not working with OEM install
Closed, ResolvedPublic

Description

(Sorry if this is a duplicate as I know you are already aware of the issue. I haven't been able to find it in the existing tasks so I post it.)

When starting the OEM install on a brand new Librem 13 v2, the touchpad is not working. Plugging an external USB mouse does work.

francois added a project: Restricted Project.Jun 27 2017, 3:30 PM
zlatan.todoric added a subscriber: zlatan.todoric.

@lamby, please take a look and debug this one.

zlatan.todoric triaged this task as "Unbreak Now!" priority.Feb 1 2018, 3:26 AM

@francois "OEM install" - you are using the downloaded ISO? If so, please give me the SHA1 of said image so we are working from the same version as there were some changes recently.

@chris.lamb The latest one where I could reproduce the bug with was the one from 2018-01-20

https://downloads.puri.sm/oem/gnome/2018-01-20/pureos-8.0-gnome-oem_20180120-amd64.hybrid.iso

This is stumping me at the moment, alas. Whilst the trackpad is being detected, it does not appear to be registering as a mouse device. Well, /dev/input/event5 is being detected as the touchpad, rather than /dev/input/mouse0 ("no input driver specified"). Not sure if that is even meaningful. X has -- unfortunately -- always worked for me in the past. Device exists in /proc/bus/input/devices as expected

This might be an evdev/libinput thing, but d-i does not ship (has has not shipped) with libinput, so there is possibly some hardware regression/change involved here.

Can you confirm that this has worked before?

@chris.lamb no, I cannot confirm that it has ever been working. I have never seen it work.

However, I have only tested one or 2 OEM installs so you should ask Zlatan or Matthias as they should have more experience than me about it.

Thanks. Have synced with debian-boot team on this..

I'd like to weigh in and let you know the same thing happened to me in my new Librem 15 purchase of a month ago. I keyboarded my way through the setup and then the trackpad worked after final boot into the windowing environment.

Thanks!

@tharvill Underlining this is not a (recent!) regression is helpful, thank you. I am fairly certain it's a somewhat structural problem with the Debian Installer generally which will require some work in Debian itself.

This comment was removed by I_have_issues.

I have never got multitouch, or two finger click to work. I run Ubuntu 17.10.

If it is not working at all for some, maybe try Fn+F1 to toggle on/off the track pad.

@I_have_issues wrote:

I have never got multitouch, or two finger click to work. I run Ubuntu 17.10.

This is a separate issue to any multitouch issues, I'm afraid :)

mak closed this task as "Resolved".Apr 11 2018, 1:22 AM
mak added a subscriber: mak.

This should be resolved via T365 (doesn't fix the d-i problem, but still resolves the issue in PureOS since the install environment and regular PureOS environment are (almost) identical now, so touchpads work well).

Add Comment