Page MenuHomePureOS Tracker

gpodder consider packaging adaptive branch
Open, Needs TriagePublic

Description

I am creating this issue here because it might affect also amd64 versions and not just the Librem 5.

Currently the Librem 5 does not have a native DEB podcast client that is adaptive.

gpodder has an adaptive branch using libhandy: https://github.com/gpodder/gpodder/tree/adaptive

I have tested it on PureOS Byzantium, both on amd64 and on the Librem 5 byantium, and it works quite nice. And made a deb package out of it to check how easy it was to package it.

Having the adaptive version version of gpodder packaged for Byzantium would allow us to provide on the Librem 5 a podcast client as DEB.

So my question is:

Is there interest in packaging the adaptive version of gpodder for Byzantium?

If there is, I would volunteer to help with this.

/cc @guido @jeremiah.foster @carsten.schoenert

Event Timeline

Also AFIK there is no deb version of gpodder adaptive in debian experimental, unlike with other packages like dino-im.

Packaging an adaptive Gpodder for Byzantium is most welcome - thank you @joao.azevedo

Rhythmbox can also play podcasts, but Gpodder is a venerable, long-standing app that many use.

ok packaged the adaptive version of gpodder at: https://source.puri.sm/pureos/packages/gpodder-adaptive

If anyone wants to take a look and nitpick it. It is still marked as unreleased in the changelog. But it passes all the build tests, in case someone wants to try it out.

@guido any feedback here? ^^^ yay, nay, something else? :D

jeremiah.foster added a comment.EditedFri, Jan 14, 12:05

Are you using gbp? What's your conf look like?

Thanks for including the pristine-tar branch. Would be cool if you were to mention how you're building this. For example, just pasting the commands you did to build the deb?

So I ran the build with;

gbp buildpackage --git-debian-branch="pureos/master"

Lintian says;

E: gpodder source: invalid-version-number-for-derivative 3.10.21-1-1 (must end with pureosX)
W: gpodder source: inconsistent-appstream-metadata-license share/metainfo/org.gpodder.gpodder.appdata.xml (cc0-1.0 != gpl-3+)
W: gpodder: unusual-interpreter usr/share/gpodder/extensions/rm_ogg_cover.py #!/usr/bin/python
W: gpodder: unusual-interpreter usr/share/gpodder/extensions/rockbox_convert2mp4.py #!/usr/bin/python
W: gpodder: unusual-interpreter usr/share/gpodder/extensions/tagging.py #!/usr/bin/python
W: gpodder: wrong-bug-number-in-closes #T1096 in the installed changelog (line 3)
`

I'll try and fix the E: error but the one I worry about is this;

W: gpodder source: inconsistent-appstream-metadata-license share/metainfo/org.gpodder.gpodder.appdata.xml (cc0-1.0 != gpl-3+)

If you didn't touch the licensing then this is not an issue, if you did something with AppStream we should try to figure out this inconsistency.

Are we changing the defaults?

@@ -94,7 +94,7 @@ defaults = {
 
     # Software updates from gpodder.org
     'software_update': {
-        'check_on_startup': True,  # check for updates on start
+        'check_on_startup': False,  # check for updates on start
         'last_check': 0,  # unix timestamp of last update check
         'interval': 5,  # interval (in days) to check for updates
     },

@jeremiah.foster

Are we changing the defaults?

Debian changes that default for gppoder, it is a patch:

https://salsa.debian.org/debian/gpodder/-/blob/master/debian/patches/disable_update_check_on_startup_default.patch

I just kept that patch.

W: gpodder source: inconsistent-appstream-metadata-license share/metainfo/org.gpodder.gpodder.appdata.xml (cc0-1.0 != gpl-3+)

no I did not touched any of the copyright. The debian/copyright file does not currently list the cc0-1.0 license for the file: share/metainfo/org.gpodder.gpodder.appdata.xml

Are you using gbp? What's your conf look like?

You are right. a gbp conf file is missing. Need to fix that.

For example, just pasting the commands you did to build the deb?

On different occasions I used:

debuild -us -uc -b

and
gbp buildpackage -us -uc -b --git-ignore-branch

W: gpodder source: inconsistent-appstream-metadata-license share/metainfo/org.gpodder.gpodder.appdata.xml (cc0-1.0 != gpl-3+)

This happen because the appdata.xml file is licensed by CC0-1.0 but d/copyright isn't respecting this. This a issue within Debian and some bug report worth.

I had a similar issue for KiCad some time ago and just needed to fix d/copyright.

Thank you both for the replies - I'll try and fix up and build.

Pushed my minor changes to the repo. (pureos/packages/gpodder-adaptive.git)
Uploaded to the repo.

Thanks @joao.azevedo

Will this automagically get built for the Librem 5 or do we have to put it into the build process for the Librem 5?

guido added a comment.Tue, Jan 18, 01:30

Everything that gets uploaded to the archive gets built for arm64 (librem5) automatically.