Page MenuHomePureOS Tracker

Package `Stream` broken in PureOS
Closed, ResolvedPublic


Currently the application stream in the pureOS repos is broken because it fails to search for a "strong instance" (invidious) to use to reproduce the videos.

Currently the latest commit to the application: fixes this issue. But there is not a new release tag.

There is a merge request to add a patch with this commit mentioned above to the PureOS package:

So IMO there is two ways to solve this issue with the PureOS package of Stream.

1 - Update the PureOS package of stream to the latest upstream commit. Which besides fixing this issue, might also add new features.
2 - Merge the patch and just do a minor release to unbreak the Stream package in PureOS.

Event Timeline

joao.azevedo renamed this task from Package Stream` broken in PureOS to Package `Stream` broken in PureOS.Dec 20 2021, 04:23
joao.azevedo updated the task description. (Show Details)

@jeremiah.foster pinging you here because you packaged Stream for PureOS.

/cc @jonas.smedegaard

joao.azevedo updated the task description. (Show Details)Dec 20 2021, 04:25
jonas.smedegaard added a project: Restricted Project.Dec 20 2021, 05:35

I assume this issue is targeted byzantium - tagging accordingly.

PureOS byzantium is currently stable (or arguably in deep freeze prior to formal release as stable), and should therefore receive only minimal bug-fixes only.
It is therefore best to cherry-pick (and adapt as needed) the bugfix patch only, not bump to newer upstream release nor bump to newer upstream development snapshot.

jonas.smedegaard triaged this task as Normal priority.Dec 20 2021, 05:36

@joao.azevedo did the outside World change, so that this is a regression, or is this a functionality which *never* worked on Stream and the patch is effectively a feature addition?

@jonas.smedegaard yes, this targets Byzantium.

The "outside world" changed with that it broke the search via API that the package Stream does to search instances from which to reproduce the videos. That caused the app that previously worked to fail. The patch in the merge request: has been tested and fixes it.

The patch adds no new features, it just makes the app work again

Thanks for the clarification!

joao.azevedo closed this task as Resolved.Dec 22 2021, 22:15
joao.azevedo claimed this task.

The patch has been merged and a new release made: