Page MenuHomePureOS Tracker

gnome-software won't install on Byzantium
Closed, ResolvedPublic


After doing an upgrade, gnome-software was automatically removed from my Byzantium install.

trying to re-install it with apt results in the following error :

The following packages have unmet dependencies:
 gnome-software : Depends: software-properties-gtk but it is not going to be installed
                  Depends: libgnome-desktop-3-18 (>= 3.18.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

Event Timeline

francois created this task.Jun 3 2020, 00:16
mak claimed this task.Jun 3 2020, 09:47
mak closed this task as Resolved.Jun 3 2020, 10:10

This should be fixed now, but the update will need a few days to migrate out of landing.

francois added a comment.Jun 4 2020, 06:09

Thank you @mak ! I will retry in a few days then. Do you know how many days?

After trying to install gnome-software again, I now get the following error :

The following packages have unmet dependencies:
 python3-apt : Depends: python3 (< 3.8) but 3.8.2-3 is to be installed
E: Unable to correct problems, you have held broken packages.
jeremiah.foster reopened this task as Open.Jun 16 2020, 11:17
jeremiah.foster triaged this task as Normal priority.

I did;

sudo apt update
sudo apt upgrade
sudo apt install gnome-software
apt list gnome-software


gnome-software/byzantium,byzantium,now 3.36.0-3pureos1 amd64 [installed]

I can't recreate this @francois. Can you try again?

@jeremiah.foster I am still getting the same error after updating and upgrading.

You may have had a version of python3 < 3.8 already installed, which is not the case for me ?

niceguy added a subscriber: niceguy.Jun 17 2020, 03:06

My python version is;

$ python --version
Python 2.7.18

You must be using a very new version of python?

@jeremiah.foster I get the same output from the same command.

$ python --version
Python 2.7.18

I guess that gnome-software doesn't depend on python but on python3 through the python3-apt package but doesn't want a python3 version higher than 3.8.

$ python3 --version
Python 3.8.3

I just found out that the python3-apt package in Byzantium is not up to date and is at version 1.8.4, which is the same version as Debian stable, which is not compatible with python 3.8 :

python3-apt/byzantium 1.8.4pureos3 amd64

There is a newer version on Debian testing (2.1.3) that is compatible with python 3.8 ;

I think this might also be the cause of this problem:

mak closed this task as Resolved.Oct 3 2021, 09:48
mak added a project: Restricted Project.

This should be fixed in landing/byzantium for a while now :-)