Page MenuHomePureOS Tracker

exim4 installation fails; repo versions are inconsistent
Closed, ResolvedPublic

Description

Attempting to install exim4 via apt fails with the following errors:

E: Failed to fetch https://repo.pureos.net/pureos/pool/main/e/exim4/exim4-config_4.92-8+deb10u1_all.deb  404  Not Found [IP: 138.201.228.45 443]
E: Failed to fetch https://repo.pureos.net/pureos/pool/main/e/exim4/exim4-base_4.92-8+deb10u1_amd64.deb  404  Not Found [IP: 138.201.228.45 443]
E: Failed to fetch https://repo.pureos.net/pureos/pool/main/e/exim4/exim4-daemon-light_4.92-8+deb10u1_amd64.deb  404  Not Found [IP: 138.201.228.45 443]
E: Failed to fetch https://repo.pureos.net/pureos/pool/main/e/exim4/exim4_4.92-8+deb10u1_all.deb  404  Not Found [IP: 138.201.228.45 443]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

apt reports, for example, that the available version of exim4-base is:

$ apt show exim4-base
Package: exim4-base
Version: 4.92-8+deb10u1

The .deb file in the repo is in fact:

exim4-base_4.92-8+deb10u3_amd64.deb 28-Sep-2019 23:20 1134852

I wouldn't normally concern myself with exim, but it's a dependency for Emacs...

Event Timeline

brandon created this task.Sun, Jan 12, 23:46
brandon closed this task as Resolved.Wed, Jan 15, 22:53
brandon claimed this task.

This problem has gone away. Its not clear why.