Page MenuHomePureOS Tracker

update-command-not-found crashing in PureOS
Closed, InvalidPublic

Description

Customer e-mailed in saying update-command-not-found keeps crashing on their laptop.

Could not find the database of available applications, run
update-command-not-found as root to fix this
Sorry, command-not-found has crashed! Please file a bug report at:
http://www.debian.org/Bugs/Reporting
Please include the following information with the report:

command-not-found version: 0.3
Python version: 3.7.3 final 0
Distributor ID:    PureOS
Description:    PureOS
Release:    9.0
Codename:    amber
Exception information:

local variable 'cnf' referenced before assignment
Traceback (most recent call last):
   File "/usr/share/command-not-found/CommandNotFound/util.py", line
23, in crash_guard
     callback()
   File "/usr/lib/command-not-found", line 93, in main
     if not cnf.advise(args[0], options.ignore_installed) and not
options.no_failure_msg:
UnboundLocalError: local variable 'cnf' referenced before assignment

I get the same output when running a command that isn't setup on my laptop.

Please see about updating/fixing update-command-not-found .

Event Timeline

Wayne added a subscriber: Wayne.Fri, Nov 29, 04:13

This looks like a duplicate of tracker item. You might wish to check there, but there has been no resolution that I have seen. I too uninstalled it.

Thanks Wayne. Closing this one.

richard.kolla changed the task status from Open to Incomplete.Fri, Nov 29, 07:17
richard.kolla closed this task as Invalid.
richard.kolla triaged this task as Low priority.