Page MenuHomePureOS Tracker

Yubikey 4 static password, random keystrokes
Closed, WontfixPublic

Description

I use a Yubikey 4 with a static password to login to full disk encryption at boot. On my other computers, it works fine. But on the Librem 15 version 4, it does not consistently reproduce the same characters. The resulting characters randomly alternate between the expected characters and their corresponding SHIFT characters, for example characters a or A, or characters 5 or %. I confirmed in gedit. Just to confirm, I tried in all four USB ports of the laptop, I rebooted a few times and tried again, and it's the same inconsistency.

Event Timeline

t1b0 created this task.Fri, Nov 22, 13:41

Hi,

Thanks for reporting this issue.

You mention testing in other operating systems - which ones did you try?
Knowing which ones you've tried which systems work may help narrow down possible places to look for the cause of this.

t1b0 added a comment.Sun, Nov 24, 16:01

@jonas.smedegaard

My Yubikey has worked on:

  • Windows 10 laptop
  • Ubuntu 18.04 on System76 PC
  • Ubuntu 18.04 on Chromebook

Something strange just happened, and I don't understand how to explain it. After I plugged the Yubikey in the Windows laptop just now, it said "configuring your Yubikey", then back to my Librem, now the characters are consistent. I can't reproduce the inconsistency anymore, so it will be hard to troubleshoot. I will cancel this ticket.

t1b0 closed this task as Wontfix.Sun, Nov 24, 16:03
t1b0 claimed this task.
t1b0 updated the task description. (Show Details)

can't reproduce, cancelling ticket

The Yubikey has a USB Keyboard driver included on the key. This may affect the way it appears in different operating systems.