Page MenuHomePureOS Tracker

Update GNOME Software deps for the Librem 5
Open, Needs TriagePublic

Description

The Librem 5 ships with GNOME Software 3.34, to work properly and to display the apps from the Debian repos, we need an up-to-date version of both appstream-glib and libxmlb. Luckily both versions are available in Debian, we could cherrypick them.

On the Librem 5devkit, we ship them as sloppy builds, but let's have proper Debian packages instead as now these versions are available upstream.

I'm not sure in which Debian version they are, likely experimental, but here are the versions I know work:

  • appstream-glib 0.7.16
  • libxmlb 0.1.13

Event Timeline