Package Lollypop
Closed, ResolvedPublic

Description

We need to ship the Lollypop music player for the Librem 5, but it is not in Debian yet as its RFP is stuck since years: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=847937.

It would be great to have it in Debian so we can have it on the Librem 5 somehow.

gusnan added a subscriber: gusnan.Aug 2 2019, 4:58 PM

I have started looking at packaging this - I can provide a packaging repo containing my work soon. I guess packaging in Debian is the preferred way, and not in pureos. I'll take ownership of that RFP.

I have made an upload - I will push the git repo to the Debian Python Applications Packaging team on salsa when I can see that it is in the NEW queue.

gusnan added a comment.Aug 6 2019, 4:10 PM

And there you have it:

https://salsa.debian.org/python-team/applications/lollypop

The question now is how long it will be stuck in the New queue... (It's quite long at this moment).

jeremiah.foster triaged this task as "Normal" priority.Aug 7 2019, 5:53 PM
jeremiah.foster added a subscriber: jeremiah.foster.

Thank you @gusnan! Tack sä hemskt mycket! I'm just going to clone your package from git and build it for PureOS (I'm in the keyring so it's easier for me.) I'll point to it when it's uploaded to PureOS.

@gusnan I ran lintian over the lollypop build because I know that our ftpmaster will do that too. It produced a warning and a bit of info. I think the warning might be worth addressing;

W: lollypop: binary-without-manpage usr/bin/lollypop
I: lollypop: desktop-entry-lacks-keywords-entry usr/share/application/org.gnome.Lollypop.desktop

gusnan added a comment.Aug 9 2019, 7:43 PM

@jeremiah.foster I'll take care of it.

gusnan added a comment.Aug 9 2019, 9:48 PM

@jeremiah.foster I have now pushed another commit to salsa, containing a man-page. I'll provide it to upstream in a pull request too.

I submitted this to PureOS.

Thanks a lot gusnan! :D

getting this error when running it

Traceback (most recent call last):

File "/usr/lib/python3.7/site-packages/lollypop/application.py", line 218, in do_startup
  self.__window = Window()
File "/usr/lib/python3.7/site-packages/lollypop/window.py", line 51, in __init__
  self.__setup_content()
File "/usr/lib/python3.7/site-packages/lollypop/window.py", line 247, in __setup_content
  self.__toolbar = Toolbar(self)
File "/usr/lib/python3.7/site-packages/lollypop/toolbar.py", line 41, in __init__
  self.__toolbar_end = ToolbarEnd()
File "/usr/lib/python3.7/site-packages/lollypop/toolbar_end.py", line 91, in __init__
  self.__next_popover = NextPopover()
File "/usr/lib/python3.7/site-packages/lollypop/pop_next.py", line 36, in __init__
  builder.add_from_resource("/org/gnome/Lollypop/NextPopover.ui")

gi.repository.GLib.Error: g-resource-error-quark: The resource at “/org/gnome/Lollypop/NextPopover.ui” does not exist (0)

@user22492 Is this with the PureOS package?

How did you install the package that gives you this error? It looks like an old version of Lollypop - The one I have packaged doesn't install to site_packages but to dist_packages, and also doesn't even contain the file pop_next.py.

I cannot reproduce here with lollypop 1.1.4.11

jeremiah.foster closed this task as "Resolved".Aug 16 2019, 2:07 PM
jeremiah.foster claimed this task.

I'm closing this issue since Lollypop is now packaged for PureOS. I'm going to work with others on the team to see about integrating into CI/CD for L5. If there are any issues with the PureOS version of Lollypop for the Librem laptops, please open another issue. Thanks!

Add Comment