Page MenuHomePureOS Tracker

ClamTK and ClamAV can not be installed due a conflict between some programs and libcurl3
Closed, ResolvedPublic

Description

It happens when i am going to install ClamTK. I can not uninstall these packages because i need them. I would be great if you modificate package files to solve conflicts with the library (other path to install, etc) and then, you could disable the conflict list in the package.

echedey@echedey-500-500ns:~$ sudo apt-get install clamtk
[sudo] password for echedey: 
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 clamtk : Depende: clamav (>= 0.95) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
[1]+  Salida 1                nohup syncthing
echedey@echedey-500-500ns:~$ sudo apt-get install clamtk clamav
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 clamav : Depende: libcurl3 (>= 7.16.2) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
echedey@echedey-500-500ns:~$ sudo apt-get install clamtk clamav libcurl3
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
  gir1.2-appstream-1.0 libluajit-5.1-2 libluajit-5.1-common libminiupnpc17
  libnatpmp1 libopenbabel4v5 librhash0 python-apt transmission-common
Utilice «sudo apt autoremove» para eliminarlos.
Se instalarán los siguientes paquetes adicionales:
  clamav-base clamav-freshclam libclamav7 libcommon-sense-perl libjson-perl
  libjson-xs-perl libtext-csv-perl libtext-csv-xs-perl libtfm1
  libtypes-serialiser-perl
Paquetes sugeridos:
  clamav-docs clamtk-gnome
Los siguientes paquetes se ELIMINARÁN:
  cmake curl isenkram-cli libcurl4 php-curl php7.2-curl trafficserver
  transmission-gtk
Se instalarán los siguientes paquetes NUEVOS:
  clamav clamav-base clamav-freshclam clamtk libclamav7 libcommon-sense-perl
  libcurl3 libjson-perl libjson-xs-perl libtext-csv-perl libtext-csv-xs-perl
  libtfm1 libtypes-serialiser-perl
0 actualizados, 13 nuevos se instalarán, 8 para eliminar y 17 no actualizados.
Se necesita descargar 442 kB/2.093 kB de archivos.
Se liberarán 31,3 MB después de esta operación.
¿Desea continuar? [S/n]

PD: Sorry for the language.

Event Timeline

EchedeyLR created this object with edit policy "All Users".
EchedeyLR updated the task description. (Show Details)

New clamav release 0.100.1+dfsg-1pureos1 uploaded just now should fix this issue (when it enters green in ~10 days).

Thanks for reporting!

EchedeyLR closed this task as Resolved.Aug 10 2018, 11:32

No problem to install it on last version.