Blank screen after failed, then "successful" login
Closed, ResolvedPublic

Description

Librem 13v3 on PureOS with updates through 7/2

I use long passwords, so sometimes I mistype and have to go through the login again. Here is new behavior that I noticed recently:

  1. System boots normally to login screen after decryption.
  2. I enter the wrong password for my user ID.
  3. Re-prompted for password.
  4. I enter the correct password.
  5. Screen goes blank appearing to try to display the Gnome desktop.

I write appearing because what I end with is a mouse cursor and a blank screen. If I hit the Menu button (stacked icon) on the keyboard, I get a balloon with Copy, Paste, Show text. That leads me to think the system is still expecting a password.

Ctrl+Alt+F2 also yields a blank screen, though I do see a cursor on the upper left-hand side. Fortunately Ctrl+Alt+F3 worked to get a log.

I have done “dpkg --configure -a”. The tracker item Gnome login screen does not start does not seem applicable; I do not think I am really logged in.

I have to power off to recover, though there may be some key sequence that could restore the screen of which I am unaware. (Interestingly, though my power switch is configured to power off, it actually suspends unless I hold it down for a long time. This also leads me to think I am not actually logged in.)

This only happens when I error, so I may have had this problem longer than I think, but I will guess this started in the last two weeks. This is reproducible every time. I do not have problems when I type the correct password the first time, so this is a minor issue.

The attached log, created with 'journalctl -b', is with steps 1-5, plus switching to a terminal (Ctrl+Alt+F3) and creating the log. If you need others, please let me know.

journal.log

ADDED: As an afterthought, I tried locking my system and going through the "wrong password, right password" sequence. This worked as expected.

Wayne created this task.Jul 3 2018, 12:01 PM
Wayne edited the task description. (Show Details)Jul 3 2018, 12:58 PM
Wayne added a comment.Jul 26 2018, 5:57 PM

FYI. This is not fixed by any updates this month, including the Linux 4.17.0-1 image update on 7/26.

Wayne closed this task as "Resolved".Aug 26 2018, 12:22 PM
Wayne claimed this task.

This appears to work with the new kernel image and today's (8/26) update.

Add Comment