Page MenuHomePureOS Tracker

Some emoji too big, others in black-and-white
Closed, WontfixPublic

Description

Steps to reproduce:

What should happen:

  • Most emoji render in colour
  • Missing emoji appear as "tofu"

What happens instead:

  • some emoji render in color as expected
  • some emoji render in black and white (rather than color)
  • some emoji render in color, but are far too big
  • missing emoji appear as tofu

Notes:

  • Related link: https://unix.stackexchange.com/questions/444141 (suggestion there is that this issue may be related to fontconfig)
  • This persists after running fc-cache -f -v
  • If I copy and paste the text into Text Editor, the emoji appear as expected:

Event Timeline

d3vid created this task.May 17 2018, 02:12
d3vid updated the task description. (Show Details)May 17 2018, 02:43
d3vid updated the task description. (Show Details)May 17 2018, 02:49
d3vid updated the task description. (Show Details)May 17 2018, 06:11
d3vid updated the task description. (Show Details)May 17 2018, 06:18
d3vid added a comment.EditedJul 20 2018, 05:27

Workaround:

Now the Noto emoji symbols do not appear, because the Twemoji TTF has equal emoji coverage. If Noto coverage improves and your Noto package gets updated, the problem will recur for any new emoji symbols. At that point you will have to wait for a new Twemoji/eosrei release and reapply the workaround.

If your PureBrowser package gets updated, it may re-add EmojiOneMozilla.ttf, in which case you will have to delete it again. It may remove TwitterColorEmoji-SVGinOT.ttf, in which case you will have to re-add it.

jonas.smedegaard triaged this task as Normal priority.Thu, May 27, 06:34
jonas.smedegaard closed this task as Wontfix.Fri, May 28, 00:59
jonas.smedegaard claimed this task.
jonas.smedegaard added a subscriber: jonas.smedegaard.

Purism has abandoned the development of PureBrowser for some time now.

PureOS now recommends using GNOME Web (a.k.a. Epiphany), and also provides Firefox ESR.