First post-install upgrade triggers "cryptsetup: WARNING: found more than one resume device candidate"
Closed, InvalidPublic

Description

Steps to reproduce:

  • Install PureOS from latest ISO
  • sudo apt update
  • sudo apt upgrade

What should happen:

  • Packages are updated

What happens instead:

  • Packages are updated, and the following warning appears:
Processing triggers for initramfs-tools (0.130pureos2) ...
update-initramfs: Generating /boot/initrd.img-4.15.0-2-amd64
WARNING: Setting CRYPTSETUP in /etc/initramfs-tools/initramfs.conf is deprecated and will stop working in the future. Use /etc/cryptsetup-initramfs/conf-hook instead.
cryptsetup: WARNING: found more than one resume device candidate:
                     luks-11111111-1111-1111-1111-111111111111
                     luks-22222222-2222-2222-2222-222222222222
cryptsetup: WARNING: target luks-22222222-2222-2222-2222-222222222222
has a random key, skipped
I: The initramfs will attempt to resume from /dev/dm-1
I: (UUID=33333333-3333-3333-3333-333333333333)
I: Set the RESUME variable to override this.

Rebooting after this succeeds, as do further upgrades (although I'm not sure that I've received another upgrade to initramfs-tools since then.)

d3vid created this task.Apr 23 2018, 3:57 PM

Seems an issue for @mak.

mak changed the task status from "Open" to "Incomplete".Aug 26 2018, 2:36 AM

Is this still an issue? Cryptsetup has been upgraded multiple times since this issue was reported...

I don't have a straightforward way of reproducing this. Let me see if I can find someone who can...

d3vid closed this task as "Invalid".Nov 22 2018, 5:03 PM

I've closed this as invalid since I can't reproduce it.

Add Comment