[tablet] Wacom tablet crash configuration panel
Closed, ResolvedPublic

Description

Hi,

How to reproduce
On a updated system from Sunday 3 September, connect a Wacom tablet (Intuos4Medium here) via USB and try to configure it via the configuration panel ( a dedicated icon Wacom/Tablet exists on it ).

Result
It is impossible to configure the tablet. Nothing happen. The icon refuse to launch.
Trying to launch the configuration system via terminal get this output:

Wacom: crash, "schema 'org.gnome.settings-daemon.peripherals.wacom' is not installed"

Information
I wanted to acknowledge PureOS team of this issue, even if it's an upstream one.
It's in Debian-testing since more than 10 days (a half pushed GNOME desktop environment, conflict 3.22/3.24 as far as I understand).
It really block my adoption of PureOS: not your fault, but adopting Debian-testing is too dangerous for professional artist living with a tablet.
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=872875

Workaround
Downgrading the gnome-settings-daemon to 3.22 doesn't work for my tablet model.
It improves the situation: I can now open the configuration panel; but no settings apply to the tablet.
Also, the app "Software" become crazy after a downgrade and prompt user for updating all the time...

wget http://ftp.uk.debian.org/debian/pool/main/g/gnome-settings-daemon/gnome-settings-daemon_3.22.2-2%2Bdeb9u2_amd64.deb
sudo dpkg -i gnome-settings-daemon_3.22.2-2+deb9u2_amd64.deb

Configuring manually the tablet via xsetwacom command-line could work, but then it's a fight against the desktop-environment to reapply the script all the time:
Screenlock reset the the default config, no way in GNOME to add a startup bash script, etc...

This is most probably Wayland issue, it will be solved in updates this month.

Ok, I'll retest in a month, it will probably work because meanwhile, for professional needs (I'll teach Krita course in Paris in a week), I installed a Fedora 26 and didn't ran into this issues on same hardware.

Good to know, we will maybe need to check some diff in Fedora packages but I assume that it is only matter of updated package in this case.

it is only matter of updated package in this case.

Thanks and ok; we will see. I'll keep retesting and I'll post update here.
Meawhile you can close this bug report with a sort of WONTFIX/UPSTREAM flag ( I don't know Phabricator too much ) , same can be done for the color-calibration bug as it is dependent of the gnome-settings and settings-daemon.

jeff added a subscriber: jeff.Oct 3 2017, 11:54 PM

@davidrevoy is this bug still existing?

@zlatan.todoric : It was fixed upstream on end October. Sorry for not reporting it back here and thanks for the reminder. This thread can be closed.

zlatan.todoric closed this task as "Resolved".Jan 11 2018, 3:28 PM
zlatan.todoric claimed this task.

Add Comment