Page MenuHomePureOS Tracker

Failed to connect to lvmetad
Closed, ResolvedPublic


After using the software bleachbit to clean up the system, after restarting the librem 13 v2, and after successfully adding my pwd to decrypt the hard drive, I get this error ;
firmware : failed to load i915/sk1_dmc_ver 1-26
Failed to connect to lvmetad Failling back to device scanning
Volume Group “crypt” not found

2 logical volume(s) in volume group “crypt” now active
/dev/mapper/crypt-root : clean,…

From there I’m totally locked, the all thing is down :s

apparently a similar error occured upgrading the OS :

as a newbie, I dont know how to manage this properly and easily :s

when I run the recovery mode, after successfully putting my pwd to uncrypt the drive, I have at some line : cannot open access to console, the root account is locked

Event Timeline

QiZhi created this task.Aug 30 2017, 10:04

what OS are you using? Do you get to initramfs line or rescue line? what is the output of ls command?

i'm using PureOs.
I don't have anything I simply locked there whith that information after successfully enter my pwd to decrypt the drive

can you post a screenshot of the issue?

I left the Librem to an IT repair store, it's been a week and the guy have found nothing to solve the problem yet :s

I personnally just find this :

Hopefully that will help...

mak added a subscriber: mak.Sep 7 2017, 10:48

Do not use Bleachbit - ever. See
I can look into this later this week, to maybe figure out what's wrong, but if you can, reinstalling the OS is probably the best idea.

Thanks for your help, highly appreciated !!!
Newbie with linux, my question may seem very stupid, but if I'm reinstalling PureOs do I keep my home directory folder datas safe (like with Mac system) or do they get 'crashed' (like with windows system) ?

mak added a comment.Sep 7 2017, 13:29

Since you apparently are using a fully encrypted disk, it would mean that any data would be lost when you reinstall.

Can you try to make another screenshot of the error message? The first one is hardly readable.

If you have a backup of your data, or if you can rescue the data via a live-cd, the fastest way to get back to a working system is via a reinstallation. Otherwise, if I have more information on this, we can maybe figure out what the actual problem is. (And apparently, dropping bleachbit from the repos makes sense ^^)

much better :) sorry

mak lowered the priority of this task from High to Low.Sep 8 2017, 19:01

This actually looks like the decryption worked okay and LVM is good.
Did you get this message *after* you entered your password to decrypt the device?

In order to figure out what's going on I will need more logs, to see what broke.
If you did get the decryption prompt, you can try booting with Bash as init:

  1. Go into the GRUB bootloader by holding down the shift key while booting (if it doesn't show automatically already)
  2. Select the appropriate boot entry (the first one in this case) in the GRUB menu and press e to edit the line.
  3. Select the kernel line and press e again to edit it.
  4. Append init=/bin/bash at the end of line.
  5. Press Ctrl-X to boot. After booting you will be at the bash prompt.
  6. Your root file system is mounted as readonly now, so remount it as read/write mount -n -o remount,rw /

With that in place, you can mount a USB pendrive (plug it in first), then:

  1. Figure out the device node of the USB drive with fdisk -l (usually /dev/sdb)
  2. Mount it: cd /tmp && mkdir usbdrive && mount /dev/sdb usbdrive
  3. Copy the logfiles: cp -r /var/log/* /tmp/usbdrive/

The logs contain sensitive data, so if you manage to get that far, you should send them to me in a private email. Do you remember what exactly you did with bleachbit? Did you remove any packages? In case any packages were removed, you can reinstall them in the shell via apt install pureos-desktop.
In any case, if you can get to the shell prompt as described above, you can rescue your data relatively easily and then fix this issue with a reinstallation.

QiZhi added a comment.EditedSep 9 2017, 01:14

I did not remove any package using bleachbit.

Ok I've managed a way out : I simply boot using a Live Kali Linux distribution, there I'm able to access to my Home Directory and decrypt it; then simply copying the files...
I'm now reinstalling PureOs.

PS : I got the log files with your method.

Thanks a lot for your help.

QiZhi closed this task as Resolved.Oct 2 2017, 06:14
QiZhi claimed this task.


I've managed a way out : running a KaliLinux Live on USb, I could access to my hard drive and decrypt it without a problem with the password.

From there, I simply did a back up and then reinstall the all system.
It is now ok.

Thanks for your help.